We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Wifi Connection problems

  • I am having a strange issue with WiFi connections.

    I have the latest update installed, performed manually via usb stick and serial connection.

    The question I now have is running wifi setup will not connect to my network at work or my android cell phone hotspot. I even tried to connect to my wireless router at home and a no go.

    I had a colleague take it home and try it out and it worked fine on his network, as well as on his cell phone. He came back to work and tried on the work network and no go.

    I even brought in a backup wireless router from home and that one does not work either.

    Phone devices are:
    Android Droid Maxx (does not work)
    Nexus 6 (works)

    Routers tried:
    Linksys Wireless-G 2.4GHZ WRT54G (does not work)
    Linksys WRT1900AC (works)
    TP-Link TL-WR1043ND (does not work)

    All routers/phones are setup with WPA AES, able to see all routers but only 2 will connect.

    Anyone have any clues as to why some work and some don't even with similar configurations?



  • @Shannon-Peterson The driver seems really picky about what it wants to work with, like e.g. very long passwords seem to cause issues, various kinds of special characters in the password or the wireless network's SSID seem to cause issues, the WiFi-network's channel may cause issues and so on. Basically, I would suggest trying to set the SSID and password to something 8-characters long or so, with only letters, no dash, exclamation mark or anything, encryption-type to WPA2-AES, WiFi-channel 9 to or lower, and if it works with that, then testing one-by-one changing the settings back to what they were and seeing which setting it is that breaks the connection.

  • Tried everything with nothing working on those routers having the issues.

    Kind of pointless to be calling this thing a IoT device if it is this dang hard to link to wifi devices for communications one would think. I would presume on release it would have been close to 100% wifi compliant for about any wifi network in the world.

    Loosing hope here šŸ˜ž

  • Have you tried setting up the wifi via the command line? I had trouble getting my Omega 2 to connect to my Apple Time Capsule using the GUI, but configuring via the CLI worked fine.

  • I have tried the web interface, the command line wifisetup command as well as commandline options. I have even tried to manually configure the network and wireless files manually in /etc/config.

    But at the moment it still looks like I have to purchase special hardware to get this working as nothing I own will connect the with the device.

    I have tried WEP, WPA, WPA2PSK with all the passwords simple as well as clear simple SSID's. My next step is to try open connections I suppose but that is not a real solution to get a device connection to the network, it is more of a last ditch effort.

  • I had an issue that turned out to be signal strength. The chip antenna was good enough to detect my router but not good enough to get a reliable signal to it. It sounds like some of your cases include being right next to the router (cell phone connection sharing). But, this might be part of your problem in other cases.

  • @Benjamin-Stoltz

    Just tried with units farther away from each other across a small room and even farther. It still is not pairing with the wifi units and still works with the ones that work.

    I seriously think there needs to be serious improvements to the wifi connectivity libraries or hardware.

    I am thinking I will have to chalk this up as a no go for now as a work alternative to building prototype units for IoT at work. Probably buy a version of the router that is noted as working with for home and play more with it there but it definitely is not to any stage near wanting to use or prototype with in the industry yet.

    Something such as a wifi connection on a IoT device should be the easiest thing to setup and configure on about any wifi network. Can you imagine deploying it and having it only work on a handful of specific routers and networks the returns would be tremendous and your IoT product reputation would be destroyed before you even get started.

  • @Shannon-Peterson
    Must be true that Linksys Wireless-G 2.4GHZ WRT54G is pretty old or anything over say 7 years old which need to upgrade or update to today standard, I had one and got fed up and so I go upgrade to Belkin one. I have now got EE wifi and that works mostly, with the b149 seem ok.

  • @David-Wickenden

    Ya the WRT54G are old but my cell phone hotspot on DROID MAXX is not so old neither is the TP-LINK router. One can't expect everyone to buy a new cheap IoT device to also purchase brand new network routers (expensive or much more expensive devices) etc to just get the cheap IoT solution to work. That would be rediculous thinking.

    It is extremely to sensitive to working with specific devices to even want to consider using at the moment for industrial purposes, an industry would want to know the IoT devices they sell connect to probably close to 98-99% of the devices out there or else they would spend so much time in support cases tweaking to get the key part working the I in IoT.

    As stated above I will look at getting a device that works at home to play with these chips I am just thinking this is not a viable solution at work to do any design work there and think we will move on to testing other options. We can always come back in 6 months to a year and see where things sit then with this device. The pro behind this product was the 5-9usd linux based chip for IoT, just design the boards to plug the chip into after prototyping using the nifty prototyping expansion boards and be set.

  • I was able to get another used router working a Linksys Wireless-G 2.4GHZ WRT54GL.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.