We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

gps receiver not locking

  • Well, i decided to take a chance for Ā£11 and have ordered an active antenna with 3m lead and an SMA to u.FL adaptor.

    Was going to be part of my half formed idea anyway so lets see how it goes.

  • worked by connecting to 2 satellites while sky was totally clear, as soon as any cloud cover appeared stopped, i'm assuming the antenna as supplied is next to useless. bit of a shame really.

    if anyone is thinking of buying this device i'd suggest thinking twice..


  • @Ian-Marchant hi ian, to save me reinventing the wheel, can you give me details of what you have ordered and where from? Ā£11 sounds doable so will follow suit..


  • Hi,

    The antenna is


    and the u.FL to SMA adaptor is

    u.FL - SMA Female

    More news when it arrives šŸ™‚

  • I would put in a trouble ticket and get the GPS units replaced. Mine will connect inside my house and give back readings that match the GPS on my phone (+/- 3m).

  • I logged a ticket but so far it is sitting at processing with no reply from anyone.

    The active antenna arrived and at present with it sitting on the desk in the office (well away from any windows) i am seeing between 9 and 12 satellites and it has a fix.

    Will try it on the omega shortly.

  • Hmm

    Well same problem here, on the Omega2+ I am not able to get a gps fix at all doesnt matter where i put the gps expansion... Same problem with the program under windows.

    So also wondering if I might have a faulty gps expansion as well... Had to go through hoops and hurdles to get the Omega2+ going as, bad soldering which had to be removed but now that is at least working.


  • I think it may be an antenna issue. The external antenna has worked perfectly now and gives a good solid fix

  • @Ian-Marchant Yes agreed it might very well be a faulty antenna or just the antenna being quite small. I don't have an external antenna lying around unfortunately but will try experiment with one, once I find one šŸ˜‰ Ow well experimentation can be fun ! šŸ˜‰


  • had re reply to my ticket this morning which may help a little.

    "There might be a design problem on GPS. We are sorry for that. It is not defective issue. There is a capacitor add wrongly on GPS. But due to the short of resources we are unable to fix that before campaign. The problem is harder than we expected. We will try our best to solve it thanks to your support. If there is new GPS version. We will let backers know as soon as possible. There is a way to solve that. Start from Antenna connector to the USB header, the second yellow component is the wrong capacitor. Right after the white inductor. Try dis-solder the capacitor, and you can get GPS fixed."

  • From this photo however, I am not 100% sure which part i am supposed to use?


  • @Ian-Marchant That's interesting I think I know which component is meant but desoldering an SMD type capacitor is not something I would love to do without the proper tools ie soldering equipment... If they promise me on my ticket, which I opened for this isse(no updates what so ever till now...), to send me a replacement I might just go for it. If I do I will let you know the results.


  • @Ian-Marchant Maybe someone from @administrators can put a picture with a circle around the right capacitor on here, I also asked this on my running ticket.

    your right the description in that message is somewhat unclear šŸ˜‰


  • I also have the same issue being unable to lock onto a satellite both indoors and outdoors.

  • From the ticket reply I suspect there are lots of users with GPS devices that need to be returned to sender.
    Could just be a small bad batch but I'm guessing at a large batch as they don't make these in one's and two's.

  • Personally after reading the description several times i believe its the red encirceld capacitor which needs to be desoldered.. might just give it a go regardless since the expansion is useless currently anyway...


    0_1486052141470_gps expansion.jpg

  • @Leo-de-Blaauw I would concur but the ticket is far from clear.

    I'm gobsmacked that a supplier even suggests such a fix without first acknowledging they are financially liable for a replacement if the end user is unable to do the suppliers remedial work for them. This includes messing around with the wrong resistor because their instructions are ambiguous.

  • @Costas-Costas true, but in their defence i had a soldering bridge on my omega2+ they have promised to send me a replacement on my ticket for that issue. So went ahead and fixed it and it is working fine now. Replacement not yet here though..

  • I have the same issue. Anybody tried to unsolder the cap yet?

  • I am waiting for a definite response on my support ticket. Will post update when I get one.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.