We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

[workaround] Omega2+ "wifimanager" command never completes

  • After doing a "factory reset" on my Omega2+ it boots up nicely and its AP shows up. But if I connect to it, all I get is an "Index of /console/" page in the web browser. Thinking I just need to oupgrade, I thought I'd use the commands "wifisetup" and then "wifimanager" to connect to the internet. After running multiple experiments, here's where I ended up.

    The "wifisetup" command looks like it works okay. It scans for and reports the available Wifi networks, and lets me choose the one I want. After doing that, if I do a "wifisetup list" command, I see a JSON structure showing the AP I chose. It's an open network (no security) with a simple SSID -- nine letters, all lowercase except for the first one. But if I then run the wifimanager command, it never completes -- the command prompt never comes back, though I can bring it back by typing ^C.

    If I reboot, the amber LED on Omega2+ never changes from flashing to steady.

    Anyone have an idea what might be going wrong, or what I should do next?

  • So, I found the -v option on the "wifimanager" command. When I use that, I see it doesn't get very far before the command hangs:

    root@Omega-6E87:/# wifimanager -v
    radio0 is up
    Reading configured networks in station mode...
    Scanning nearby networks...
    Current Count: 1
    Number of configured nets: 1

    Then nothing. Is it possible that the Omega2+ can't connect to an open Wifi AP?

  • The answer to my question is, "Yes, it can." It appears that my Omega2+ can't connect to an open Wifi AP.

    I first updated the firmware from a USB drive and tried again. Same story.

    Next I added WPA2PSK security to the Wifi AP I was trying to connect to (leaving the SSID and everything else unchanged). I tried configuring the Omega2+ again, and all was well. Who'd have thought.

  • Doesn't work for me though, my router is WPA2 protected, and it can't connect to it at all, it just hangs the same place yours do and then reboot the wifi connection, it seems.

  • @Leonardo-Motyczka Hmmm. Just to be sure, did you upgrade to the latest release of the firmware? My Omega2+ is running Ω-ware: 0.1.9 b150. I needed to upgrade using a USB flash drive as detailed above since I couldn't connect via Wifi.

    The only other thing I can think of is that people have reported the Omega2+ won't connect to Wifi APs whose SSID contains special characters. I don't think anyone's tracked down which characters don't work, though.

    Whatever the causes, it is certainly annoying and disheartening to open the box, turn it on and have essentially nothing work and get little or no feedback about what has gone wrong. I feel your pain. I hope you find a solution soon.

  • i have found that one method of getting rid of the "index of" screen is to re-install the console. do an opgk update and you will see it as a package.

  • I have the same problem with wifimanager failing for no apparent reason. I hate to say it, but from the shipping delays to the firmware bugs, the whole Onion Omega 2+ experiment has been a complete failure. It's completely unusable, and doesn't even perform the basic functions which were promised.

    We paid $5 for a computer, and got what we paid for. Too bad it's too small to use as a doorstop.

  • @WayneL I share your sentiments. I also have this wifimanager problem, my Omega 2+ is essentially useless. Disappointing in the extreme.

    Back to the 1st generation for me which has functioned flawlessly from opening the box.

  • @David-Ehnebuske said in [workaround] Omega2+ "wifimanager" command never completes:

    After doing a "factory reset" on my Omega2+ it boots up nicely and its AP shows up. But if I connect to it, all I get is an "Index of /console/" page in the web browser.

    After a factory reset if returns "Index of /console", You need to go to and follow the wizard.

Looks like your connection to Community was lost, please wait while we try to reconnect.