We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ unable to de-brick

  • "bad magic" means that the memory does not seem to contain the special value that indicates the start of an image in the expected location.

    Take a look at the log in this post


    Where someone else does an apparently succesful USB flashing; their process seems to complete in a ways yours did not (before the newly flashed system then goes on to crash; that outcome is not the useful part)

    At a level somewhat of guessing, any chance you have a different flash stick you could try?

    If you can get into uboot via the serial terminal for commands as well as output, you can try this:

    spi read 0x50000 64

    On a bootable system you would get back something beginning with

    27 5 19 56 which is the correct magic number.

    Interestingly if you try md 0xbc05000 you will probably not get the right values, even on a good system - that may be an address where flash gets "sort of" mapped for boot, but just accessing it won't necessarily get you bytes from flash.

  • When I read that portion I get 26 7f d7 63 99 3 4e 96... (trimmed because it is 100 long). I will dig up another thumb drive and give that a crack just in case this one has some issue.

  • I've tried 4 or 5 other USB keys and none of them power up when plugged in to the Mini Dock. The one that works is a 128GB Samsung one, the ones not working are various 4GB ones.

  • Hmm... for the 128 GB stick to have problems is not entirely surprising, actually it's a little surprising it works at all.

    That the 4 GB ones do not seem to work is more worrisome. What is the ultimate source of power?

  • Powered off my laptop via USB, laptop is a MacBook Pro (pre-USB-C)

  • @Chris-Watt - Chris, just read your post. Sorry to learn of your USB drive issues with the Mini Dock. Can I assume that you communicated from your Mac with the Mini Dock over a USB to serial connection? I'm curious when you bought your Mini Dock. I and others are having problems with the Mini Docks and the serial connection to Omega2, as described here and here. If your serial connection is working this could help us learn a bit more about why ours are not.

  • Hey @Ken-Conrad, the serial is working fine, it is flashing of the USB that is the issue on that dock, the issues on the Power Dock is that I can't get the serial (connected via the RX1/TX1 headers) to work at all.

  • @Chris-Watt said in Omega2+ unable to de-brick:

    the issues on the Power Dock is that I can't get the serial (connected via the RX1/TX1 headers) to work at all.

    Unless I'm mistaken, the Omega2 serial console is on the actual UART0, as opposed to UART2 where most other builds for this chip put it. I'm not aware of any that use UART1.

    What I can't tell you however is if the labels on your dock directly correspond to the UART numbering of the MT7688 itself.

  • This post is deleted!

  • @Chris-Watt Chris Watt, thanks. Did you recently receive this Mini Dock, or is it an older model from the first round of Omegas?

    Onion says you won't find serial or an connection to TX0, RX0 pins (UART0) on the Power Dock. Extension Dock, yes.

  • I received it recently but I think it shipped early Jan if I recall correctly.

    Ugh so basically there is no useful serial at all on the Power Dock? How frustrating. I can't try the Ethernet recovery option in that case. As it won't recognise any of my smaller thumb drives I am not sure what to try next to get it working! It never allowed connections when I got it either, I just wanna play with it!!

  • @Chris-Watt If you have a loose USB<>3v3 serial converter you should be able to either solder wires to the relevant header pin pads of the dock, or perhaps use a wire-wrap tool to directly tap out signals from the Omega2 pins before plugging it in.

    (Only once in childhood did I ever use a wire wrap tool on a proper wire wrap socket, but it's remained lifelong favorite for making semi-lasting connections to both 100-mil and 2mm headers)

  • @Chris-Watt Yes, sorry to bear that news but perhaps this will save you some time. It is explained here that the Power Dock doesn't have a UART, required for the USB to TTL serial communication. Chris Stratton is right, there are many good choices for inexpensive TTL UARTS to make this serial connection. I am using several with Omegas. I second Chris's advice - you can solder to the bottom side of the dock at TX0 and RX0 or wire wrap would work. Then any of these 3.3V UARTs will connect the Power Dock to your PC- the 'Swiss Arm Knife' FTDI board at Sparkfun or this particularly nice one at Tindie or the eBay stuff.

    Make sure that you have a good and not too long USB cable. Hopefully, the USB port will work with your thumb drives on the Power Dock.

  • Unfortunately soldering things to the board just isn't an option because I will definitely destroy things with my soldering skills.

    Really I need a solution to the flashing issue, if I can't use the ethernet option then I guess we need some alternative solution, so what are the ideas for that, short of soldering things? I really would prefer not to have to buy more things I have no room to store (tiny apartment problems!).

    I wish it had been pointed out at backing time, I would have got the expansion dock instead of the power dock and just not worried about the battery things I wanted to test.

    Basically: how do I recover the Omega2+ with the equipment I have already have? It's never worked and it starting to seem like it was a dud šŸ˜ž

  • @Chris-Watt my omega2's haven't arrived yet, but late this afternoon I tried loading the same omega firmware you tried into a different MT7688 board via the USB stick method, and it seemed to work fine. So while we're technically using different versions of U-Boot, the fact that it isn't working for you suggests a fair possibility of either a power supply problem or a problem with the specific USB sticks you are using. The fact that your smaller USB sticks aren't working is particularly notable, and I think merits more investigation of possible power issues, or else reformatting one and putting only the upgrade file on it.

  • @Chris-Stratton I'm not sure it is power but not really sure how I can test that? Currently it is drawing the power and serial via my MacBook Pro's USB port, if I power via a PSU I lose my serial connection to trigger the upgrade at all.

    I did also try ensuring only the upgrade file was on the stick, it's very odd that the 4GB isn't working but the 128GB is. I am going to try and find a major brand smaller stick, Sandisk or whatever, just in case the stick itself is oddly configured/designed.

    Any suggestions for how to test things are appreciated!

Looks like your connection to Community was lost, please wait while we try to reconnect.