We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

I bricked my Omega2 it can not boot any more

  • @WereCatf i do not know

  • @damir-djikic is this the same unit that you tried to use Serial via the ethernet pins (-Tx & -Rx) ? I offer this as a hypothesis - I haven't yet committed this error. If the unit now runs considerably warmer, did some part in the ethernet circuit get fried to a short condition?

    Also, I have seen many data errors and halts caused by connection problem(s) in the serial wires and/ or the power wires. The Omega2 are very picky about having sufficient power at 3.3- 3.6V

  • @Ken-Conrad first i used rx - and tx - but as it was mentined to me in another post those are not the pins for serial and it should be connected to serial rx 0 and tx0 .now i attached the correct pins and the unit that worked comunicate normally but the unit with the partition messed up is not comunicating and its overheating in 30 secods it goes to 35 degrees celsius there is nothing shorted out.

    both are in arduino dock and the serial communication is connected to the pins right of the omega2 and omega2 is powered over USB

  • @damir-djikic Your other Omega2 works with this set-up so you know that the UART and serial connection are good, also there is sufficient power for the Omega. Re-check the serial wire connections to this unit.

    Perhaps you corrupted some of the boot code in this unit by connecting a serial wire to the ethernet pin. Have tried a factory restore? That is, try resetting this unit to factory boot by pushing the reset button for more than 10 seconds.

    When the firmware was truly toasted in an Onion1 and with no serial or Wifi connection, we used an ethernet adapter to reflash like this. No one has reported yet how this works with the Omega2.

  • @Ken-Conrad
    I messed it up when I changed the partition size as I already said before, it has nothing to do with the connection because bot are in the Arduino dock and I am using the serial communication pins on the right side named Omega_Tx Omega_Rx ground, the units do not move and its possible that there is a connection or signal issue as I checked that 50 times already before posting here but anyway the unit do not move and do not react to anything send to it like the working one who move to the command window and you can write this one is stuck on showing only that text even after trying to factory restore it just pop up the same text even after holding the reset button for 30 seconds ( even after disconnecting the power and holding the reset button when I connect the power again, waiting 30 seconds and then releasing the button it does the same ) only the led blinks when I hold the reset button and as soon as I release it shows this screen

  • Until you get a cabling and power solution that works without serial errors, anything else is just wasting your time.

    Once you get clean output, post what that says, and people may be able to help you.

  • @Chris-Stratton To clarify, he wrote that he has another Omega2 that is working fine with the same power and serial connection.

    Thinking outside of the box .... Damir, when you look at available wifi (with your phone or tablet or whatever) do you see that this unit is broadcasting its SSID, that is "Omega-XXXX"? If yes, can you connect to the Omega? If so, then there is the possibility of using a SSH connection to reflash the firmware.

  • wifi is not booting i can not log in it's stuck at the screen that i posted

  • @damir-djikic

    Connecting over the USB power, what happens when you press reset for more than 10 seconds? Do you see it attempting to reflash and giving an error?

    Baud rate is 115200 for that console.

  • @damir-djikic said in I bricked my Omega2 it can not boot any more:

    wifi is not booting i can not log in it's stuck at the screen that i posted

    Again, until you solve the serial noise you are just wasting everyone's time - especially your own.

    • Without clean output you cannot determine what the actual stopping state is. The only clean output you posted was from a different device, not the problem device, so it is meaningless. Don't assume that power and serial solutions that work on one will work on the other, as you are in the domain of edge cases.

    • Without clean input you can't even know if there is an actual problem, or if noise inputs are being interpreted as a user request to halt the bootup and remain in u-boot.

Looks like your connection to Community was lost, please wait while we try to reconnect.