We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ can't connect to wifi network during initial setup

  • @Patrick-Nou You have the tools to update your Omega to working - the broken switch on the Expansion dock has been common problem, can you use a small needle to make it work? To copy the update .bin file from your computer to the Omega - If your "standalone CP2102" is a USB (serial) TTL UART, then you can use it to connect to the Omega on your Expansion dock with a serial connection.

    Copy the correct firmware .bin file to a thumb drive and put that in the USB port on the Expansion dock - if your Omega is a Plus then use the Omega2pvXX version, ie has the "p" etc. Use a terminal program like Putty to open a Console session then follow the steps for Manual firmware installation from the Alternate Step 1 on, works fine from the V1.5 firmware that usually ships on the new Omega2s. With Sysupgrade, do use the -n option which will overwrite your setup to the default, so hopefully your Wifi connection will then work.

  • @Ken-Conrad said in Omega2+ can't connect to wifi network during initial setup:

    @Patrick-Nou You have the tools to update your Omega to working - the broken switch on the Expansion dock has been common problem, can you use a small needle to make it work?

    Actually I already tried the needle, but ended up breaking the switch further, in the OFF position. I guess I will have to replace it, but the solder points are really tiny and I may well tear away the fragile printed circuit.

    From the updated instructions, should I understand nor the serial connection or the Ethernet Expenasion aren't required anymore? I do have access to the SSH server, even if the Omega isn't set up yet.

    What filesystem should the USB key be formetted in?

  • @Patrick-Nou Since you broke off the switch ... if I had that problem I would solder a short jumper wire to connect the two pads needed to close the circuit, then the unit will always be on when it has power. How are you connecting via SSH, with the CP2102? If you can access the Console then sysupgrade should work. The thumb drives I've used are formatted as they came from the vendor, I believe FAT32. For SD storage and RAM buffering Linux seems to prefer EXT4 but the format doesn't matter for this upgrade/ restore. Do use the -n option as noted above.

    After you complete the update if you still have Wifi problems, PVadam gave helpful connecting advice in this post today.

  • Well, I did just that, attempting the upgrade from a previously downloaded image on a USB drive formatted in FAT32. I took the b157 version, the latest when I attempted to make the Ω2+ work.

    However, I still can't make it connect to my router 😞
    I tried to create an unsecured, ad-hoc network on my computer for the Omega to connect to, but it also fails, and still doesn't give out any details.

    What would be next?

  • @Patrick-Nou said in Omega2+ can't connect to wifi network during initial setup:

    What would be next?

    Debugging !
    So, apparently it worked? The update?

    About your broken switch position ... against GPIO it is ON and away from GPIO is OFF.
    With what are you working now (dock)? Why did you not let this dock replace ?! RMA or at leas ask that they send you a good switch. Then you could ask a professional to fix that.

    Before turning off (take the power off) your device do you type in a halt command?

    It is really not easy, you ask for help. Then you do 10 Steps and ask what's next ... just give feedback and learn from the mistakes you do 😉

  • @Luciano-S. Actually I did contact the Onion team about the issue, they just acknowledged the problematic switch, but didn't offer an RMA. The switch is broken "away from the GPIO", i.e. OFF, and I can't move it back on. This Expansion Dock is essentially unusable until I replace the switch. I surely won't ask a professional to replace a 50cents part on a $15 board, that would cost me $50 at least (last time I asked for surface soldering service). This is a board to be tinkered with (somewhat), after all!

    Indeed, I managed to get the latest, b159 version on a USB key (FAT32), and install it manually. After that, it finally connected to the router. The Onion team has some great ideas, but should really test their firmware before shipping!

    For the record: I plugged the Ω2+ on the Battery Expansion Board, and didn't need the CP2102 standalone converter I had. Also, the USB key didn't mount automatically, but issuing command /etc/init.d/mountd restart mounted the key at /tmp/run/mountd/sda1, not /tmp/mounts (this directory doesn't exist)

    Buggy firmware + outdated documentation…

  • Well, bad news, it broke again. After I rebooted the newly installed b162 running on the Ω2+, the orange light flashed slowly for a few seconds as if booting normally, then turned off. It didn't broadcast any SSID.

    I then tried to put it on the small expansion board, same result.
    Tried pressing the reset button while turning it on, same result, no light and no SSID.

    What can I do now?

  • My Omegas are now gathering dust. They can't connect to the 802.11n network.

    How would I get a hint of what's not working?

  • I had this same problem with two of my new Omega 2+s last week. After lots of searching around and digging into config files...I tried power-cycling my router and then they both worked. Might be worth ruling that out first.

  • i think b162 was causing a lot of issues so it was withdrawn. unless i am looking at the wrong list, b160 is the current newest firmware. this is the list that i'm using,

  • @Patrick-Nou I had a similar problem trying to connect. It turned out to be the micro USB cable could not pass sufficient current to drive the Omega Tx. A better cable with higher DC cable spec did the trick. All good. Cheap is not always the best.

  • My similar problem turned out to be firmware version and config files. Updated to b160 and edited config files as specified here https://community.onion.io/post/13754 and it finally connected to my router for the first time since I got the board in February.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.