We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

I cannot see Omega 2 in the WiFi list

  • I don't have a dock so I use a breadboard psu. When I power the board I see the led light. It blinks couple of times but not as fast as mentioned in the documents.

    Then nothing happens. I cannot see it in the wifi list. I cannot connect, I cannot do anything. Btw board gets egg frying hot. It looks like a power issue but I only have this breadboard psu.

    What should I do?

  • @Gökhan-Türkeli said in I cannot see Omega 2 in the WiFi list:

    Btw board gets egg frying hot.

    It shouldn't get that hot. Measure with a multimeter how much current it is drawing, there is probably a short -- if it's drawing 300mA or more, then there definitely is a short somewhere and you need to carefully inspect the board. There are comparison-pictures in http://community.onion.io/topic/1332/close-up-pictures-of-working-omega2/2 from working Omega2's for this.

  • @WereCatf I measured the current as 0.94 amps. However every time when I try to measure board lost power and shut down. So I am not sure if I could measure it in a right way. I put the multimeter bars on the pins that I used the power the board.

    I checked the images on the link you shared but couldn't see anything different on my board.

  • @Gökhan-Türkeli said in I cannot see Omega 2 in the WiFi list:

    @WereCatf I measured the current as 0.94 amps.

    Just as I thought, then. There is a short and it quite possibly goes through the RF-shielding. You need to get a good magnifying-glass and pore over your Omega2 a second time. If you still cannot find the short it could be underneath the shielding, too, and then it's just best to open a support-ticket and tell Onion to send you a replacement.

  • @Gökhan-Türkeli said in I cannot see Omega 2 in the WiFi list:

    I don't have a dock so I use a breadboard psu. When I power the board I see the led light. It blinks couple of times but not as fast as mentioned in the documents.

    Then nothing happens. I cannot see it in the wifi list. I cannot connect, I cannot do anything. Btw board gets egg frying hot.

    I agree with @WereCatf, if that measurement is correct 0.94 amps, then the unit is drawing way too much power and you likely have some short on it's board. Any chance that there was a decimal error with the reading and it was .094A?

    A hot Omega can be a sign that the power supplied is way too high a VOLTAGE. Do measure the power supply output, even if you are connected to the 3V3 pins. Those power supplies can be off voltage or miss-labeled. In my experience the Omegas tolerate somewhat higher volts for a short time but will get very hot. Don't run the Omegas on more than 3.5 -3.6V if you care about the life of the unit.

    That said, much has been posted in this community about the quality of your connection TO the Omega - for a successful boot you need good quality wires and good quality connectors at the + and ground pins (also at the TX0 and RX0 if you are using a USB TTL UART board for serial communications). The problem with a poor connection is that it can cause a momentary sag in the voltage, then the Omega will halt the boot.

  • @Ken-Conrad @WereCatf

    I have more than 1 board. I tried the other one and the same result here. The only difference is the second one is not that hot when I power it. But still I cannot see it in the wireless list. So I cannot connect it.

    Btw I measured the same current. That might be related with my bad electronics knowledge.

  • @Gökhan-Türkeli First of all, check the VOLTAGE which you supply from PSU and position of voltage jumpers on PSU board. If you apply 5V to Omega - you may kill it in moment... Especially the RF part of Omega. The processor part may still work (led blink) but RF part is dead (that's why very hot). Also, voltage stabilizer IC on psu board may be hot.

  • @Gökhan-Türkeli After re-reading what you've said, I think you're connecting your multimeter in parallel, not series. You can't measure current by connecting it in parallel. I would recommend googling "how to measure current with multimeter" or looking it up on Youtube.

  • @Ken-Conrad
    I checked the voltage and it was 3.3.

    I connected the multimeter in serial and the currents are 162 and 172 mA

    So I still cannot understand why I cannot see it in the wireless networks list. I am using Ubuntu. I tried to check the wireless networks with my iPhone too but no luck.

  • @Gökhan-Türkeli Both these measurements are good news for you, 172 ma is normal operating current of the Omega2 and 3.3V is the spec voltage. No shorts there. Some of those breadboard power supplies don't supply sufficient current for the Omegas to successfully boot. You statement that the Omega was "egg frying hot" is paradoxical. Is that still the case when supplied 3.3V?

    How have you connected the power wires to the Omega, ie via what connectors? Are this connections secure, ie tight? In my experience the quality of these connections will make or break a complete boot. You are connected to Gnd and Vin?

    As to why you can't see a Wifi SSID .... at this point it would be much easier to troubleshoot if you have a serial connection, then you can watch the booting process in a Ubuntu Console. If and where the boot halts will suggest the problem. To do this you will need a 3.3V USB TTL UART board, these cost 2 - $8, depending on the source. The most reliable ones have SiliconLabs CP210X chips.

    Have you tried opening the Wifi available screen on your phone, powering the Omega then watching the phone screen, especially at 30 - 60 seconds into the boot to see if the SSID for your Omega appears for an instant or two?

  • @Ken-Conrad
    Yes unfortunately it is still the case. Board gets really hot.

    I used this breadboard psu. I used an usb cable to connect it to my computer. Then I used jumper wires between breadboard and Omega 2. I use Vin and Gnd pins. (-) for Gnd and (+) for Vin.

    I have this and this usb ttl uart boards. Are they right options?

    Yes, I tried it but I saw no change

  • @Gökhan-Türkeli That psu is rated to supply enough current. Problem with many jumper wires is that they are made for longer and larger pins, so the metal connector will be buried in the housing and may not effectively grab the Omega's short pins, in which case the Omega won't receive sufficient power and halts while booting. Very likely if a power connector is loose on the pin that is your problem!

    The USB TTL UARTs you have -
    the Smart Electronics PL2303 cable - my experience with those is 4.7V on the data lines!! this is likely since they don't list 3V3 on that page. Don't use that one without confirming a safe ~3.3V on the Tx, Rx and V lines.

    the "FTDI" board (at that price probably a copy) - may have to use an older driver to work, the current Prolific driver can refuse to work with counterfeit chips. Also, with the Prolific UARTs the Com port number can change from session to session - so always try to use the same USB port. For these and other reasons I like the SiLabs CP210X boards best. If the FTDI board does supply 500mA it can power your Omega, so try it first without the breadboard psu, with power from the 3V3 pin (not 5V pin ... ). If you decide to use the FTDI with the PSU then DO NOT connect a wire from the FTDI 3v3, that will fry your FTDI 😧 . Use both grounds but power only from the PSU. After you know that the UART is working with your computer, follow Onion's instructions from starting a Console/ terminal/ Putty session to see serial communications from the Omega.

    Apologize for so many details, lots can go awry.

  • @Gökhan-Türkeli
    I had problems running from an MB102 power module. Using relatively heavy gauge wire and short runs would probably help. Ultimately I built a small board with the LM1117 regulator and a tantalum bypass capacitor very close to the Omega power pins to get reliable operation.

    An easy way to test your USB to Serial converter is to wire the Tx and Rx pins together and verify that it can talk to itself. If this is the case then your device drivers are working. When connecting to an external serial device (the Omega) you may have to go Tx to Tx or you may have to go Tx to Rx between the device and USB serial. Labeling of USB to Serial devices is inconsistent.

    The Omega should be warm to the touch, but not so hot you can't keep a finger on it indefinitely. Current draw is a few hundred milliamps and fluctuates largely depending upon WiFi activity.

    I posted some power data in this thread link text

  • @Ken-Conrad

    Thank you for all the explanations. I removed the plastic part surrounding the pins and tried again. Still the same. Board is not that hot though.

    I think I will quit trying. All I wanted to do is to power the board. It shouldn't be that hard just because I didn't buy a dock. Thanks everyone for your helps.

  • I'd like to point out the "breadboard psu" link in the first post is a really bad one.
    It only has one (probably low capacitance and very cheap) capacitor in the circuit design.
    This is not good for AMS1117 (or friends) linear regulator.

    That regulator needs both input and output capacitor in a normal design.
    To use it for an Omega 2, these capcitors have to have high enough values (I suggest 220 uF.)

    For the bursty-power-demand device such as Omega 2,
    you really cannot cut corner in this front in power supply department.


Looks like your connection to Community was lost, please wait while we try to reconnect.