We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Mega Omega Software Release!

  • administrators

    Mega Omega Software Release

    Hey everyone, it looks like we've finally figured out how to transform coffee into code, meaning that version 0.0.5 of the Omega firmware is available with a whole bunch of goodies in tow! We've been listening to you guys and this release is all about the Expansions!

    Expansion Drivers

    The OLED Expansion has finally gotten some love and now has a driver called oled-exp! You can use the driver application to:

    • initialize the expansion
    • clear the display
    • turn it on and off (while preserving the image)
    • invert the display colours
    • dim the brightness
    • set the text cursor
    • write a message
    • enable horizontal or diagonal scrolling
    • display an image

    The best part is that all of the commands can be cascaded, so you can do multiple things in one call. Detailed documentation will be available tomorrow (December 4th), in the meantime, you can run oled-exp -h to see the usage instructions.

    Oh and one more thing, all of the driver functions used in the pwm-exp, relay-exp, and oled-exp are now in their own static C libraries, so anybody can use them in their C/C++ applications to directly control these three Expansions. Documentation for this is coming soon, most likely Saturday, December 5th. Info on using these libraries with Python shortly afterwards. We also have a C/C++ cross compilation project in the works so stay tuned!

    The Console

    It wouldn't be a real software update with some goodies being added to the console, so we proudly present the Ando N2 Console Release!

    Right off the bat, you'll notice the new apps to control the control the Servo, Relay, and OLED Expansions. Play around with them, we've tried to make them as intuitive as possible but don't be afraid to reach out if you have any questions.
    The GPIO control app now has a new mode where the pins are laid out to match the Expansion Dock. We figured it would be nice to have some options šŸ™‚

    Last but definitely not least, after using a few of the apps, you'll notice the new taskbar at the bottom of the screen, allowing you to quickly switch between any open apps. We would love to know what you think of it!

    Remember to clear your browser's cache in order to load the console updates!

    Expect a change-log for the Console to be published in the next couple of days

    The Onion Package Repo

    Another big thing is that the Onion Package Repo is now available and can be used in conjunction with opkg to install packages! Run opkg update after updating your firmware to configure the Omega to use this repo.

    Stay tuned, we'll be adding more packages to the repo and more info as well!


    We've also been able to make a nice opkg package for NodeJS v0.10.5. To install it after updating your firmware, run the following:

    opkg update
    opkg install nodejs

    This installation takes up about 3.1MB so it will fit on the on-board storage with no problems. We're also actively working on a package for NodeJS version 0.12.7 so keep your eyes peeled for that next week, just note that it will take up significantly more disk space than the currently available version.

    How to Upgrade

    To get the latest firmware, you can run oupgrade on the terminal, or you can use the Firmware Upgrade tool in the Console's settings app.

    I would recommend backing up all your files and doing a factory reset after the new firmware is installed, just to ensure all of the new files make it to your filesystem.

    Hold down the reset button for 10 seconds and release to initiate a Factory Reset.

    Happy hacking!

    Make sure to let us know if you find any issues or have any suggestions!

    I just want to take a moment to thank you guys for your patience and understanding. We're working super hard and doing the best we can, but unfortunately there's only so many hours in a day. Rest assured that we are completely commited to building the very best product we can for you! šŸ™‚

    Oh and on a personal note, ll is now automatically aliased to ls -al... this was driving me crazy!

  • @Lazar-Demin Whoopee!!!! Well done šŸ™‚

  • Awesome, thanks for the update and detailed change info! Looking forward to the documentation releases.

  • Good job on the update and on giving us NodeJS!
    āœØ āœØ āœØ

  • @Lazar-Demin Sorry to be picky after all the good work you people have done, but a couple of issues:

    1. I had previously done the pivot-overlay method from https://wiki.onion.io/Tutorials/Using-USB-Storage-as-Rootfs to give me more space - it was all working well.
      However, the upgrade to 0.0.5 b233 over wrote my /etc/config/fstab file and I no longer had access to /overlay on my USB
      I hand edited /etc/config/fstab back to reference /overlay but then my Omega believed it was still on the earlier version - so I will need to do the pivot-overlay procedure again šŸ˜ž Not a big deal since I wont' loose anything I can't recover, but perhaps this should be addressed in a future release.

    2. Which brings me to the second point - in looking for the details for https://wiki.onion.io/Tutorials/Using-USB-Storage-as-Rootfs to check that I was getting the details right I found the Omega Wiki doesn't seem to be available now - https://wiki.onion.io/Home gives a 502 Bad Gateway response

  • @Kit-Bishop Don't worry, that's what we are here for! We won't stop until all the issues have been addressed. šŸ™‚

    1. We will make sure we don't erase /etc/config/fstab file since some users will be using the pivot-overlay method.
    2. Wiki is back up. It was overloaded for some reason. Sorry about that!

  • @Boken-Lin Thanks šŸ™‚

    1. Good idea about preserving /etc/config/fstab
    2. Have seen Wiki is back up - thanks

  • @Boken-Lin All back to where I was - just had to reinstall a couple of opkg packages after redoing the pivot-overlay stuff

  • Sorry - me again šŸ˜ž with another problem.

    Accessing Editor in Console shows no files:
    This is with both Chrome and Firefox

  • @Kit-Bishop Just tested it on mine, the files loaded properly... Can you open up the Javascript console on your browser and let me know if you see any errors?

  • @Boken-Lin I'm not all that good with dealing with Javascript console, but think I may have found something from Chrome that may help:

    I wonder if this may be being caused by the last used path no longer existing. I don't remember whether or not I had deleted anything - it is possible. However, Editor should just use a default path in this case.

  • @Boken-Lin I've been doing a bit more digging and think the problem comes from here in onion-file-provider.html:
    Still digging to see if I can find the cause and/or fix it.

  • @Kit-Bishop Can you download this file: https://s3-us-west-2.amazonaws.com/onion-cdn/community/console/console.tar.gz. This is a tarball of the console that I am testing (and didn't find any error). you just need to delete the /www directory on your Omega, and replace it with the content of the tarball.

    Please let me know if it does anything. If not, I will take a look at it again tomorrow morning.

  • @Boken-Lin Using the tar.gz file you supplied, it all works šŸ™‚
    At this stage, I don't know why, though I did have to flush my browser data first.
    I then did a file comparison between what you sent me and what was originally in my /www directory (I preserved it first). The files were identical and when I restored my original /www files, everything worked.
    My suspicion at this stage is that my problem was originally caused by something that the browser had cached.
    I had to clear cache individually on Chrome and Firefox before each worked properly.

    If there is nothing that can be done for dealing with invalid information coming from cached browser data, it might be an idea to document somewhere that clearing of cached browser data might be needed.

    Anyway, thanks again for your advice and help. I'm all happy here šŸ™‚

  • After upgrading one on my omegas, i couldn't connect to it via ssh over my local network wifi. Upon inspecting /etc/config/wireless i discovered that wireless settings were changed and became a mixture of my previous config before upgrade and defaults. For example, SSID has changed to "Omega-xxxx", while the password was the same as i need for the local wifi connection. It became a mix of access point and standard client setup.

    I ended up resetting the device (10 second press on button on the expansion dock) and re-running wifisetup

  • @Andrei-Railean Thanks for letting us know! We will take a look at the upgrade process today and see what's the issue.

  • Ahh great update looks very slick and super stoked that the OLED expansion is working so well now. Just one quibble really and that is the repo mismatch still seems to be there:

    opkg install tinc
    Installing tinc (1.0.26-1) to root...
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/packages/tinc_1.0.26-1_ar71xx.ipk.
    Collected errors:

    • satisfy_dependencies_for: Cannot satisfy the following dependencies for tinc:
    • kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66) *
    • opkg_install_cmd: Cannot install package tinc.
      root@Omega-1956:~# uname -a
      Linux Omega-1956 3.18.23 #1 Fri Dec 4 02:26:08 UTC 2015 mips GNU/Linux

    Are there any new repo updates we can use?

    Great work otherwise. Thanks!

  • @t-nt It doesn't look like you are getting the Onion repo. I can't test till later today. @Lazar-Demin are the downloads supposed to automatically use the Onion repo, or is this something that needs to be configured?

  • @Chris-Ward The Onion repo currently has only part of the packages offered by the default OpenWRT repo. For stuff that's not on our repo, opkg still uses the default OpenWRT one. We are still in the process of compiling more packages over to our own repo.

  • Ah. Ok, that sounds like a good way to do it - gets the Onion repo partially out. Thanks.

Looks like your connection to Community was lost, please wait while we try to reconnect.