We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Mega Omega Software Release!

  • @Kit-Bishop Don't worry, that's what we are here for! We won't stop until all the issues have been addressed. šŸ™‚

    1. We will make sure we don't erase /etc/config/fstab file since some users will be using the pivot-overlay method.
    2. Wiki is back up. It was overloaded for some reason. Sorry about that!

  • @Boken-Lin Thanks šŸ™‚

    1. Good idea about preserving /etc/config/fstab
    2. Have seen Wiki is back up - thanks

  • @Boken-Lin All back to where I was - just had to reinstall a couple of opkg packages after redoing the pivot-overlay stuff

  • Sorry - me again šŸ˜ž with another problem.

    Accessing Editor in Console shows no files:
    This is with both Chrome and Firefox

  • @Kit-Bishop Just tested it on mine, the files loaded properly... Can you open up the Javascript console on your browser and let me know if you see any errors?

  • @Boken-Lin I'm not all that good with dealing with Javascript console, but think I may have found something from Chrome that may help:

    I wonder if this may be being caused by the last used path no longer existing. I don't remember whether or not I had deleted anything - it is possible. However, Editor should just use a default path in this case.

  • @Boken-Lin I've been doing a bit more digging and think the problem comes from here in onion-file-provider.html:
    Still digging to see if I can find the cause and/or fix it.

  • @Kit-Bishop Can you download this file: https://s3-us-west-2.amazonaws.com/onion-cdn/community/console/console.tar.gz. This is a tarball of the console that I am testing (and didn't find any error). you just need to delete the /www directory on your Omega, and replace it with the content of the tarball.

    Please let me know if it does anything. If not, I will take a look at it again tomorrow morning.

  • @Boken-Lin Using the tar.gz file you supplied, it all works šŸ™‚
    At this stage, I don't know why, though I did have to flush my browser data first.
    I then did a file comparison between what you sent me and what was originally in my /www directory (I preserved it first). The files were identical and when I restored my original /www files, everything worked.
    My suspicion at this stage is that my problem was originally caused by something that the browser had cached.
    I had to clear cache individually on Chrome and Firefox before each worked properly.

    If there is nothing that can be done for dealing with invalid information coming from cached browser data, it might be an idea to document somewhere that clearing of cached browser data might be needed.

    Anyway, thanks again for your advice and help. I'm all happy here šŸ™‚

  • After upgrading one on my omegas, i couldn't connect to it via ssh over my local network wifi. Upon inspecting /etc/config/wireless i discovered that wireless settings were changed and became a mixture of my previous config before upgrade and defaults. For example, SSID has changed to "Omega-xxxx", while the password was the same as i need for the local wifi connection. It became a mix of access point and standard client setup.

    I ended up resetting the device (10 second press on button on the expansion dock) and re-running wifisetup

  • @Andrei-Railean Thanks for letting us know! We will take a look at the upgrade process today and see what's the issue.

  • Ahh great update looks very slick and super stoked that the OLED expansion is working so well now. Just one quibble really and that is the repo mismatch still seems to be there:

    opkg install tinc
    Installing tinc (1.0.26-1) to root...
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/packages/tinc_1.0.26-1_ar71xx.ipk.
    Collected errors:

    • satisfy_dependencies_for: Cannot satisfy the following dependencies for tinc:
    • kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66) *
    • opkg_install_cmd: Cannot install package tinc.
      root@Omega-1956:~# uname -a
      Linux Omega-1956 3.18.23 #1 Fri Dec 4 02:26:08 UTC 2015 mips GNU/Linux

    Are there any new repo updates we can use?

    Great work otherwise. Thanks!

  • @t-nt It doesn't look like you are getting the Onion repo. I can't test till later today. @Lazar-Demin are the downloads supposed to automatically use the Onion repo, or is this something that needs to be configured?

  • @Chris-Ward The Onion repo currently has only part of the packages offered by the default OpenWRT repo. For stuff that's not on our repo, opkg still uses the default OpenWRT one. We are still in the process of compiling more packages over to our own repo.

  • Ah. Ok, that sounds like a good way to do it - gets the Onion repo partially out. Thanks.

  • administrators

    @Chris-Ward @T-NT The Onion Repo is available by default, but as Boken said, it only offers some packages and the default OpenWRT Repos are still in use as well.

    I was able to access all of the repos ok just now:

    root@Omega-1302:~# opkg update
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_base.
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/Packages.sig.
    Signature check passed.
    Downloading http://repo.onion.io/omega/packages/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_onion.
    Downloading http://repo.onion.io/omega/packages/Packages.sig.
    Signature check passed.
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/packages/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_packages.
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/packages/Packages.sig.
    Signature check passed.

    Let me know if you still experience any issues.

  • Great update! And exciting to see the OLED support!

    Interestingly, I can use oled-exp to write characters to the display that the web interface can't handle. E.g. attempting to write anything with parentheses (either opening or closing or both) in the web interface fails silently, but when using it in a quoted string in oled-exp it works fine. My suspicion is that something is not getting properly quoted/escaped from the web interface but I haven't poked into it to see.

  • @fader Yeah, we just encountered this bug as well, and we are working to fix it!

  • @Boken-Lin said:

    @Chris-Ward The Onion repo currently has only part of the packages offered by the default OpenWRT repo. For stuff that's not on our repo, opkg still uses the default OpenWRT one. We are still in the process of compiling more packages over to our own repo.

    Ahh well that explains that. Well if you can see your way to making tinc a priority that would be a great help. It is the only thing that is really stopping me using the Omega in a real world scenario. I need to tie it into it's own vpn because I want to put it on the same network at other smart sensors and stuff I use.

    But like I say the rest of the work is fantastic and I cannot believe how clear and crisp the OLED display is. I positively squealed with delight when I saw my own images scrolling across the display šŸ™‚

  • @T-NT It definitely is one of our highest priority items on the list šŸ™‚

Looks like your connection to Community was lost, please wait while we try to reconnect.