We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Interesting oupgrade problem and the fix

  • I just got an Omega2+ and oupgrade kept failing with

    Device Firmware Version: 0.1.5 b130
    Checking latest version online...
    ERROR: Could not connect to Onion Firmware Server! Check your internet connection and try again!

    I could use opkg, ping sites, and wget sites.
    So to debug this in console I used +x option on ash (the shell) as follows:
    sh +x /usr/bin/oupgrade
    That shows the shell script in action.
    A few lines about the final failure message was:

    I scratched my head. WAIT "not yet vaild" on a SSL certificate -- like in was issued in the future or DOH the omega2p was in the past!

    The date command returned Wed Nov 23 02:13:06 GMT 2016, not good.
    The date is not automatically set and ntp wasn't running (used ps | grep ntp to check).
    I set the date with date -u -s '2017-06-04 01:27:30' then tried oupgrade again.
    Seems like it is working. It has just typed "Sending TERM to remaining processes ... onion-helper udhcpc S79wifimanager wifimanager udhcpc packet" and disconnected.
    Onion amber LED didn't come back on though. I may be in for more FUN.

  • you might want to go through the setup process by using browser to navigate

  • Tried that first. The oupgrade script will fail is clock is in the past.

  • Setting the time locally worked for me too. The real solution would be to fix the time it's pulling via ntp or lack there of. I attempted to update uci with 0.pool.ntp.org, with no joy. How do you fix the NTP daemon?

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.