We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Connecting via serial putty inserts jibberish characters

  • Have you tried looking at windows settings to make sure that they are correct?
    Control Panel > Device Manager > Ports (COM & LPT) > COM20 , Right click, Properties, Port Settings tab,
    Bits per second:115200
    Data bits: 8
    Parity: None
    Stop bits: 1
    Flow control: None

  • I installed Bonjour service and its running. No change.
    I tested several cables. No change.
    I tested several driver versions. No change.

    The serial settings are probably correct, because between all the jibberish I can read the correct strings. I think there might bee something wrong with my omega2, because I see this jibberish only when I log in several seconds after the device startup. When I try to log in after 30 seconds all I see is black screen in my PuTTY.

    When I turn the switch off and then back on the jibberish starts getting streamed after one seconds of start.

    [ 0.479869] i2c /dev entries driver
    [ 0.484045] mt7621_wdt 10000120.watchdog: Initialized
    [ 0.489405] MTK MSDC device init.
    [ 0.530875] mtk-sd: MediaTek MT6575 MSDC Driver
    [ 0.536903] NET: Registered protocol family 10
    [ 0.545499] NET: Registered protocol family 17
    [ 0.550097] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
    [ 0.562953] 8021q: 802.1Q VLAN Support v1.8
    [ 0.569440] mtk-linkit bootstrap: Version :
    [ 0.573941] mtk-linkit bootstrap: Revision :
    [ 0.583048] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
    [ 0.591121] Freeing unused kernel memory: 156K (803e9000 - 80410000)

  • @Filip-Franik
    Say something about the hardware please.

    You have an Omega2 and its RX0, TX0 pins ie. UART0.
    You have a PC with a serial port COM20 (probably a USB virtual port), running PuTTY Connection type: Serial, on ??? OS.

    What is between the two endpoints?

    Bonjour service is an other Galaxy 😉

  • @György-Farkas
    My system is Windows7 (I tested also on Win10)
    I use Silicon Labs CP210X USB UART Bridge (COM20) version

    I tested it using PuTTY and RealTerm with exactly same result.

    My Omega is connected to my PC with a out-of-box Onion Omega Mini Dock.

    I finally got the time to play with the hardware that I got as a backer of the kickstarter so the software on the is probably in a very old version. From what I see between the jibberish I have:
    "Onion Omega2 UBoot Version:"
    " Ω-ware: 0.1.5 b130"

    These are the full logs that I acquired by resetting the omega until the jibberish starts.

    When I press reset button nothing changes. I still get "Boot Linux from Flash NO RESET PRESSED." Maybe my MiniDock is faulty?

  • @Filip-Franik .59 is not very far into the boot. I have seen the 'jibberish' with loose Tx or Rx wires or power fluctuation or a funky UART. I suspect you are having an insufficient power problem. You have a Mini dock which should be Ok, provided you bought it with the Omega2 - Mini docks made last year had other problems with Omega2s. Have you tried with another USB cable? At another USB port on your computer?

    With the early firmware versions the dock Reset button did not work - Onion admitted that was a known problem. You can reset the unit by momentarily wiring the reset pin high (with 3.3V).

  • @Ken-Conrad
    I tested everything on several cables (this includes 15cm long low resistant one from my powerbank), several ports on several PCs. My Omega2 and MiniDock are the first ones ever shipped, as I got them by backing the kickstarter page so it's probably prone to "early version" problems.

    I don't think I can use part of my arduino board as Rx/Tx to USB converter to bypass the docks UART due to it using 5v logic and possibly burning the Omega2. Anyway I bought a new Omega2 with a new dock and I wait for delivery. I will check if it's just the dock that's faulty.

    My internet controlled plant watering device will be completed! Whatever the cost!

  • @Filip-Franik
    I suppose your Omega is otherwise working well - you just tried out the serial console (with the same PC, USB port, USB cable).
    Make sure your Omega’s pins are fully plugged into the Minidock's socket, especially the Serial RX0 pin.
    Maybe you have a loose contact there.

    Good Luck!

  • @Filip-Franik Parts redundancy is most helpful while working through problems with an inexpensive Chinese made board - your plan with multiple docks and Omegas etc will serve you to solve this problem, learn more about the Omegas and IoT.

    Yes, don't try to use the UART on an Arduino, unless it is a 3.3V version. As recommended by György-Farkas, you could try one of the inexpensive SiLabs USB to UART boards on eBay connected to the Omega Rx0 and Tx0 pins - these boards are very useful to have to troubleshoot the Omegas. In which case you will also need a sufficient (1-2A) 3.3V power supply.

  • @Ken-Conrad said in Connecting via serial putty inserts jibberish characters:

    As recommended by György-Farkas, you could try one of the inexpensive SiLabs USB to UART boards on eBay connected to the Omega Rx0 and Tx0 pins ...

    Yes, it could be the next step.
    At the moment I'm talking the [Omega with Minidock only] HW config.

  • Looks like I got a case of faulty Mini Dock!

    Thanks everyone for help!

Looks like your connection to Community was lost, please wait while we try to reconnect.