We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Watchdog on Omega2+

  • Hi,

    According to the datasheet of MT7688, this SoC has timers able to work as a watchdog. But I'm not sure if the current firmware (0.1.10 b160) has driver support for this feature.
    I've tried to use it writing at /dev/watchdog and /dev/watchdog0 files but I received resource busy error, be it via echo or ioctl's call.
    So I would like to know if it is possible to use Linux watchdog on Omega2+ and if yes, what I must to do to enable it.


  • @Rodrigo-Fructuoso Did you ever resolve this? I have a situation where my omega2+ stops after a while and although I want to fix this I also want to have a working watchdog solution... Should I design an external watchdog or can I rely on the MT7688&?

  • Go deeper and find out the root cause, IMHO, is a better/reliable way.
    Known (possible) issues are (1) power brown-out due to instantaneous power demand, (2) very heating, (3) in early days, flaky soldering. In any of these cases, you'll have to address the RCA first before trying the reboot path which may or may not work anyways.

  • @ccs-hello 2 things
    1 - I went deeper and found out that depending on where my device was in my home the problem would go away / be present. At the location where the problem was present, I attached a Wifi antenna and the problem disappeared...so the problem is related to a weak Wifi signal. But the consequence were that everything stopped, including Ethernet. Not good and very surprising!!

    2 - RESET and FW_RESET never worked, even when the device was being successfully pinged. Those 2 pins are not very useful.... I know that FW_RESET can be converted to GPIO but my device is still pretty much at factory reset (except for a script that toggles a different GPIO)

  • @Claude-Robitaille

    Sigh, still that buggy picky strange WiFi behavior that never goes away. RESET (probably power-cycle reboot) unnecessarily is like wrack-a-mole exercise, it will never end.

  • @ccs-hello Yeah... and it is not like I did not checked I am running the latest and "greatest".....:-(

Looks like your connection to Community was lost, please wait while we try to reconnect.