We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

New OS Release!

  • administrators

    A small note:

    To successfully run the oupgrade command, you must connect to the Omega's command line with SSH or via Serial. The command will not work from the Terminal app on the Console.

    @Douglas-Kryder When you try with sysupgrade, for best results I would suggest adding the -n option. This will reset the Omega to the default settings as dictated by the new OS, should make for an easier install.

    Regarding the MAC address, yep there have been some changes:

    • The MAC address of the wireless interface used to host the Omega's AP network will match that written on the label
    • The MAC address of the wireless interface used to connect to other networks will be the MAC address on the label +1

    As for the wireless config file reset, on the very first boot, the new OS will look for traces of the old wireless configuration, and if found, will reset the config.
    It's possible that you still have programs installed that write old wireless configuration, try running the following:

    opkg update
    opkg remove wifi-manager
    opkg upgrade onion-console-base

  • @Lazar-Demin Hello. How to verify that new OS is installed into our omega.

  • @Swapnil-Katpally It tells you so in the bootup banner. Do cat /etc/banner.

    root@Omega-17FD:~# cat /etc/banner
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/
       Ω-ware: 0.2.0 b176

    Also check

    root@Omega-17FD:~# oupgrade --check --latest
    > Device Firmware Version: 0.2.0 b176
    > Checking latest version online...
    > Repo Firmware Version: 0.2.0 b176
    > Comparing version numbers
    > Device firmware is up to date!

  • This post is deleted!

  • This post is deleted!

  • Ok so I flashed this to my OO2P and as I had nothing to lose also factory reset it with firstboot -y

    So I was a little surprised when I say a segfault on restart to do with the SPI driver.

    [ 11.542654] spidev spi32766.1: buggy DT: spidev listed directly in DT
    [ 11.549271] ------------[ cut here ]------------
    [ 11.553970] WARNING: CPU: 0 PID: 486 at drivers/spi/spidev.c:720 0x8768833c()
    [ 11.561222] Modules linked in: spidev(+) snd_usbmidi_lib slhc rfcomm nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_mangle iptable_filter ip_tables hidp hid_generic hci_uart crc_ccitt cdc_acm btusb btintel bnep bluetooth snd_soc_simple_card snd_soc_ralink_i2s snd_soc_wm8960 videobuf2_vmalloc videobuf2_memops videobuf2_core hid v4l2_common videodev evdev snd_soc_core mt_wifi ralink_gdma virt_dma ledtrig_oneshot ledtrig_morse ledtrig_heartbeat ledtrig_gpio ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables msdos snd_pcm_dmaengine snd_compress snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_rawmidi snd_seq_device snd_hwdep snd input_core soundcore vfat fat ntfs configfs autofs4 nls_utf8 nls_iso8859_1 nls_cp437 regmap_i2c dma_shared_buffer ecb cmac mmc_block usb_storage sdhci_pltfm sdhci mtk_sd mmc_core leds_gpio ohci_platform ohci_hcd ledtrig_transient ehci_platform ehci_hcd sd_mod scsi_mod gpio_button_hotplug ext4 jbd2 mbcache exfat usbcore nls_base usb_common crc16 cryptomgr aead crypto_null crc32c_generic crypto_hash
    [ 11.666647] CPU: 0 PID: 486 Comm: kmodloader Not tainted 4.4.74 #0
    [ 11.672911] Stack : 80380780 00000000 00000001 803d0000 87dab4d4 803cae63 80361c18 000001e6
    [ 11.672911] 80413438 0000000c 0000001a 024000c0 80066378 8004af58 80367120 803c0000
    [ 11.672911] 00000003 0000000c 80365524 875a7b4c 80066378 80048ec4 00000000 00000000
    [ 11.672911] 00000001 00000000 00000000 00000000 00000000 00000000 00000000 00000000
    [ 11.672911] 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
    [ 11.672911] ...
    [ 11.709089] Call Trace:
    [ 11.711629] [<80066378>] module_sect_show+0x0/0x18
    [ 11.716513] [<8004af58>] vprintk_default+0x24/0x30
    [ 11.721390] [<80066378>] module_sect_show+0x0/0x18
    [ 11.726268] [<80048ec4>] printk+0x2c/0x38
    [ 11.730352] [<8002552c>] warn_slowpath_common+0xa0/0xd0
    [ 11.735683] [<8014de3c>] dump_stack+0x14/0x28
    [ 11.740106] [<80014908>] show_stack+0x50/0x84
    [ 11.744524] [<8002552c>] warn_slowpath_common+0xa0/0xd0
    [ 11.749843] [<8768833c>] 0x8768833c
    [ 11.753403] [<800255e4>] warn_slowpath_null+0x18/0x24
    [ 11.758560] [<801fb304>] of_match_node+0x20/0x44
    [ 11.763272] [<8768833c>] 0x8768833c
    [ 11.766846] [<801c0a10>] devm_kfree+0x20/0x44
    [ 11.771285] [<801e1bd8>] spi_drv_probe+0x3c/0x84
    [ 11.775994] [<801bd540>] driver_probe_device+0x120/0x288
    [ 11.781405] [<8008b928>] kstrdup+0x44/0x8c
    [ 11.785589] [<801e1ad8>] spi_match_device+0x38/0xa8
    [ 11.790567] [<801bd724>] __driver_attach+0x7c/0xb4
    [ 11.795442] [<801bb948>] next_device+0x10/0x30
    [ 11.799959] [<801bd6a8>] __driver_attach+0x0/0xb4
    [ 11.804746] [<801bba04>] bus_for_each_dev+0x9c/0xac
    [ 11.809706] [<80303c9c>] klist_add_tail+0x24/0x50
    [ 11.814484] [<801bb7d8>] bus_get+0x2c/0x50
    [ 11.818679] [<801bcc38>] bus_add_driver+0xec/0x20c
    [ 11.823549] [<800ae92c>] exact_match+0x0/0x8
    [ 11.827899] [<800aee34>] exact_lock+0x0/0x24
    [ 11.832253] [<801bde3c>] driver_register+0xa8/0xf8
    [ 11.837133] [<8775a000>] init_module+0x0/0xdc [spidev]
    [ 11.842387] [<8775a098>] init_module+0x98/0xdc [spidev]
    [ 11.847711] [<80159a08>] kasprintf+0x1c/0x28
    [ 11.852061] [<800458b0>] __wake_up+0x24/0x48
    [ 11.856412] [<8775a000>] init_module+0x0/0xdc [spidev]
    [ 11.861646] [<8000d938>] do_one_initcall+0x1e8/0x214
    [ 11.866709] [<800458b0>] __wake_up+0x24/0x48
    [ 11.871046] [<8775a000>] init_module+0x0/0xdc [spidev]
    [ 11.876291] [<80034568>] call_usermodehelper_exec+0x144/0x160
    [ 11.882138] [<80034058>] call_usermodehelper_setup+0x38/0xa8
    [ 11.887922] [<80066378>] module_sect_show+0x0/0x18
    [ 11.892805] [<80067598>] do_init_module+0x74/0x1cc
    [ 11.897700] [<8009f418>] __vunmap+0xf0/0x114
    [ 11.902076] [<80068e2c>] load_module+0x16c0/0x1b68
    [ 11.906958] [<80066964>] unknown_module_param_cb+0x0/0xac
    [ 11.912443] [<8009f90c>] __vmalloc_node+0x34/0x40
    [ 11.917260] [<80069368>] SyS_init_module+0x94/0x180
    [ 11.922213] [<80069404>] SyS_init_module+0x130/0x180
    [ 11.927293] [<8000682c>] syscall_common+0x30/0x54
    [ 11.932077] [<80008c58>] __bzero+0xbc/0x164
    [ 11.936331]
    [ 11.937846] ---[ end trace d1d675f9648aa3a7 ]---

    I was also surprised when the promised better performing 'Warp Core' driver did not seem connect to any of my networks. In fact it kept on saying it connected but there was no internet. A blatant falsehood given that my laptop I was using to login via the Serial console was working fine on the same access points.

    Anyway of debugging what is going on? If i cannot connect to wifi then not sure how I will ever fix a problem on it again.

  • ERROR: Could not connect to Onion Firmware Server! Check your internet connection and try again!

    Connected via serial or SSH.
    Definitely have internet connection, can perform update, upgrade, install.
    Possibly issue in connecting with Firmware Server, will try again later.

  • Had to do manual download and install.
    link text

  • Installed new firmware omega2p-v0.2.0-b176.bin on 2+.
    Discovers WiFi but will not connect?

  • wifisetup not working?

    root@Omega-35EB:~# wifisetup
    Onion Omega Wifi Setup

    Select from the following:

    1. Scan for Wifi networks
    2. Type network info
      q) Exit

    Selection: sh: 1: unknown operand
    sh: 2: unknown operand

    I'm relatively new to this, but what is going on?

  • @John_L You should simply hit the 1 (or the 2) key.
    It seems you typed the sh: 1 (or the sh: 2) text instead.

  • @John_L

    I noticed in my one the wifisetup script used uci set wireless.radio0.. when of course the device is actuall ra0 now.

    That fixed that problem.. but still cannot get it to connect to any of my wifi AP's,


  • @György-Farkas said in New OS Release!:

    (It seems you typed the sh: 1 (or the sh: 2) text instead.

    NO, I only typed wifisetup and return and was not given a chance to enter selection, rest of output was generated by Omega.

  • @T-NT said in New OS Release!:

    I noticed in my one the wifisetup script used uci set wireless.radio0.. when of course the device is actuall ra0 now.

    But if you look at wireless script in /etc/config , option device is 'radio0' for both ap and sta interface. AP interface seems to work as I can connect and log onto Omega WiFi directly.
    But I can't get STA interface to work to connect to my WiFi router AP?

    In quick start web interface setup, Omega scans and detects my external WiFi router and AP's , but will not connect?

    Then tried terminal wifisetup and will not let me make menu selection, see previous post.

    Looks like I'm not alone with WiFi connection issue?????

  • administrators

    @Brian-Kaisner installation of the new OS will wipe the previous wireless configuration,
    please try running wifisetup and configuring your Omega to connect to your network

    @T-NT regarding SPI, it's not a segfault, rather a very loud complaint, see this for more details: https://github.com/raspberrypi/linux/issues/1054

    Can you post the output of uci show wireless, ifconfig, and iwconfig? That will give some more insight into what's going on.

    @John_L What you're describing is symptomatic of still having the older wifi programs but the new driver. I would say your best bet forward is to back-up anything you don't want to lose from that Omega to a USB and perform a factory reset.
    This will setup your Omega with only the b176 files and you should be good to go. Let me know how it goes!

  • Thanks Lazar,
    No problem, will try factory reset, have over 50 omega 2+ to play with.
    Will let you know how it goes.

  • OK, sorted out wifisetup. Was using TeraTerm terminal on Win-7 and had CR+LF set as Return/Enter. Fixed by deleting LF and only sends CR after Return/Enter key.

    Still no joy in connecting to my local WiFi router that works with previous firmware version.
    Have tried Factory Reset on previously used Omega 2+ and number of new units with previous fresh firmware out of the box.

    Anyway new firmware flashed is omega2p-v0.2.0-b176.bin. Not sure if this is region dependent regarding WiFi channels, I am in Australia?

    After scanning and selecting local WiFi without encryption for this exercise. this is the listing of wireless file in /etc/config

    config wifi-device 'radio0'
    option type 'ralink'
    option variant 'mt7628'
    option country 'US'
    option hwmode '11g'
    option htmode 'HT40'
    option channel 'auto'
    option disabled '0'
    option device_mode 'apsta'
    option op_mode 'preference'

    config wifi-iface 'ap'
    option device 'radio0'
    option mode 'ap'
    option network 'wlan'
    option ifname 'ra0'
    option encryption 'psk2'
    option key '12345678'
    option disabled '0'
    option ssid 'Omega-C0B5'

    config wifi-iface 'sta'
    option device 'radio0'
    option mode 'sta'
    option ifname 'apcli0'
    option encryption 'psk2'
    option ssid 'YourSsidHere'
    option key 'YourPasswordHere'
    option network 'wwan'
    option disabled '0'

    config wifi-config
    option key 'none'
    option ssid 'RR2'
    option encryption 'none'

    config wifi-config is added to the bottom of the script file as above with correct WiFi ssid and no encryption.
    Not sure if config wifi-iface 'sta' should have been filled in with my WiFi setting, it is in fact unchanged from factory reset?

    Below is the output after running wifi command.

    root@Omega-C0B5:/etc/config# wifi
    root@Omega-C0B5:/etc/config# [ 947.402706] br-wlan: port 1(ra0) entered disabled state
    [ 947.441399] device ra0 left promiscuous mode
    [ 947.445912] br-wlan: port 1(ra0) entered disabled state
    [ 947.486297] IPv6: ADDRCONF(NETDEV_UP): br-wlan: link is not ready
    [ 947.793368]
    [ 947.793368] _ _____ ___ ___ _________ ___ ____
    [ 947.793368] | | /| / / _ | / _ / _ \ / / __ / _ / / V1.0
    [ 947.793368] | |/ |/ / __ |/ , _/ / / // // / , _/ _/
    [ 947.793368] |
    / |//|// _/_//|/__/
    [ 947.793368] Onion Enhanced MT7688 WiFi Driver
    [ 947.793368]
    [ 947.968677] DMA Scheduler Mode=0(LMAC)
    [ 947.972528] efuse_probe: efuse = 10000012
    [ 947.976690] 1. Phy Mode = 14
    [ 948.142871] 2. Phy Mode = 14
    [ 948.145897] 3. Phy Mode = 14
    [ 948.149182] WTBL Segment 1 info:
    [ 948.152547] MemBaseAddr/FID:0x28000/0
    [ 948.156475] EntrySize/Cnt:32/128
    [ 948.159921] WTBL Segment 2 info:
    [ 948.163280] MemBaseAddr/FID:0x40000/0
    [ 948.167213] EntrySize/Cnt:64/128
    [ 948.170663] WTBL Segment 3 info:
    [ 948.174030] MemBaseAddr/FID:0x42000/64
    [ 948.178021] EntrySize/Cnt:64/128
    [ 948.181468] WTBL Segment 4 info:
    [ 948.184843] MemBaseAddr/FID:0x44000/128
    [ 948.188906] EntrySize/Cnt:32/128
    [ 954.943390] device ra0 entered promiscuous mode
    [ 954.948238] br-wlan: port 1(ra0) entered forwarding state
    [ 954.953754] br-wlan: port 1(ra0) entered forwarding state
    [ 954.960267] IPv6: ADDRCONF(NETDEV_CHANGE): br-wlan: link becomes ready
    [ 956.944594] br-wlan: port 1(ra0) entered forwarding state

    My knowledge is not up to speed with what should be the correct output?

    Anyway, looking for suggestions why omega 2+ doesn't connect or is not seen by my local wifi router?

  • This is the main difference between the new V2 firmware and previous firmware when trying to connect to local WiFi.

    Output from previous firmware that connects to local WiFi:

    [ 149.529421] br-wlan: port 2(ra0) entered forwarding state
    [ 149.534954] br-wlan: port 2(ra0) entered forwarding state
    [ 151.528355] br-wlan: port 2(ra0) entered forwarding state
    [ 155.384737] !!! APCLI LINK UP - IF(apcli0) AuthMode(0)=OPEN, WepStatus(1)=NONE!

    Output from new V2 firmware that DOESN'T connect.

    [ 374.591028] br-wlan: port 1(ra0) entered forwarding state
    [ 374.596616] br-wlan: port 1(ra0) entered forwarding state
    [ 374.603060] IPv6: ADDRCONF(NETDEV_CHANGE): br-wlan: link becomes ready
    [ 376.594605] br-wlan: port 1(ra0) entered forwarding state

    Then it just hangs there!!!!

    I don't have enough knowledge on how it all works but.
    Is this the actual connection to WiFi running old firmware?

    [ 155.384737] !!! APCLI LINK UP - IF(apcli0) AuthMode(0)=OPEN, WepStatus(1)=NONE!

  • After spending more than half a day reading forum posts that don't relate much to new firmware with new wifi interface and playing with different options. No luck in connecting to Dlink DSL-2900AL wireless router. Although can connect with previous 1.9-b.159 firmware using gui web interface without any other configuration modifications.

    Since I have number of Omega 2+'s and old firmware can connect to Dlink router, I tried to eliminate direct connection to Dlink router and connect via Omega 2 with 159 firmware that is connected to Dlink . SUCCESS, sort of.

    I can connect to Dlink router and local WIFi network through Omega with old firmware but don't have Internet access yet.

    I guess more research and reading what is the difference between Dlink router AP and Omega AP with old firmware? Also how to get to Internet? This is suppose to be easy beginner friendly module?

    Update .
    Have modified firewall settings in Omega connected to Dlink and use it as "Range extender" with internet access available.

    Omega with new firmware connected to Omega as range extender works unreliably with internet access. Can ping Internet IP for a little while and then it stops, have to reset WiFi (wifi command) to get internet access again. opkg update DOSN'T work "opkg_download: Failed to download..........opkg_download: Check your network settings and connectivity"

    Omega with old firmware as range extender appears to have good internet access through Dlink wifi router, pings OK, opkg update works fine.

    ?? More troubleshooting or may just forget about new firmware until it becomes more stable.

  • administrators

    @John_L the new firmware won't show a message like !!! APCLI LINK UP - IF(apcli0) AuthMode(0)=OPEN, WepStatus(1)=NONE!
    That's something we'll look into adding.

    The sta part of the /etc/config/wireless won't get populated until wifi is run so no worries on that front.

    Can you try connecting to a different router, maybe one with a WPA2 password?
    Also, to debug, it would be helpful if you posted the output of the following commands: ifconfig, iwconfig, uci show wireless

Looks like your connection to Community was lost, please wait while we try to reconnect.