We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Having trouble with SD and USB cards

  • I have been playing with the Omega 2+ for some time now and would have to say it is not an easy beast to get working correctly. I have tried to get some more memory by using the swap file system but would have to say that from my point of view it is flaky to say the least.
    Am I missing something?
    Why can't the firmware just be setup to add the SD card to the base memory, this is getting to the point that I just want to throw the
    2 + in the bin and go back to Raspberry, at least that works

  • Agreed 100%. All I want to do is move the root filesystem to the SD card and I think this might do it for me, but it has taken me a while to get there...

    I have been playing with my Kickstarter Omega2+ for several days now and have yet to get it working to the point where I would consider it usable. I discovered quickly that you can't install much software on it until you expand the memory and have spent these past several days struggling to use an SD card as "expanded memory" without success.

    After searching and searching, I finally found the info I wanted and set about formatting and mounting etc only to have the thing slow to an absolute crawl when I started it up a while ago.

    I'm afraid I need to re-initialize it yet again and start over.

    The Raspberry Pi Zero W can be frustrating at times, but I've always been able to get it up and working and my projects built, programmed and deployed without wanting to hit one with a hammer. For the most part, they "just work". I love the form factor and the expansions but if I can't get it running, it's all just money wasted.

    I agree that there ought to be a documented process to fix the biggest weakness of the Omega2+: lack of memory [storage].

  • @Jeff-in-TX

    I agree that there ought to be a documented process to fix the biggest weakness of the Omega2+: lack of memory [storage].

    Did you try the procedures as documented here Extending the Omega’s Available Memory for memory and here Booting from External Storage for storage?

    If so, were they not useful, or did you find errors that prevented you from achieving the objectives?

  • Gents,
    This repo has working code for memory expansion:

    git clone git@bitbucket.org:xpivot/omega2_infrastructure.git

    There's serious rocket surgery going on now in this code, so just focus on the "disk" directory which is somewhat well tested. The branch you'll need to check out is named "refactor/debuoy".

    So, clone the repo, check out the branch, and run the shell script in the disk directory. Just a perusal of the code for five minutes ought to get you up to speed on what it does.

    Of course I'll gladly entertain any questions and improvement suggestions.

    I'd appreciate a report of any bugs found.

    take care!

  • @William-Scott git clone git@bitbucket.org:xpivot/omega2_infrastructure.git
    through an access rights error for me.

    PS C:\Users\dkryder> git clone git@bitbucket.org:xpivot/omega2_infrastructure.git
    Cloning into 'omega2_infrastructure'...
    Warning: Permanently added the RSA host key for IP address '' to the list of known hosts.
    git@bitbucket.org: Permission denied (publickey).
    fatal: Could not read from remote repository.

    Please make sure you have the correct access rights
    and the repository exists.

    any suggestions?

  • @Douglas-Kryder Daoh! I'll fix it and advise.


  • @Douglas-Kryder Cloning the repo would require allowing permissions to it which, when I think about it, I could be getting requests for access for months or a couple of years. Instead here is a different approach.

    I cloned, changed to the branch with the clean storage upgrade code, and tarred it up. It's now on my org's site at https://xpivotcorp.com/omega2/omega2_infrastructure.tar.gz

    I'd be more than happy to collaborate with anyone on building O2 software and projects in general. However for the moment I think just providing access to a download without repo access could get interested folks access faster.

    There's no need to clone or change branches now. It's just a simple tarred up download of the correct branch.


  • What is the solution for booting from a MicroSD card ? I have tried all of tutorials but they don't work, Can someone help me please ?

  • @Alejandro--Torrente Just one post back from yours (unless we got jumped) is a url to some code I wrote that might very well solve your problem. Note I wrote the code to solve MY problem, so you may need to tweak it. But for my problem it's allowed me to bring up several devices with little to no effort.

    take care!!

  • I followed the steps of that video [https://www.youtube.com/watch?v=d1UbEg9kf5c](link url) but at the end I add one step ... I execute that command mount /dev/mmcblk0p1 /overlay ... and then reboot. That was the only way to configure the microSD card. Thanks for your help 🙂

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.