We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Can't access my Omega Onion2+ over Wifi after running oupgrade (again)

  • Once again, fter running "oupgrade" on my Onion Omega2+, I am no longer able to access it over my home's Wifi connection (I'm using a a Windows 10 PC). I am only able to connect to the device via SSH (and access the web interface) when I'm connected to the Onion's Wifi hotspot, and even then I am only able to do so using the Onion's IP address (using omega-XXXX.local does not work).

    Everything was working perfectly and as expected before the oupgrade. And just like the last time, I did the following in attempt to troubleshoot:

    1. I uninstalled Bonjour using Add/Remove programs
    2. I rebooted the PC
    3. I added the registry entry that's described at the link that Gyorgy provided:
    4. I rebooted the PC
    5. I downloaded and ee-installed the Bonjour print service:
    6. I rebooted the PC

    But none of these things made any difference whatsoever.

    I also tried running "oupgrade -f" via the command line to update the firmware, .. and also tried doing a factory reset by holding down the reset button for 10+ seconds. But that also didn't make any difference. And what's odd is that the Onion's LED now only blinks for something like 10 seconds before it goes solid, whereas before It used to blink for over a minute before going solid (although this might be a deliberate result of the os upgrade. Lastly, I have confirmed that I am definitely running the latest firmware / OS version. Note that I am using the Power Dock, and that I am powering the device via USB.

    Any help in figuring this out would be greatly appreciated.

    -- Yvan

  • I have the same problem and the same issue: factoty reset, reinstall...

  • @Yvan-Gagnon
    If you are able to connect to the omega2+ via SSH, have you tried to remove and re-add the wifi connections to your main AP manually using wifisetup?

    Did you get any errors and if so, what errors were displayed?

    There's some useful checks that can be done as mentioned here: FAQ: How do I check if I'm successfully connected to a WiFi network?

  • Yes .. that is how I configured the Wifi connection to begin with .. using wifisetup via the terminal. I'm pretty sure that I'm connected, because I'm able to surf the web and send and receive email when I'm connected the the Onion's Wifi access point. Is it even worth the trouble for me to run those diagnostics if this is the case?

    • Yvan

  • ok, it seems the omega2 is connected to your router since it can serve webpages. what i do not understand is the thread states unable to connect via wifi and yet you state you can surf/email when connected to wifi access point. it can't be both.

  • Yes .. the Onion itself is successfully connected our home Wifi/router. The problem is that once I disconnect my laptop from the Onion's Wifi access point and then reconnect it to my home Wifi's access point .. the Onion is then no longer accessible .. neither via the hostname nor the IP address. And even when I'm connected to the Onion's Wifi access point .. accessing it via the hostname now no longer works.

  • @Yvan-Gagnon
    Ok, I misunderstood your problem then.
    Are you using the IP assigned to your O2+ by your home router when trying to connect to it? What is the IP you are using, perhaps there is a clash?

  • yes, cas is right concerning IP. generally, your router will assign an IP to the onion that fits within it's network. so if you are connected to the router you need to use the IP assigned to the onion by the router. you should be able to access a network map of the router by browsing to or something similar established by the router. the map will give you the IP address assigned by the router. use that IP when connected to router and the onion IP when connected to the onion. at least that is how i handle it and it has worked for me. good luck.

  • Hmmm .. but that wouldn't explain why i was able to access the Onion using the hostname prior to upgrading .. and why I am now no longer able to access it using the hostname after the upgrade.

  • Ok -- I get it now. There are 2 different IP address that I can access the onion through .. the default "" one (which only works when I'm connected to the Onion's Wifi hotspot) .. and the router assigned IP address .. which I just verified allows me to access the Onion when I'm connected to my home's Wifi connection.

    Also -- interestingly -- it appears that I am able to connect to the Onion via SSH using the hostname using my iPhone .. which hints that the issue is likely specific to my local PC. Anyone have any idea as to how I might resolve this issue?

    • Yvan

  • @Yvan-Gagnon i thought bonjour was supposed to resolve that on the pc. you could check that you have no firewall on pc or router blocking udp port 5353. bonjour install is supposed to handle windows firewall setup but some routers block all udp ports by default. check the router firewall via admin page via browser.

  • I thought so too. I know it's definitely not the router that's blocking the port .. since my iPhone seems to be able to access the Onion using the hostname. So how would I check to see if my Windows 10 PC is blocking udp port 5353 ?

  • @Yvan-Gagnon visit the firewall settings. i get there via control panel/windows defender firewall/advanced settings then just look around.

  • I've checked my Windows Defender Firewall settings and see 6 different entries for UDP connections on port 5353 .. and all 5 of them have a green checkmark beside them (which I assume means that the port is open). Two of those ports are "mDNS (UDP-In)" .. one which is marked "Domain, Public" .. and the other "Private".

    I have no idea what any of this means ... or if it lends any clues pertaining to the issue I'm having.

    • Yvan

  • @Yvan-Gagnon If you have Windows 10 x64 try to install 'Bonjour64.msi' - a part of the 'iTunes64Setup.exe' installer.
    iTunes installer https://www.apple.com/itunes/download/
    See also Can't access my Onion Omega2+ over Wifi.

  • I just did as you suggested (unpacked and installed Bonjour64.msi) .. and the local hostname for the Onion still isn't resolving.

Looks like your connection to Community was lost, please wait while we try to reconnect.