We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Can no longer boot from external storage after update to OpenWRT18

  • I previously set up my Omega 2+ to boot from an SD card using the instructions here:

    Booting from External Storage

    It worked fine when I did it before upgrading to OpenWRT18.

    After upgrading to OpenWRT18, I had to do it again, and I followed the same instructions, precisely, as far as I can tell.

    However, after rebooting, this file:


    reverts to what it was initially, even though I edited it as the last step before rebooting (and I checked, it is being saved properly before I reboot).

    After rebooting, the file system looks exactly as it did before I started:

    Filesystem                Size      Used Available Use% Mounted on
    /dev/root                 7.8M      7.8M         0 100% /rom
    tmpfs                    29.3M     84.0K     29.2M   0% /tmp
    /dev/mtdblock6            6.6M      6.6M         0 100% /overlay
    tmpfs                    29.3M    116.0K     29.2M   0% /tmp/root
    overlayfs:/tmp/root      29.3M    116.0K     29.2M   0% /
    tmpfs                   512.0K         0    512.0K   0% /dev
    /dev/mmcblk0p1           14.5G     40.0M     13.7G   0% /mnt/mmcblk0p1

    And the relevant part of /etc/config/fstab goes back to what it was before I edited. Before rebooting, I changed it to this:

    config mount
            option target '/overlay'
            option uuid 'c4f1e098-785d-412a-af16-491e184650ff'
            option enabled '1'

    But after rebooting, it goes back to:

    config mount
            option target '/mnt/mmcblk0p1'
            option uuid 'c4f1e098-785d-412a-af16-491e184650ff'
            option enabled '0'

    Anyone know why it keeps reverting to what it was before I reboot? I want to install Node but I can't because there is not enough space. My 2+ is useless without more space.

  • I thought it might be related to the fact that my SD card is apparently partitioned (that "p1" at the end of the device name seems to be the clue that my Omega sees partition 1).

    I reformatted the drive so now it only has one partition (and the device name is now mmcblk0), but the end result is the same, once I reboot, /etc/config/fstab is reset to what it was before I edited it.

  • A factory reset, followed by repeating the entire process, hasn't solved the problem.

    I did notice this during the boot process:

    [   15.408335] block: attempting to load /etc/config/fstab
    [   15.415885] block: unable to load configuration (fstab: Entry not found)
    [   15.422871] block: no usable configuration

    ...but I don't know if that is significant. /etc/config/fstab does exist once the device has booted, but it still contains what I pasted above.

  • This is no help but I too have experienced the same problem. Just updated after bricking it early this morning trying to rush to update and now after getting it back to the 2.0.2 build (Omega2+) I upgraded and reset to use my SSD card and no love still just base system.

  • Well I got it to work doing a little hack. Here is what I had to do:

    1. Installed new firmware 0.3.2 b217 -> oupgrade -latest
    2. Copied the overlay folder per the instruction found here onto my SD Card
    3. Created my /etc/config/fstab file and made necessary changes per link here.
    4. Rebooted - no love as I mentioned. So onto the hack...
    5. Downloaded the prior build b202 and installed it via my USB using the Expansion Dock and Putty per instruction here. You may be able to do the firmware update using ssh but I had already had the system setup for unbricking my processor from earlier so I stuck with it.
    6. Rebooted
    7. Created my /etc/config/fstab again using block > /etc/config/fstab and made the necessary changes per link here.
    8. Rebooted NOTE: I did not copy back over the overlays folder as that would have put the older firmware onto the SD Card.
    9. upon reboot I have my 116.GB Card with 110GB of space WOOT!
      0_1551324674921_Screenshot 2019-02-27 22.25.04.png
      Now time to play with Node and SQLite... Enjoy

  • @Shane-Neighbors Run this command please:
    ubus call system board

  • @György-Farkas said in Can no longer boot from external storage after update to OpenWRT18:

    ubus call system board

    Yeah it as I suspected after trying to install the underlying system still is not updated as it would not allow me to install packages that are part of the 18.06 Snapshot. I kept getting "Signature check failed". So back to square one....
    "kernel": "4.4.74",
    "hostname": "Omega-XXXX",
    "system": "MediaTek MT7688 ver:1 eco:2",
    "model": "Onion Omega2+",
    "board_name": "omega2p",
    "release": {
    "distribution": "LEDE",
    "version": "17.01-SNAPSHOT",
    "revision": "r3529-8d3b49a",
    "codename": "reboot",
    "target": "ramips/mt7688",
    "description": "LEDE Reboot 17.01-SNAPSHOT r3529-8d3b49a"

  • To add to that I was able to download the packages from the links inside the /etc/opkg/distfeeds.conf for what I needed (the ipk files) and just run them from the command line using opkg install <packagename> and if they need additional packages you will get an error. I was able to get sqlite3 running along with Node and npm so I'm happy for now will see what other issues popup.

  • so openwrt 18.06 is actually lede 17.01 snapshot? i guess it is some marketing mumbo jumbo.

  • @Douglas-Kryder said in Can no longer boot from external storage after update to OpenWRT18:

    so openwrt 18.06 is actually lede 17.01 snapshot? i guess it is some marketing mumbo jumbo.

    HW Omega2+ FW OpenWrt 18.06 based omega2p-v0.3.2-b217

    BusyBox v1.28.3 () built-in shell (ash)
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ?  /___/
       Ω-ware: 0.3.2 b217
    root@Omega-5BE1:/# ubus call system board
    	"kernel": "4.14.81",
    	"hostname": "Omega-5BE1",
    	"system": "MediaTek MT7688 ver:1 eco:2",
    	"model": "Onion Omega2+",
    	"board_name": "omega2p",
    	"release": {
    		"distribution": "OpenWrt",
    		"version": "18.06-SNAPSHOT",
    		"revision": "r0+7437-d624ea1daf",
    		"target": "ramips\/mt76x8",
    		"description": "OpenWrt 18.06-SNAPSHOT r0+7437-d624ea1daf"
    root@Omega-5BE1:/# onion os version
    === Version Info ===
    Omega firmware: v0.3.2 b217
    onion-os - 1.0.6-1
    root@Omega-5BE1:/# uname -a
    Linux Omega-5BE1 4.14.81 #0 Thu Feb 21 20:59:23 2019 mips GNU/Linux

    It seems it is not yet fully perfect. It's rather a release candidate.

  • @Douglas-Kryder - No it is my hack to make it recognize my SSD card as I need the space to play with NodeJS and SQLite which would not all fit on the base system. So my system is running the 17.02 lede snapshot under the covers and my ssd has the 18.02 overlays installed so I can access those tools.

    Again just a hack till someone way smarter than me figures out how to get the 18.06 base system to boot from external devices.

  • ok, thanks @György-Farkas & @Shane-Neighbors for the explanations. i initially could not figure out the ubus call system board output. thanks.

  • @Thomas-McCarthy said in Can no longer boot from external storage after update to OpenWRT18:

    Anyone know if there will be an update to let us boot from an external device with OpenWRT18?

  • I have several Omega2S+ on OpenWRT 18, Omegea-ware 0.3.2 b218 booting from external storage using exactly this set of commands.

    opkg update
    opkg install kmod-usb-storage-extras e2fsprogs kmod-fs-ext4 block-mount
    umount /tmp/mounts/SD-P1
    echo -e "y" | (mkfs.ext4 /dev/mmcblk0p1)
    mkdir /mnt/mmcblk0p1
    mount /dev/mmcblk0p1 /mnt/mmcblk0p1
    block detect > /etc/config/fstab
    uci set fstab.@mount[0].target=/overlay
    uci set fstab.@mount[0].enabled=1
    uci commit
    mount /dev/mmcblk0p1 /mnt/ ; tar -C /overlay -cvf - . | tar -C /mnt/ -xf - ; umount /mnt/


    reboot now & exit

    log back in and check

    df -h. 

  • @Jeff-Seese Thank you, I will try that!

  • @Jeff-Seese I tried that but I don't have the /tmp/mounts folder after upgrading to 3.2 b218? I seem to get it to work without the first umount. But now I can't set up a swap page on the overlay. Any suggestions?

  • Just to verify you are able to reboot after these steps and see a larger overlay with df -h?

    What is the command you are using to try and set up you swap file?

Looks like your connection to Community was lost, please wait while we try to reconnect.