We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

problems with the o2lte command

  • Hello everyone,

    Checking on multiple different lte boards, I noticed that once connecting to an apn ( i tried hologram and tmobile ) turning off the data connection doesn't seem to work. Even though o2lte says it turns it off, the interface is still there, it still has an ip address and traffic is still routing out off it.

    There also seems to be an issue switching from one apn to another. If I add a sim after a fresh restart, it will provision it correctly, but if I want to switch to a different sim and run the apn command again, it doesn't switch correctly.



  • administrators

    @Nate the data disable command shuts off the lted daemon. See the source here: https://github.com/OnionIoT/OpenWRT-Packages/blob/openwrt-18.06/omega2-lte/files/omega2-lte.sh#L195

    That should disable the data connection. Have you found any commands that work to disable the data?
    Maybe try out ifconfig down-ing the lte interface.

  • @Nate: I run into the same issue yesterday. The problem is that procd latches onto the command given i.e. lted-run which in turn starts lted. So during stop only this script is killed and the real daemon keeps running.

    What I did for now (in /etc/init.d/lted) is to run lted directly and merge the two extra commands from lted-run (ifconfig/echo) into it (before the procd sequence).

    #!/bin/sh /etc/rc.common
    # Copyright (C) 2019 Onion Corporation
    APN=$(uci -q get onion.@onion[0].apn)
    start_service() {
        [ "$APN" != "" ] && {
            # do lted-run stuff locally
            ifconfig wwan0 down
            echo "Y" > /sys/class/net/wwan0/qmi/raw_ip
            procd_set_param command $BIN -s $APN
            procd_set_param respawn  # respawn the service if it exits
            procd_set_param stdout 1 # forward stdout of the command to logd
            procd_set_param stderr 1 # same for stderr


Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.