We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

firmware upgrade error

  • I have the omega2 pro and after initial setup after connecting there is a page with docs, terminal, and software panels. tried to install console by clicking on install button, it shows the circling like it is installing, but just keeps it up with no change. I tried installing it half a dozen times after closing connection and reconnecting, then clicking on install button with the circling indicator for up to 30 minutes with no software installed. Also tried to do oupgrade with it erroring out "/usr/bin/oupgrade: local: line 378: not in a function". so cannot upgrade firmware either. does anyone have a fix for this? Wanted to do a serial install of firmware, but instructions say to connect zip drive and connect usb cable to computer with the omega off. Cannot connect with terminal with omega in off position , saying no such device in putty window. So how can it be done with the omega not on and booted to enable connection?

  • @jra8462 The first thing I would check is whether your Omega is connected to your wifi.

    Frist step is to connect to the device via the serial console:


    With putty you need to first determine the correct com/serial port and ensure you set the connection type to serial and set the baud rate to 115200. The Omega must be powered on for any of this to work.

    Once you are connected to the serial console you can check the wifi connection, use the command: ifconfig
    This will list a few network devices but the one you are interested in is named apcli0 . Check it has a valid ip address, mine is highlighted in bold below:

    apcli0 Link encap:Ethernet HWaddr 40:AA:2B:C3:0E:2A
    inet addr: Bcast: Mask:

    If the device has a valid ip address you then check it is connected to the internet, an each check is to ping google's main DNS server:


    If this gives you an error then you're not connected to the internet so any firmware update etc would fail.

    If you let us know how you go with this we will have a better idea of where your issue lies

  • @jra8462 said in firmware upgrade error:

    Also tried to do oupgrade with it erroring out "/usr/bin/oupgrade: local: line 378: not in a function". so cannot upgrade firmware either. does anyone have a fix for this?

    Probably you have an Omega2 Pro with v0.3.0 b207 or lower firmware.
    Please read this post Official Resolution: oupgrade not working on Omega2 Pro factory firmware of @Lazar-Demin.

  • Thank you, crispyoz, and gyorgy farkas, I had verified the wifi was working and also serial communications. The problem was ytring to update firmware or install console, always errored out or just sat there with progress indicator circling regardless of time spent, without any download of software or installing happening. With your help and hints, I succeeded in updating oupgrade, and then updating firmware, and installing console. The problem was in the oupgrade file origionally installed. Again thanks, everything working as it should now.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.