We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Can't setup with Linux

  • Hi

    I can't seem to setup my Onion.
    Im using linux ubuntu and when im plugged in with a good cable (led stops blinking) there is no access point showing up.
    I would like to use the gui but i tried the Terminal too. I read on some other thread that there may be a mixup with OSX setup commands and Linux. Is this possible?
    I installed "Screen" and when i run Step 5, i get [Screen is terminating].

    Could somebody help? Thank you!

  • Hi @marc-rozender, what command did you use to connect to the serial terminal on Linux?

  • Hi Boken
    I used just like it says in the setup page :
    screen /dev/tty.SLAB_USBtoUART 115200

  • Hi @marc-rozender, yeah, on Linux you should use screen /dev/ttyUSB0 115200 to connect to the serial terminal.

  • Hi Boken
    I tried that and all i get is a fully blank terminal.

  • administrators

    This post is deleted!

  • administrators

    @marc-rozender have you tried pressing enter to activate the terminal?

    If you have, then let's make sure that the Omega is actually being mapped to /dev/ttyUSB0
    Can you unplug your Omega and run ls /dev/tty*
    And then plug it in and run ls /dev/tty* again and post the output?

    Edit: Also, I've fixed the typo in Step 4 of the Connecting with Serial in Linux guide

  • Hi Lazar looks like its being mapped....

    Here is the output unplugged:

    [bunchy@Lapbunchy ~]$ sudo ls /dev/tty*
    [sudo] password for bunchy:
    /dev/tty /dev/tty20 /dev/tty33 /dev/tty46 /dev/tty59 /dev/ttyS12 /dev/ttyS25
    /dev/tty0 /dev/tty21 /dev/tty34 /dev/tty47 /dev/tty6 /dev/ttyS13 /dev/ttyS26
    /dev/tty1 /dev/tty22 /dev/tty35 /dev/tty48 /dev/tty60 /dev/ttyS14 /dev/ttyS27
    /dev/tty10 /dev/tty23 /dev/tty36 /dev/tty49 /dev/tty61 /dev/ttyS15 /dev/ttyS28
    /dev/tty11 /dev/tty24 /dev/tty37 /dev/tty5 /dev/tty62 /dev/ttyS16 /dev/ttyS29
    /dev/tty12 /dev/tty25 /dev/tty38 /dev/tty50 /dev/tty63 /dev/ttyS17 /dev/ttyS3
    /dev/tty13 /dev/tty26 /dev/tty39 /dev/tty51 /dev/tty7 /dev/ttyS18 /dev/ttyS30
    /dev/tty14 /dev/tty27 /dev/tty4 /dev/tty52 /dev/tty8 /dev/ttyS19 /dev/ttyS31
    /dev/tty15 /dev/tty28 /dev/tty40 /dev/tty53 /dev/tty9 /dev/ttyS2 /dev/ttyS4
    /dev/tty16 /dev/tty29 /dev/tty41 /dev/tty54 /dev/ttyprintk /dev/ttyS20 /dev/ttyS5
    /dev/tty17 /dev/tty3 /dev/tty42 /dev/tty55 /dev/ttyS0 /dev/ttyS21 /dev/ttyS6
    /dev/tty18 /dev/tty30 /dev/tty43 /dev/tty56 /dev/ttyS1 /dev/ttyS22 /dev/ttyS7
    /dev/tty19 /dev/tty31 /dev/tty44 /dev/tty57 /dev/ttyS10 /dev/ttyS23 /dev/ttyS8
    /dev/tty2 /dev/tty32 /dev/tty45 /dev/tty58 /dev/ttyS11 /dev/ttyS24 /dev/ttyS9

    and plugged:

    [bunchy@Lapbunchy ~]$ sudo ls /dev/tty*
    /dev/tty /dev/tty21 /dev/tty35 /dev/tty49 /dev/tty62 /dev/ttyS17 /dev/ttyS30
    /dev/tty0 /dev/tty22 /dev/tty36 /dev/tty5 /dev/tty63 /dev/ttyS18 /dev/ttyS31
    /dev/tty1 /dev/tty23 /dev/tty37 /dev/tty50 /dev/tty7 /dev/ttyS19 /dev/ttyS4
    /dev/tty10 /dev/tty24 /dev/tty38 /dev/tty51 /dev/tty8 /dev/ttyS2 /dev/ttyS5
    /dev/tty11 /dev/tty25 /dev/tty39 /dev/tty52 /dev/tty9 /dev/ttyS20 /dev/ttyS6
    /dev/tty12 /dev/tty26 /dev/tty4 /dev/tty53 /dev/ttyprintk /dev/ttyS21 /dev/ttyS7
    /dev/tty13 /dev/tty27 /dev/tty40 /dev/tty54 /dev/ttyS0 /dev/ttyS22 /dev/ttyS8
    /dev/tty14 /dev/tty28 /dev/tty41 /dev/tty55 /dev/ttyS1 /dev/ttyS23 /dev/ttyS9
    /dev/tty15 /dev/tty29 /dev/tty42 /dev/tty56 /dev/ttyS10 /dev/ttyS24 /dev/ttyUSB0
    /dev/tty16 /dev/tty3 /dev/tty43 /dev/tty57 /dev/ttyS11 /dev/ttyS25
    /dev/tty17 /dev/tty30 /dev/tty44 /dev/tty58 /dev/ttyS12 /dev/ttyS26
    /dev/tty18 /dev/tty31 /dev/tty45 /dev/tty59 /dev/ttyS13 /dev/ttyS27
    /dev/tty19 /dev/tty32 /dev/tty46 /dev/tty6 /dev/ttyS14 /dev/ttyS28
    /dev/tty2 /dev/tty33 /dev/tty47 /dev/tty60 /dev/ttyS15 /dev/ttyS29
    /dev/tty20 /dev/tty34 /dev/tty48 /dev/tty61 /dev/ttyS16 /dev/ttyS3

  • administrators

    @marc-rozender hmm and you've tried pressing Enter and it does nothing?
    Have you been able to connect with SSH?

  • Yes, the terminal screen just goes blank. I tried PuTTY SSH but no luck.
    I finally found the access point by setting up a hidden network. Its Omega-132D.
    I can then go to the setup wizard page on the browser but then everything is greyed out and i can't do anything. The "login to Omega" doesnt go green either by itself or by clicking on it.

  • administrators

    @marc-rozender can you try using Chrome or Opera for the Setup Wizard? There's a bug that shows up when using Firefox, Safari, or IE.

    Once you go through the setup wizard, lets try connecting through SSH again.

  • I played a long time around after i got my two onions today. Unfortunately i also not was able to connect with the USB Cable in Linux. I do work with the Debian based LinuxMint.
    I could not figure out how to map the /dev/ttyUSB0. I had everything else but never saw this ttyUSB0. Just had a lot of ttyS*. Finaly i gave up and tried with Windows10 in a VirtualBox. So i could finally connect with the USB Cable.

    I was wondering that I never saw my own wireless. Always appeared everything else just never my own wifi i have at home. In the end I found out, that i optimized my wlan and did put a ID over 10 (13 in my case). Then the Onion never saw mine. Just wifi with ID equal 1. When i changed my ID back to one, i just saw it and could finally connect and Update.

  • @Luciano-S I recently switched to a Linux-based computer as my MacBook is experiencing some issues. I found that for some distributions, you might need to use sudo to run screen /dev/ttyUSB0 115200 command. If you get a chance, please give this a try to see if it will allow you to successfully connect to the Omega via serial terminal.


  • @Boken-Lin , i made the test .. i had to plug in in a certan USB Slot. My computer has about eight with the 2 USB3 ports. I found it now and i got also displayed /dev/ttyUSB0.

    Then i connected without sudo ... and it works.

  • @Boken-Lin

    Personally I use picocom.

    picocom -b 115200 /dev/ttyUSB0

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.