We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Mount File System Remotely using SSHFS

  • I am trying to mount the onion's remote file system using sshfs over my network. I'm using the following command from my linux terminal:

    sshfs root@ /mnt/onion -o allow_other

    It connects successfully and asks for the password: onioneer

    Then, I receive the message: "remote host has disconnected". I have also tried the directory /usr with no luck. I have successfully ssh'ed into the onion so remote connection is not the issue.


  • I do not have the onion here at work with me, but there is at least one error in your sshfs string:
    the slash must be after the colon.

    sshfs root@šŸ˜• /mnt/onion -o allow_other

    and not

    sshfs root@ /mnt/onion -o allow_other

    Also sshfs is really slow: http://wdtvforum.com/main/index.php?topic=5393.0
    It'd use it for temporary acts, but in general you should definitely have a look to NFS or Samba.

    @Janus-Sanders said:

  • did you

    opkg install openssh-sftp-server

  • @Johannes-Zellner I ran the command opkg install openssh-sftp-server and it crashed the system. After a factory reset, I could no longer connect to my home network and have been working for hours to restore it.

    Lucky, I have a second Onion in which I ftp'ed successfully into it without installing additional packages. This seems to be the best route for moving packages and files to/from the onion at this point.

    Thanks for your help.

  • @Janus-Sanders oops, I'm very sorry about that. But...

    1. I can't really believe that installing a package "crashes" the omega so that it needs a factory reset
    2. openssh-sftp-server is the package you need for sshfs

    I use sshfs with the omega since a few months w/o problems and with different versions of the operating system (currently b266).

  • @Johannes-Zellner I think you're correct. Sorry for the rash explination about crashing. I don't think that's what happened. From further research, I think there's an issue with losing configuration settings and possibly system dependancies in /etc when a factory reset is performed.

    At this point, I'm not really sure what happened and I'm in the process of rebuilding the system. Good to hear that you've had success with sshfs!

  • Hi @Janus-Sanders, hmmm, installing a package on the Omega shouldn't crash it... Can you give us a little bit more description on what happened? This way we might be able to figure out what the issue might be and hopefully resolve it in the future.


Looks like your connection to Community was lost, please wait while we try to reconnect.