We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Trying to install pc-ble-driver-py library

  • Hi all, I'm trying to install the pc-ble-driver-py library on my Onion Omega 2+
    I have already installed full version of python3 and pip3.

    When I runned "pip install pc-ble-driver-py" I got this:

    root@Omega-6E16:~# pip3 install pc-ble-driver-py
    Collecting pc-ble-driver-py
      Downloading https://files.pythonhosted.org/packages/38/6f/0bd202ea117a2c944234                             
     992f4d9f8c8b68964470dacc34164f20111712a9/pc_ble_driver_py-0.11.4.tar.gz (8.0MB)
        100% |████████████████████████████████| 8.0MB 262kB/s
    Collecting wrapt (from pc-ble-driver-py)
      Downloading https://files.pythonhosted.org/packages/82/f7/e43cefbe88c5fd371f4c                             
    Collecting future (from pc-ble-driver-py)
      Downloading https://files.pythonhosted.org/packages/45/0b/38b06fd9b92dc2b68d58                             
     b75f900e97884c45bedd2ff83203d933cf5851c9/future-0.18.2.tar.gz (829kB)
        100% |████████████████████████████████| 829kB 434kB/s
        Error [Errno 12] Out of memory while executing command python setup.py egg_info
    Could not install packages due to an EnvironmentError: [Errno 12] Out of memory

    I checked the memory and it should have enough:

    root@Omega-6E16:~# free -m
                 total       used       free     shared    buffers     cached
    Mem:        124808      42284      82524       9084       1192      18852
    -/+ buffers/cache:      22240     102568
    Swap:            0          0          0

    I have tried to download the .tar.gz and install it maually by typing "python3 setup.py build ":

    root@Omega-6E16:~# cd pc-ble-driver-py-0.15.0/
    root@Omega-6E16:~/pc-ble-driver-py-0.15.0# ls
    CMakeLists.txt        azure-pipelines.yml   swig
    LICENSE               pc_ble_driver_py      tests
    MANIFEST.in           pyproject.toml        tox.ini
    README.md             requirements-dev.txt
    README.rst            setup.py
    root@Omega-6E16:~/pc-ble-driver-py-0.15.0# python3 s
    setup.py  swig/
    root@Omega-6E16:~/pc-ble-driver-py-0.15.0# python3 setup.py build
    Traceback (most recent call last):
      File "setup.py", line 42, in <module>
        from skbuild import setup
    ModuleNotFoundError: No module named 'skbuild'

    I installed the module

    root@Omega-6E16:~/pc-ble-driver-py-0.15.0# pip3 install scikit-build

    And I tried again with "python3 setup.py build " and this is what I got:

    root@Omega-6E16:~/pc-ble-driver-py-0.15.0# python3 setup.py build
    Traceback (most recent call last):
      File "/usr/lib/python3.6/site-packages/skbuild/setuptools_wrap.py", line 560, 
    in setup 
           cmkr = cmaker.CMaker(cmake_executable)
      File "/usr/lib/python3.6/site-packages/skbuild/cmaker.py", line 95, in __init_                                     _
        self.cmake_version = get_cmake_version(self.cmake_executable)
      File "/usr/lib/python3.6/site-packages/skbuild/cmaker.py", line 82, in get_cma
        "Problem with the CMake installation, aborting build. CMake executable is %s 
    " % cmake_executable)
    Problem with the CMake installation, aborting build. CMake executable is cmake

    So then when I tried to install cmake this error showed up:

    root@Omega-6E16:~/pc-ble-driver-py-0.15.0# pip3 install cmake
    Collecting cmake
      Downloading https://files.pythonhosted.org/packages/0a/37/2ff538a860a694780e1f2150e0616f7202c15a5dde0833ee09050002c091/cmake-3.20.2.tar.gz
      Installing build dependencies ... done
    Building wheels for collected packages: cmake
      Running setup.py bdist_wheel for cmake ... error
      Failed building wheel for cmake
      Running setup.py clean for cmake
    Failed to build cmake
    Installing collected packages: cmake
      Running setup.py install for cmake ... error
    Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-sv4qux6c/cmake/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-x0nmuya1/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-install-sv4qux6c/cmake/

    Any suggestions about installing it with pip or manually?

  • @Jorgehst Check out python light.

  • This post is deleted!

  • @crispyoz I already did it but didn't work, got the same message

Looks like your connection to Community was lost, please wait while we try to reconnect.