We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Arch Linux

  • Has anyone got the serial driver installed under Arch Linux? I am learning now how to use make to get the driver installed.

  • administrators

    Have you tried the steps from the Linux section of this guide?

    We haven't tried it out on ArchLinux but it works on Ubuntu and Debian.
    Let us know how it goes.

  • When I try running make inside of the unzipped folder this I what I see. For now I'm using the web console until I have more time later this week to play around.

    make -C /lib/modules/4.2.5-1-ARCH/build M=/home/extremo/Downloads/Onion_Omega/Linux_3.x.x_VCP_Driver_Source modules
    make[1]: Entering directory '/usr/lib/modules/4.2.5-1-ARCH/build'
    make[1]: *** No rule to make target 'modules'.  Stop.
    make[1]: Leaving directory '/usr/lib/modules/4.2.5-1-ARCH/build'
    Makefile:4: recipe for target 'all' failed
    make: *** [all] Error 2

  • I'm on Arch as well, it works out of box. I'm guessing it's because I've got Arduino installed.

    Regarding the error you posted, might be good to post it in Arch's forum as well.

  • I was able to connect to the /dev/USB0 device tonight without installing the driver. Haven't tried accessing my expansion boards though.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.