We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Step-by-Step Video Instructions for Mobile Network File Server (Cloud)?



  • Hi Onioneers,

    Back in 2018 I purchased the Onion Omega 2+, but I have never done anything (i.e., project) successfully with it. I am a complete noob, with zero education or experience in this field. Moreover, trying to figure out how to use it has been anything but intuitive.

    Then life gets in the way, and I am always overwhelmed, or have something going on. For years I told myself with things slow down I'll figure out how to use the onion. It has been 5 years since I purchased this thing; life continues to be hectic. As such, despite everything going on I am determined to give this another go, and build my own cloud.

    https://docs.onion.io/omega2-project-book-vol1/network-file-server.html

    Recently I am fired it back, up and it works. I can log in, and get to the home screen. I downloaded an app or two, but that’s it. I really want to create my own cloud (aka the Mobile Network File Server project found in Volume 1... is there a Volume 2?). Granted I have no idea how to use Samaba. I downloaded the Samba files hyperlinked under section titled ample configuration files, but I have no idea what to do now.

    If someone knows of a step-by-step instructional video, please let me know. I’ve searched YouTube and Reddit. Have not found anything.

    Thank you,



  • @Amalee welcome back 🙂

    I'm not aware of any such video however the steps look well written so perhaps you can elaborate on which steps you have completed, any specific probems you are experiencing or if you require any additional clarifications that would assist you.



  • This post is deleted!


  • Hi Crispyoz,

    Thank you for responding. I really appreciate it.

    Here is a snippet of what I tried.

    First, you can see that the apcli0 is does not have the most RX bytes and TX bytes as suggested in the instructions.

    Second, you can see in Step 4 when I tried to configure Samba an error message popped up that said permission denied.

    Any advice?

    Please & Thank You

    ![alt text](Screenshot of Onion Omega.PNG image url)



  • @Amalee The permission error is becasue you are trying to execute /etc/config/samba, this is a configuration file not an executable file. Can you post the content of /etc/config/samba. Also post the results of ps command.

    I assume you installed samba server using opkg install samba36-server , what other steps have you taken? By default samba listens on all interfaces, you can modify /etc/config/samba to force it to listen only on a single interface by adding the line:

    option interfaces 'apcli0'

    or

    option interfaces '192.168.10.93'

    You will also need to add firewall rules to allow access to samba ports, take a look at /etc/config/firewall and add rules for all ports:

    config rule
    option target 'ACCEPT'
    option src 'wwan'
    option proto 'udp'
    option dest_port '137'
    option name 'SAMBA 137'
    option enabled '1'

    config rule
    option target 'ACCEPT'
    option src 'wwan'
    option proto 'udp'
    option dest_port '138'
    option name 'SAMBA 138'
    option enabled '1'

    config rule
    option target 'ACCEPT'
    option src 'wwan'
    option proto 'tcp'
    option dest_port '139'
    option name 'SAMBA 139'
    option enabled '1'

    config rule
    option target 'ACCEPT'
    option src 'wwan'
    option proto 'tp'
    option dest_port '445'
    option name 'SAMBA 445'
    option enabled '1'

    Probably easier to reboot then.

    Before setting up the firewall rules I usually just stop the firewall and troubleshoot the issue and then setup the rules and restart the firewall.

    Stopping the firewall: service firewall stop

    Let us know what steps you have taken and how you are trying to access your omega samba device, using a MAC/Windows/*nix??



Looks like your connection to Community was lost, please wait while we try to reconnect.