We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

[RESOLVED] Wifi does not work

  • I'm having a problem connecting to a wifi network with the Omega. I haven't used it in a while but since I finally got the battery dock I wanted to put it to good use. I have used the Omega in the past and it was working, but that was back when we originally got them shipped.

    I reset the firmware by holding down the button for 10 seconds and logged into the admin panel. Filled out the wifi info and it just got stuck, didn't see any feedback that it was connected. Restarted it and my network info was gone. So I went into the Terminal and tried configuring with the wifisetup script. This is what I get:

    /tmp # wifisetup
    Onion Omega Wifi Setup                                                                                                                                                            
    Select from the following:                                                                                                                                                        
    1) Scan for Wifi networks                                                                                                                                                         
    2) Type network info                                                                                                                                                              
    q) Exit                                                                                                                                                                           
    Selection: 1                                                                                                                                                                      
    Scanning for wifi networks...                                                                                                                                                     
    Select Wifi network:                                                                                                                                                              
    ***List of networks***                                                                                                                                                                
    Selection: 6                                                                                                                                                                     
    Network: ****                                                                                                                                                              
    Authentication type: psk2                                                                                                                                                         
    Enter password: ****                                                                                                                                                  
    /usr/bin/wifisetup: line 1: uci: not found                                                                                                                                        
    /usr/bin/wifisetup: line 1: uci: not found                                                                                                                                        
    /usr/bin/wifisetup: line 1: uci: not found                                                                                                                                        
    > Connecting to **** network using intf 1...                                                                                                                                
    /usr/bin/wifisetup: line 1: uci: not found                                                                                                                                        
    /usr/bin/wifisetup: line 1: uci: not found                                                                                                                                        
    /usr/bin/wifisetup: line 1: uci: not found                                                                                                                                        
    /usr/bin/wifisetup: line 1: uci: not found                                                                                                                                        
    /usr/bin/wifisetup: line 1: uci: not found                                                                                                                                        
    /usr/bin/wifisetup: line 1: uci: not found                                                                                                                                        
    /usr/bin/wifisetup: line 1: wifi: not found                                                                                                                                       
    > Checking wwan device status...                                                                                                                                                  
    > wwan is not up!!                                                                                                                                                                
    > Checking internet connection...                                                                                                                                                 
    > ERROR: request timeout, internet connection not successful                                                                                                                      
    /usr/bin/wifisetup: line 1: uci: not found                                                                                                                                        
    > No network on intf 1                                                                                                                                                            
    /usr/bin/wifisetup: line 1: uci: not found                                                                                                                                        
    > Network intf 1 is not set to sta mode                                                                                                                                           
    > Done!

    What are my options now to get this working?

  • administrators

    @Marcin-Pawelek Not a problem, you will just have to modify a file by hand.

    Add the following to /etc/config/wireless :

    config wifi-iface
            option device 'radio0'
            option mode 'sta'
            option network 'wwan'
            option ssid 'YourWifiSsid'
            option encryption 'psk2'
            option key 'YourWifiPassword'
            option disabled '0'

    Where YourWifiSsid and YourWifiPassword are your actual SSID and wifi password, respectively.
    Then run wifi. You should then be connected to the internet. Then, try updating your firmware.

    Let me know how it goes
    alt text

  • @Lazar-Demin No luck. Apparently wifi command does not exist:

    ~ # vi /etc/config/wireless                                                                                                                 
    ~ # wifi
    /bin/ash: wifi: not found

    And this is very weird:

    ~ # oupgrade -check                                                                                                                         
    /usr/bin/oupgrade: line 235: uci: not found
    > Device Firmware Version: unknown b
    > Checking latest version online...
    > ERROR: request timeout, internet connection not successful

    Somehow I have an unknown firmware but I never installed custom firmware. I only reset with the hold down button for 10 seconds method.

    Thanks for your help

  • ok, got it working. After a restart it connected to my wifi. Apparently I was on a very old version of the firmware 0.0.3 b189. After the update to 0.1.4 b330 things look a lot different. Seems like I'm back up and functional. Thanks for your help!

  • administrators

    @Marcin-Pawelek Not a problem, glad it worked out!

Looks like your connection to Community was lost, please wait while we try to reconnect.