We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Serial connection not possible, not detected

  • I've upgraded the firmware to the recent release, 0.0.4 (b216,) and my systems no longer recognizes the Onion Omega as a usb-serial device on the mini-dock or arduino dock. I performed a factory reset, firmware version remains the same but still cannot access the Onion Omega via com port. I am able to connect to the console and web interface via the AP mode and in WiFi host mode.

    Any help is much obliged

  • More specifically:

    I connected for the first time to the Arduino dock and powered via the micro-usb adapter, first noticing my system didn't recognize it as a host device for the Onion Omega or as an Arduino.

    Then I reconnected the mini dock, thinking it was just the Arduino dock thing but also the mini dock ceased recognizing the host device. Then I updated the firmware and performed a factory reset but to no avail on restoring a serial connection.

  • @Matthew-Hiebert Hmmm, the detection of USB-serial device on your computer isn't related to the firmware on the Omega at all. In fact, even if you unplug the Omega from the dock, it should still be able to connect. Were you able to get USB-to-Serial working previously?

    BTW, Arduino Dock does not have a USB-to-Serial chip, so it shouldn't show up.

  • @Boken-Lin Yes, previously it was operational. It was operational since I received the device last and first used it Tuesday. Upon connecting to three Windows 8.1 systems and installing the cp210x driver I was able to connect using the wired USB-to-Serial interface using SecureCRT and the device manager reported the COM port.

    Conceding that the firmware has no relation to this issue, what else would cause the USB-to-Serial interface to cease operation?

  • @Matthew-Hiebert There's a few possibilities. It could be that the driver on your Windows machine is malfunctioning. You can try uninstalling the USB-to-Serial driver and reinstalling it again. It could also be that the Expansion dock is broken. Can you try if you can get the dock to work by reinstalling the driver?

  • @Boken-Lin I did that on all of the systems, three of them. Two windows 10 and one windows 8.1 workstation.

  • I have the same problem. I also have developed with Silabs CP210x chip and that device has no problems connecting to my PCs (Win10 & WinXP), the systems just don't recognize the device, my own device is recognized instantly . Something is wrong here.

  • @Matthew-Hiebert @Robert-Stewart Can both of you send me a clouse-up of the front and back side of your docks? I want to determine if this is caused by a loose solder or something.

  • MiniDockTop.jpg DockBottom.jpg

    Images of Mini Dock with Silabs chip.
    I have Arduino Dock as well, however this board doesn't have SiLabs chip

  • Hi @Robert-Stewart, I'm not able to see anything wrong with the board itself. The only solution I can think of right now is to send you another mini dock for you to try out. Can you confirm that your address has not changed from the previous shipment?

  • Thanks, the address is the same. I have since tried another device which is simply a USB to serial board using the same chip you are and that works fine. So it appears as you say it is a hardware fault, however everything else works.

  • @Robert-Stewart Ok, I have submitted a request to have it sent šŸ™‚

  • I recently needed to use the serial. Previously in came up in windows as an unrecognizable device. I have since changed the USB cable and it worked. The USB cable I had was a cheapy and stopped being able to charge my phone (with a lightning adapter). It still powered fine.

    Might be worth changing cables first

  • @Sawyer-McBride is a scholar of high order. So elementary I never even considered it. With an alternate cable, the device manager successfully reported the mini dock as a serial COM port of which I can connect with my terminal client. Will test on my other computers and report back.

  • @Matthew-Hiebert glad to be of service fine sir!

  • For anyone else running into this problem, I was using this on an Ubuntu 14.04 system (stock cp210x driver). The serial port was flaky, meaning I would get part of the kernel log, then the serial messages would stop. It might or might not come back if I reset the Omega. I tried other USB ports and several different cables as well.

    I changed to another machine and everything worked fine (meaning reliably). Morale of the story: if you're seeing weird USB/serial behavior, try using another PC.

    Also, I tried connecting it through a USB hub and Linux didn't see the USB-serial anymore. If you're trying it in a hub and it's not working, try skipping the hub.

    Hope that helps a random Internet passerby!

  • Just tried the expansion dock I just received and having the same issue as above on win 10. I'll try on another pc. But I did try a variety of cables and USB ports.

    This is concerning as you have to use serial to reconfigure WiFi. Unlike the particle.io boards that have a hard button for resting just WiFi

  • Hi @Shai-Perednik, I just want to check back with you to see if had any luck connecting the the serial terminal using another PC? Please let us know. Hopefully we can figure out the reason why it's not getting detected and get it fixed. You are absolutely right, having a hard line is very important when configuration via WiFi doesn't behave.


  • Hi @Boken-Lin ,

    I tried out the two omegas that I had for the first time, unfortunately both won't work.

    AP is advertised, but can't connect. Same with tty. (see attached)

    Screen Shot 2016-03-31 at 9.20.40 PM.png

    Any help on how to debug greatly appreciated.


    PS: power switch on both mini and regular dock snapped in second use šŸ˜ž

  • administrators

    For the serial connection, it looks like your computer isn't detecting the Omega, there should be a /dev/tty.SLAB_USBtoUART listed when you run ls /dev/tty.*
    Have you installed the driver?

    And for the wifi connection, can you describe in more detail how it doesn't connect?

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.