Serial connection not possible, not detected

  • Hi @Boken-Lin ,

    I tried out the two omegas that I had for the first time, unfortunately both won't work.

    AP is advertised, but can't connect. Same with tty. (see attached)

    Screen Shot 2016-03-31 at 9.20.40 PM.png

    Any help on how to debug greatly appreciated.


    PS: power switch on both mini and regular dock snapped in second use :(

  • administrators

    For the serial connection, it looks like your computer isn't detecting the Omega, there should be a /dev/tty.SLAB_USBtoUART listed when you run ls /dev/tty.*
    Have you installed the driver?

    And for the wifi connection, can you describe in more detail how it doesn't connect?

  • Hi @Lazar-Demin ,

    I should've given bit more info in my earlier post. My bad.

    1. UART
      Yes, I have installed Silicon Labs driver. but still I don't get to see the device registered under /dev/tty.*

    2. HTTP
      I get to see AP advertised (as shown in the screenshot), but when tried to access the page omega-150e.local (or the IP address mentioned in the doc), the page (setup wizard) is not reachable.

    I would like to get the HTTP part working soon for a project. Any help on that would be greatly appreciated.


  • Update

    Please ignore my comment on UART above. After rebooting my mac, I could see the tty and screen to it.

    The HTTP worked fine as well. Thanks @Lazar-Demin !


  • administrators

    @Rajesh-L glad to hear it worked out!

  • Sorry @Lazar-Demin ,

    HTTP is still a issue for me . Looks like I'm doing something wrong.
    Spent last hour debugging with no luck.

    Here are some traces..

    server on omega - OK

    root@Omega-150E:/# wget http://localhost
    --2015-09-13 18:52:21--  http://localhost/
    Resolving localhost...
    Connecting to localhost||:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 5334 (5.2K) [text/html]
    Saving to: 'index.html'
    index.html          100%[=====================>]   5.21K  --.-KB/s   in 0s
    2015-09-13 18:52:21 (32.3 MB/s) - 'index.html' saved [5334/5334]

    my ip address - looks OK (connected to omega AP)

    rajesh at Rajeshs-MacBook-Air in ~
    $ ifconfig | grep -A3 en0
    	ether b8:e8:56:3c:ac:a2
    	inet6 fe80::bae8:56ff:fe3c:aca2%en0 prefixlen 64 scopeid 0x4
    	inet netmask 0xffffff00 broadcast
    	nd6 options=1<PERFORMNUD>
    	media: autoselect

    route on my laptop (excluding ipv6)

    $ netstat -nr
    Routing tables
    Destination        Gateway            Flags        Refs      Use   Netif Expire
    default          UGSc            7        0     en0
    127                UCS             1        0     lo0          UH              7      752     lo0
    169.254            link#4             UCS             1        0     en0
    192.168.3          link#4             UCS             2        0     en0        b8:e8:56:3c:ac:a2  UHLSr           8      350     en0     link#4             UCS             1        0     en0   link#4             UCS             2        0     en0      ff:ff:ff:ff:ff:ff  UHLWbI          1        5     en0

    curl , ping or telnet fails

    rajesh at Rajeshs-MacBook-Air in ~
    $ curl
    curl: (7) Couldn't connect to server

    Am I missing something here ?


  • Update

    Gave up on the board and picked up a new one.

    This looks better - curl works from my mac.

    $ curl -v http://omega-158a.local -o /tmp/omega.html
    * Rebuilt URL to: http://omega-158a.local/
    *   Trying fe80::42a3:6bff:fec1:158b...
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
      0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0* Connected to omega-158a.local (fe80::42a3:6bff:fec1:158b) port 80 (#0)
    > GET / HTTP/1.1
    > User-Agent: curl/7.41.0
    > Host: omega-158a.local
    > Accept: */*
    < HTTP/1.1 200 OK
    < Connection: Keep-Alive
    < Keep-Alive: timeout=20
    < ETag: "5e-14d6-55f5b94d"
    < Last-Modified: Sun, 13 Sep 2015 17:58:37 GMT
    < Date: Sun, 13 Sep 2015 18:41:31 GMT
    < Content-Type: text/html
    < Content-Length: 5334
    { [2674 bytes data]
    100  5334  100  5334    0     0   9928      0 --:--:-- --:--:-- --:--:--  744k
    * Connection #0 to host omega-158a.local left intact

    However, neither of the browsers (chrome, FF, safari) succeed to load the setup wizard.
    Screen Shot 2016-04-03 at 8.06.36 PM.png

    Screen Shot 2016-04-03 at 7.59.31 PM.png

    Any updates (firmware upgrade, etc) to be made ?


  • administrators

    @Rajesh-L if you access the Omega via serial, you can run the wifisetup command to connect to a wifi network, and then the oupgrade command to download and install the latest firmware. You can check out the Getting Started guide for OS X for more details.

    Let me know how it goes.

  • @Lazar-Demin, oupgrade solved the UI issues. But I missed the opportunity to see the 'first user' experience of setting up as I was intending to use it as part of project that has zero setting to start with.

    I tried factory reset and the board stopped working.
    So, I'm dropping for now.

    Thanks !

  • administrators

    @Rajesh-L The Omega stopped working after a factory reset?

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.