Please check out the post by Krzysztof Skiba in Will an official KiCAD library and footprint be released for the Omega2S?.
The title is about the Omega2S, but Krzysztof Skiba gave us a link to files on Omega2 Kicad footprint & 3D shape.
Please check out the post by Krzysztof Skiba in Will an official KiCAD library and footprint be released for the Omega2S?.
The title is about the Omega2S, but Krzysztof Skiba gave us a link to files on Omega2 Kicad footprint & 3D shape.
The original firewall configuration is correct. The problem is the
config interface 'usb'
option ifname 'wwan0'
option proto 'dhcp'
After removing this from /etc/config/network, I can get internet on the mobile device after connecting to the Omega.
@Douglas-Kryder Thanks. Actually, I have already gone through those pages.
@William-Scott Thanks for the help. The Omega is set up as an access point and not a station. The system will access the internet through the modem's gateway. The cellular modem is connected to the Omega's USB. The apcli0 interface is actually unused.
The Omega acts as an hotspot router. Mobile devices will connect to the Omega's SSID and access internet through the cellular modem.
File /etc/config/wireless
config wifi-device 'radio0'
option type 'ralink'
option variant 'mt7628'
option country 'US'
option hwmode '11g'
option htmode 'HT40'
option channel 'auto'
option disabled '0'
option device_mode 'apsta'
option op_mode 'preference'
config wifi-iface 'ap'
option device 'radio0'
option mode 'ap'
option maxassoc '5'
option network 'wlan'
option ifname 'ra0'
option encryption 'psk2'
option key 'MyKey'
option disabled '0'
option ssid 'Omega-39FF'
config wifi-iface 'sta'
option device 'radio0'
option mode 'sta'
option ifname 'apcli0'
option encryption 'psk2'
option ssid 'YourSsidHere'
option key 'YourPasswordHere'
option network 'wwan'
option disabled '1'
I have modified the following zone in /etc/config/firewall - change list network 'wwan' to list network 'wlan':
config zone
option name 'usb'
option output 'ACCEPT'
option forward 'ACCEPT'
option masq '1'
option mtu_fix '1'
list network 'wlan'
list network 'usb'
option input 'ACCEPT'
Still cannot access internet from my mobile device after connecting to the Omega.
I am setting up the Omega2S as a hotspot router. A Huawei ME906s modem is connected to the USB. I can ping 8.8.8.8 from the Omega and can connect my mobile phone to the Omega through WiFi, but when I open the browser on my mobile phone, I cannot access internet.
Running ip addr shows
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc fq_codel state DOWN qlen 1000
link/ether 40:a3:6b:c0:3a:01 brd ff:ff:ff:ff:ff:ff
3: ra0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-wlan state UNKNOWN qlen 1000
link/ether 40:a3:6b:c0:39:ff brd ff:ff:ff:ff:ff:ff
inet6 fe80::42a3:6bff:fec0:39ff/64 scope link
valid_lft forever preferred_lft forever
4: usb0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen 1000
link/ether 02:1e:10:1f:00:00 brd ff:ff:ff:ff:ff:ff
inet 100.xxx.xx.x/29 brd 100.xxx.xx.x scope global usb0
valid_lft forever preferred_lft forever
inet6 fe80::1e:10ff:fe1f:0/64 scope link
valid_lft forever preferred_lft forever
5: br-wlan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
link/ether 40:a3:6b:c0:39:ff brd ff:ff:ff:ff:ff:ff
inet 192.168.3.1/24 brd 192.168.3.255 scope global br-wlan
valid_lft forever preferred_lft forever
inet6 fd1d:48c4:7633::1/60 scope global
valid_lft forever preferred_lft forever
inet6 fe80::42a3:6bff:fec0:39ff/64 scope link
valid_lft forever preferred_lft forever
6: apcli0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN qlen 1000
link/ether 40:a3:6b:c0:39:00 brd ff:ff:ff:ff:ff:ff
inet6 fe80::42a3:6bff:fec0:3900/64 scope link
valid_lft forever preferred_lft forever
The following is my configuration:
/etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd1d:48c4:7633::/48'
config interface 'wlan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.3.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'usb'
option ifname 'usb0'
option proto 'dhcp'
config interface 'wwan'
option ifname 'apcli0'
option proto 'dhcp'
option hostname 'Omega-39FF'
config interface 'usb'
option ifname 'wwan0'
option proto 'dhcp'
/etc/config/firewall
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option disable_ipv6 '1'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'wlan'
config zone
option name 'wan'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
option network 'wwan'
option input 'ACCEPT'
config zone
option name 'usb'
option output 'ACCEPT'
option forward 'ACCEPT'
option masq '1'
option mtu_fix '1'
list network 'wwan'
list network 'usb'
option input 'ACCEPT'
config forwarding
option src 'lan'
option dest 'usb'
config rule
.....
I restarted the network after setting up the above configuration, but I still cannot access internet from my mobile phone's browser.
I also tried adding the following to the file /etc/firewall.user, but still it does not work.
iptables -t nat -A POSTROUTING -o usb0 -j MASQUERADE
iptables -A FORWARD -i wlan -o usb0 -j ACCEPT
Any help is appreciated. Thanks in advance.
@Caio-Mehlem Try to use the packages in your image directories. My packages are under ~/source/bin/packages/mipsel_24kc & ~/source/bin/targets/ramips/mt7688/packages. Copy the packages you need to your Omega2 and install them with opkg.
Please check New omega2 boots with Omega-0000 AP and wont let me connect and see whether this can fix your problem.
@Caio-Mehlem Perhaps you are using the wrong tree. Try https://github.com/OnionIoT/source/tree/lede-17.01. "wifi-warp-core" should be in the config menu.
Re: Wifi not working after building customized image
I have successfully built the customised image. The steps are pretty straight forward. I am using Docker on my MAC. Just follow the steps on Cross-Compiling C & C++ Programs: Part 1 - Setting Up the Build System to pull the latest source from the repository. If you do not have Docker, just follow the steps to install & set up Docker and create a container.
Run the image. After the container is up, you should be at ~/source. If not, just ensure you are at ~/source.
Run
make menuconfig
Select Onion -> WiFi, you should see "wifi-warp-core" there.
It should be automatically selected already. If it is not, just click "Y" to include this in the kernel.
If you need other libraries, drivers, modules, etc., just select those in the config menu.
There is a problem with compiling mosquito if libwebsockets is selected under Libraries, I disable
Network -> mosquito-ssl -> libwebsocket support
Save & Exit the config menu.
Usually, I will run
scripts/feeds update -a
If the packages I require are not there, I run
scripts/feeds install package_name
To compile the customised image, run
make V=s
If you encounter a problem with compiling MicroPython and you are not using it, just unselect it in the config menu.
Next month. From their staff by email directly. At least, this is what they told me.
According to Onion, they will roll out a new WiFi driver in April.
@Pavel-Metrokhin I suspect the ralink-wifi-mt76x8 module is not in the customized image. Can you let me know where the ralink-wifi-mt76x8 is located? I cannot find the module under '/lib/modules/4.4.74'. Is the name 'mt76x8.ko' same as that in the OnionIoT/OpenWRT-Packages?
@Pavel-Metrokhin I modified /etc/config/wireless to your setting, but still does not work. Whether using my old or this new setting, running 'ip addr' only shows
1: lo: <LOOPBACK,UP,,LOWER_UP> ......
......
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> .....
......
3: br-wlan: <BROADCAST,MULTICAST,UP,LOWER_UP> .....
......
4: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> .....
.....
The ra0 device does not show up.
We followed the steps on https://onion.io/2bt-cross-compiling-c-programs-part-1/ and customized the kernel by adding the huawei_cdc_ncm driver. We ran 'scripts/feeds update' & 'scripts/feeds install ralink-wifi-mt76x8' . Then ran 'make menuconfig' and selected Onion -> Ralink -> ralink-wifi-mt76x8.
But when we run the new kernel, we got the error message 'ra0(ralink) interface type not supported'.
Then we modify /etc/config/wireless to use the mac80211 driver instead:
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11g'
option channel '1'
option path 'platform/10300000.wmac'
option htmode 'HT20'
option disabled '0'
config wifi-iface
option device 'radio0'
option network 'wlan'
option mode 'ap'
option encryption 'psk2'
option ssid 'mySSID'
option key 'myPassword"
We ran 'wifi'. There were no errors, but we still could not see the Omega broadcasting the SSID. We also tried rebooting the system, but the wifi is still not working.
Any help is appreciated.
@György-Farkas Thanks! I finally got it working with the FT231X. For some reason, I need to reboot my MAC every time I make a connection to the Omega 2.
@Douglas-Kryder Yes, I have doubts too. I am buying this https://www.aliexpress.com/item/CJMCU-CP2102-MICRO-USB-to-UART-TTL-Module-6Pin-Serial-Converter-UART-STC-Replace-FT232-NEW/32499746290.html?spm=a2g0s.13010108.99999999.12.hvofLV.
@Douglas-Kryder Did not try connecting without the dock before. Took your suggestion. Tried connecting the RX0/TX0 pins using pin header connectors. Still cannot get a serial connection. Probably, I will wait for the expansion dock and try it again.
@Douglas-Kryder The power dock does not expose the RX0 and TX0 unfortunately.
@ccs-hello The SSID is actually the name of the access point.