but @Pavils-Jurjans I don't use nano on Onion/OpenWRT I know that on Linux utf-8 increases the size of the binary, so I suspect this is why OpenWRT disable it. I just looked at the nano makefile in my build system here are the arguments: --enable-tiny --disable-utf8 --without-slang --disable-color \ So if you build it you will need to update the makefile.