Can't register device on cloud [resolved]



  • @Lazar-Demin said in Can't register device on cloud:

    The issue came up when libcurl was updated to v7.53.0 in Lede, for whatever reason the URL to connect to the Cloud Device Server causes libcurl to throw an Invalid URL error.

    This never happened before, we're looking into it and will let you guys know when we know anything. Stay tuned for updates.

    That is good to know. Thanks.



  • Impossible to get the device online for me too. Very disappointed with this device.



  • I am also having this issue :( key is spelled correctly in my URL.



  • We all know this is very early days. And thats fine, bugs like that happen. What would be good tho is frequent updates regarding this issue please



  • This is being blamed on the libcurl library upgrade rather than a typo? I am having the same issue (device registered but shows offline in the cloud). Looking forward to a fix.


  • administrators

    @David-Vo we haven't changed the device-client code, the libcurl version has changed, at first glance it would seem that the issue lies in the libcurl update

    we will dedicate some time to fixing this next week



  • THis was reported 19 days ago and still no fix or response of proposed fix? Right during shipping of all these new devices? Kind of weak. I ahd so much higher hopes. Same issue here can connect, but device doesn't show online in cloud, but shows online from console. 0.1.7 firmware. Echo previous statement, frequent updates would be appreciated.



  • Same problem here :( I hope they resolve this quickly since it is useless not being able to control the Omega2 over the web using the cloud.
    I am thinking of waiting a couple of weeks before trying to start messing more with the Omega2, right now seems that everything is a mess, which shouldn't be as it was suppose to be a stable release. Hope the guys from Omega handle this quickly or people will get more disappointed and decide to go elsewhere.



  • @Lazar-Demin said in Can't register device on cloud:

    @David-Vo we haven't changed the device-client code, the libcurl version has changed, at first glance it would seem that the issue lies in the libcurl update

    we will dedicate some time to fixing this next week

    If the code was available for our perusal, it might have been fixed already a week ago...you know, just saying.



  • Great Markus Schuss after some try is then succeeded with the downgrade to
    omega2p-v0.1.5-b135.bin is the onion again online and the problem "fixed". Property the firmware version up to the latest "omega2p-v0.1.8-b145.bin" and only version the @Markus Schuss specified has worked with me.
    So I can continue to work with the Omega2 until then a newer firmware solves the problem.



  • same problem for me. Key spelled correctly.
    awaiting news on this, i dont want to play downgrade game, i'll wait till guys at Onion fix this.



  • @johan-ruijgt
    Hello
    I also found "k'y" in my omega request
    How do you solved this problem?



  • I also am having the problem with my Omega2 showing offline on the cloud. When I checked the URL I found that it has a double quote (") prior to the back slash before listen. ie: ...2a2"/listen?...

    I removed the double quote and was ablt to connect fine with wget.

    Any ideas on how to solve this problem?



  • @Lazar-Demin A curiosity question - How does an update in libcurl change the format of the URL being requested?

    Like others, I was able to copy the URL being shown in the device-client output, fix the request itself (replacing the ' with the e in 'key'), and wget it to successfully get my Omega2+ to show up in cloud manager.

    However, even with the cloud icon blue (and a notification on the cloud site that my device was online), I wasn't able to actually do anything to/with it.



  • So, it is now next week, where is the fix? I have 2 devices that wont come online because of this.



  • @Nick-D I upgraded to firmware version 0.1.8 b146, and now the symptoms have changed. The host name has changed to ds.onion.iop which won't resolved in DNS. Additionally the URL has changed to. The double quote I was seeing is gone, but now the URL is appended with the word "info".

    If I do a wget on the URL changing the hostname to ds.onion.io and removing info at the end of the URL I can connect. I wish there was a way we could figure out where device-client is pulling its information from so we could correct it.



  • Are not all devices showing this problem?



  • I guess my biggest question is how does someone like me, with no experience in this, get this thing fixed so it can be useful? Both of my devices are exhibiting the exact same behavior. Will not register during the setup wizard, and when I go into the cloud, there is an "Offline" entry for both devices.

    Model Onion Omega2+
    Revision R1
    Firmware 0.1.7 (b139)



  • Upgraded to b147 tonight and now the URL has changed to the URL being ds.onion.iop for me as well.

    What config file is this information pulled from? If it's something we could change manually, then we can make it work for ourselves while the team fixes the underlying issue.



  • It has been 20 days and still no sign of fix, other news like it does work with wifi, internet, programming and playing with Arduino OTA (no, I mean using like OTA and not arduinoOTA).


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.