We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ fails to connect to wifi

  • @Axel-Roest said in Omega2+ fails to connect to wifi:

    Now I just want to know how I can safely remove the default Access Point (ap) network, as that is a big security issue? Nothing about that in the Onion documentation of course...

    Please let us know what is that Omega2 AP "big security issue"?

  • @György-Farkas

    Any visible wifi network is bound to get attacks and WPA/2 crack attacks, which is an attack vector into your home or office network. Especially since OpenWRT is set up by default as an access point, which forwards traffic to the wwan network, i.e. your main network.
    I've set up firewall rules for the VLAN my iot devices are on, but still, less than optimal.

    Would you rather have an extra door or a solid wall in your bank vault?


  • @György-Farkas where the hell is the Onion team on this crap?

    Fix your wifi for the planet, or kindly give me my money back for ALL of the stuff I have purchased! I'm not going through and rebooting these things half a dozen times to get wifi AND USB disk space added to my device. The steps aren't even guaranteed to work.

  • This post is deleted!

  • Just to note that this has been yet another FULL three(3) years with no resolution on the current platform provided by the company. No matter what tips or tricks I tried, this piece of garbage STILL doesn't work here in Canada.
    Onion please give me a way to return this $h!T and get my money back, ALL of it.

    Just write up a doc, tested and verified if you have to that PROVES that this stuff works with a few extra steps. Don't make people read endless efforts and failures for HOURS of wasted time in trying to debug something that WORKED with the original firmware!

    Also, provide the ORIGINAL firmware on your download URL (http://repo.onioniot.com/omega2/images/) so that some of us can at least limp along with old crap rather thank a useless brick!
    @crispyoz @György-Farkas I don't know if you work for Onion but you seem VERY active here in the forums. Can you please connect this to the right folks and get this escalated?

  • Having this issue with a brand new Omega 2 Pro. Connecting to my WiFi network results in an infinite loop of the below message. I have tried messing around with compatibility settings in my Unify controller, but nothing resolves it. Also tried the suggestions made here. Unfortunately without success either. I can get it to connect to my iPhone as hotspot. Upgraded the firmware this way, but this didn't help either.

    Weirdly enough I have an Omega 1 and an Omega 2 (not plus) connecting without issues to this network...

    Interface apcli0 link up! (WPA2PSK AES)

  • @Paul-Koene For me the problem turns out to be in the length of the WiFi key. I had a key using the maximum allowed length. After reducing it to 31 chars it works fine.

  • In my case the problem was caused by long list of configured networks.

    wifimanager list

    I removed old wifi configurations using

    wifimanager remove -ssid <ssid>

    left only 2 up there and it works!

  • @crispyoz said in Omega2+ fails to connect to wifi:

    Вам понадобится работающий сервер rsyslog

    How to setting up resend logs to rsyslog?

  • @Alexandr-Didenko Please, could you start a new topic for this question? In forums it is good practice to do so when you ask a new question, it makes it easier for other people to later find this same question. Also, this thread was dead for 2 years and is now on top of the active list again (another bad habit).

  • Is this still an issue?

  • administrators

    @Stephen-Tunney please make a new topic if you're still experiencing this issue or have more to say about it.
    We'd like to avoid resurrecting very old threads.

Looks like your connection to Community was lost, please wait while we try to reconnect.