We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ fails to connect to wifi

  • After many hours, wasted on Wifi connection problem resolving, find solution for me.
    manually setup my Omega 2 WiFi network before start setup Omega2 (b160) in web mode after upgrade.

    My home WiFi Ap name is 'dd-wrt'
    Work usually in b/g mode with TKIP encription

    Most successfully variant for me at start point - has been set WEP and 'no password mode' on router for upgrade Omega2 to (b160) version of firmware.
    And I'd set back WPA-Personal mode and TKIP on Wifi router.
    After as I made this, I meet only the troubles with my Omega2 connections.

    My Omega 2 is:
    Firmware 0.1.10 (b160)
    Latest Firmware 0.1.10 (b160)

    Linux Omega-4C77 4.4.46 #0 Thu Feb 2 23:46:03 2017 mips GNU/Linux

    What I do for resolving connection problem:

    1. Made factory reset via web interface (

    2. Connect with Putty to (ssh, port 22) as root/onioneer

    3. root@Omega-4C77:~# vi /etc/config/wireless
      change your ssid and password AND COUNTRY! from 'US' to 'CAN'. It is needed for WiFi change channel restrictions (I'm not sure, but... it's work):
      warning: In Bold - options, which I changed from original values, but remember: it's must be in correlation with your wifi router settings. use omega2 linux command aps for router connect information. Something like a
      6 dd-wrt c8:3a:35:ea:29:58 WPAPSK/TKIP 52 11b/g NONE In in my case

    config wifi-device 'ra0'
    option type 'ralink'
    option mode '9'
    option channel 'auto'
    option txpower '100'
    option ht '20'
    option country 'CAN'
    option disabled '0'

    config wifi-iface
    option device 'ra0'
    option network 'wlan'
    option mode 'ap'
    option encryption 'psk2'
    option key '12345678'
    option ApCliEnable '1'
    option ApCliSsid 'dd-wrt'
    option ApCliAuthMode 'WPAPSK'
    option ApCliEncrypType 'TKIP'
    option ApCliPassWord '0015081975'
    option ssid 'Omega-4C77'

    1. Save your work in vi: <esc> :wq
    2. root@Omega-4C77:~#service network restart, reconnect Putty
    3. check 'root@Omega-4C77:~# ping' - it must work now
    4. opkg update
    5. opkg install mc - it is not very important step 😉
    6. go again into web interface (, btw, after as I connected to my Omega-4C77 AP again, it's already works as router - internet on PC is exists now), and step by step complete setup procedure.
      But do not choose WiFi network setup, it's defined already at step 3. Choose "pass step".

    Sorry for my Martian

  • So here's a good one for y'all couldn't get it to connect tried accessing it several times through web interface then through SSH no luck on either end

    But then right as I was about to give up on it I took a smoke break and came back and low and behold the web interface worked... I really want to beat my head against the screen...

  • I must have read all these messages a hundred times without success and finally bought a new router that uses AES instead of TKIP and that was the breakthrough. So after owning two Omega2+ for 6-8 months and not being able to get past first base I started to build something useful. Then I connected an I2C device to one of them and found that the i2cdetect python command does not work There are many many messages devoted to this topic and again the developers of this product sit on their hands.

    Life is too short to spend playing around with a bug ridden immature device such as the Omega2 so you've lost me Onion Community. Bin your Omega2 and sleep again at night.

  • @David-Lochlin je suis d'accord, dommage sa petite taille été un super avantage mais bon les développeurs on tellement passé de temps a vouloir le vendre a tout prix en dénigrant les autres produits du même genre qu'ils ont oublié de finir leurs propre produit.
    Au suivant!!!

  • @pvadam
    Good. Really good answer. Enable appcli did the trick !

  • I have had the same issue with an Onion 2+, the annoying thing is, to get connectivity to the internet to see if an update works....
    I fired up an Omega 1, which works no problem on the same wifi.
    Then connect the wifi on the Omega 2 to the AP on the Omega 1 and so through.
    So internet works, but wifi will still not connect to my wireless, so what has changed to make it not work between versions.

  • @MB hello, i suggest you do some searches on wifi router because last year there were many posts about the abilities of the omega2[+] to connect or not connect to some wireless router models. it seems the omega2 devices have problems with some models of wireless routers.

  • @Douglas-Kryder Yeah, thanks, I know it works with other wifi, I have it working on a wifi in my house, its more the fact that the Omega 2+ has poorer wifi support than the original omega, which connects fine. Just thought it was a downgrade in wifi support from the old one, more of me throwing that out there as an FYI.

  • For me the WiFi has also been a mayor pain in the ass. In the end I have now setup a Omega2 to connect to an original Omega which in turn connects to my WiFI network.

  • For those with Mikrotik routers.. I can confirm that Michal Rok's solution works..
    i.e. you need to initially set the mode to 'sta' (in /etc/config/wireless) to allow Omega2+ to associate with a configured AP. The default mode of '9' cannot seem to associate with the configured AP even though it is visible. The trick in Michael's solution is the switch the mode to '9' as the last step in the boot process, in order to get an IP address.

    Stupid.. but works. Not a good start to the Omega2+ journey!

  • I'm just dusting these things off after awhile and I'm hitting this issue. Nothing seems to work, not even the proposed changes above by @VLADIMIR VASHURIN . Did Onion just die off? What's going on here?

  • I just flashed the latest firmware on my Omega2+ manually to Ω-ware: 0.2.2 b202

    Still doesn't work.


  • @Lazar-Demin It has been more than two(2) and a half years and this is still an issue. What are you guys doing? Wifi is a fundamental part of your platform and it is broken in a nuclear fashion.

  • @Stephen-Tunney I think you need to cool down. I have about 80 Omega2+ based IoT devices spread across APAC in both Home and office environments, all of which are connected to whatever WiFi their location provides. I have millions of JSON requests processed. WiFi connectivity is not even in my top 50 list of potential improvements.

    Since your thread is old and very long maybe it would be better to create a new thread with a new specific set of details of your problem so the onion community can try to assist you.

    Developing any device or software is a long series of disappointments and frustrations, it is better to channel your energy into engaging with the community in order to seek help to resolve your issues than it is to attack the guys who worked so hard to provide a device that we have all benefitted from.

  • Well, upgraded to the latest F/W 0.3.2 b230 and I still can't connect. I continue to get the following for infinity... no connectivity as a wifi client.

    [ 168.508792] Interface apcli0 link up! (WPA2PSK AES)
    [ 175.074039] Interface apcli0 link up! (WPA2PSK AES)
    [ 181.710379] Interface apcli0 link up! (WPA2PSK AES)
    [ 187.952151] Interface apcli0 link up! (WPA2PSK AES)
    [ 193.467633] Interface apcli0 link up! (WPA2PSK AES)
    [ 201.154177] Interface apcli0 link up! (WPA2PSK AES)
    [ 206.669601] Interface apcli0 link up! (WPA2PSK AES)
    [ 213.307635] Interface apcli0 link up! (WPA2PSK AES)
    [ 223.374207] Interface apcli0 link up! (WPA2PSK AES)
    [ 228.506452] Interface apcli0 link up! (WPA2PSK AES)
    [ 235.070035] Interface apcli0 link up! (WPA2PSK AES)
    [ 240.668915] Interface apcli0 link up! (WPA2PSK AES)

  • @Stephen-Tunney I prefer to go back to basics first so I know I haven't msade any changes that are causing my issues. First run firstboot -y then reboot your device so you have a stock standard setup. Once it hsd rebooted connect either via serial connection or connect via hostapd and SSH. Then run wifisetup and configure your wifi.

    What version of RouterOS are you running on your router?

  • I done so many hard factory resets I've lost count, however...

    I ran the commands as you instructed, in the order you instructed and I am still getting the exact same results. All failure.

    I'm running a Ubiquity Unify AP-AC-Lite v.

  • Firmware 0.1.5 b130 works mind you on the exact same Omega2. After the firmware update to 0.2.2 or 0.3.2 the device no longer functions.

    Someone on the Onion team should be able to diff what was changed in the driver and see what broke this.

  • Upgraded my AP-AC-Lite to firmware version and it still does not work.

  • @Stephen-Tunney Coincidentally I am using the same Ubiquity Unify AP-AC-Lite at home to which I have 7 or 8 Omega2 connected. I'm also running firmware on these AP.

    My next step would be to open the UniFi controller and look in the Alerts page, for any clues. Also turn off Automatically Optimize Network in the Settings page, this has cause me no end of issues with some other WiFi clients.

    To troubleshoot further I turn on Enable Remote Syslog Server and Enable debug logging, both are on the Site settings page. You'll need a rsyslog server running so you can see the output, but the output is very informative to understand what the AP is doing with your connection. I expect you will find the cause in this logging.

Looks like your connection to Community was lost, please wait while we try to reconnect.