We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Chromebook; Wifi Overload; OLed Not Stackable, Can't Test

  • I received my onion kit this week. Very glad to have it!

    Sharing my thoughts to date.

    I can not test the OLed display, as there does not to be any example code I can load. I would really like just a very simple script that will confirm it turns on.

    The OLed I received does not have a stackable header, as shown on the order page. As I do not plan to stack anything over the OLed display, this is not a real problem for me, just a note related to the order page (see attached photo of my OLed unit). Though it does make it challenging to consider adding any wiring to the unit for breadboarding while the OLed is plugged in. However, the flush nature of the OLed would make it fit better in a case.

    I was able to set up my onion with only my chromebook. I followed the web instructions, and I was very happy to find it worked. I was pleasantly surprised to find it can do 2 wifi at once, as a client and a server - acting as a bridge in default setup! I would be willing to do a factory reset and document Chromebook setup if that would be a value to you.
    I can not install the terminal drivers [without putting my chromebook in developer mode], maybe at some point we can get google to include a terminal driver in the base chromebook code.
    I had trouble with SSH on the Chromebook to the Onion. It would not connect. I have successfully used the SSH app to connect to Raspberry PI in the past. Would like pointers on debugging ssh connection challenges.

    Looking at the documentation, I learned a tiny bit about the hardware and OS for the Onion. I was also debugging an issue with my home router, an Actiontec, and realized that it was closely related to the Onion! (The squashfs is what made me look twice).

    I have successfully used my Onion at home to prove I can connect and work with the terminal. I look forward to seeing more tools and learning more about it.
    I brought my Onion into my day job to show off the unit, and I could not connect, or even see the wifi server from the Onion.
    Back home, fine. Back in the office, no dice.
    There are many wifi access points at my job, which I can only imagine are overwhelming the signal on the onion. Or is it something about not seeing my home network that is keeping it from bringing up its wifi server? Anything I can do to troubleshoot in a noisy wifi environment?
    I even tried my wifi analyzed app on my android phone, holding it right over the Onion, and could not see any sign of the Onion wifi. I tried typing in the Wifi SSID, and could not connect.

    I wonder how hard it would be to add a standard USB driver on the Onion side so that you could access part of the onion as a flash drive without having to install special drivers?


  • I see that the oled testing is in the latest release https://community.onion.io/topic/198/mega-omega-software-release

    Now I just have to get back home to load the new update to try my OLed display - can't wait!

  • administrators

    Hi @Keith-Horowitz I'll try to address a few of your points:

    The OLED Expansion

    There was a software update released last night that includes drivers for using the OLED. Run oupgrade on the terminal to upgrade the firmware. Once the firmware is complete, you can use the Console OLED app to control the display. Also, I'll be publishing documentation about the command-line oled utility later today.

    As for the header, we decided to go with no stackable header on the OLED Expansion since it would have really reduced the ability to see the screen and embed the Omega + OLED into a project box. We'll make sure to update the photos on the store to reflect this!

    Chromebook, Serial Drivers, and SSH

    If you don't mind, documenting the setup on a Chromebook would be great, we can put it up on the wiki. It's a shame that the serial drivers don't install easily, but I think developer mode just gives you linux super user permissions so it shouldn't be too scary. But don't quote me on that, I've never actually used a Chromebook!

    With regards to ssh, have you tried using the command line with the command from the Omega SSH guide?

    Wifi Issue

    So the Omega wasn't being overloaded with too many wifi signals. The issue is something we're working to resolve; you know how your phone or laptop has a list of wifi networks it has connected to before and automatically connects when those networks are available? The Omega doesn't have that functionality yet, it can only remember information for one network at a time.

    What was happening at your office was that the Omega was looking for your home wifi network and not finding it. Unfortunately, the Omega's access point does not work if the client network is not active. I would suggest disabling the client network at home before going into the office, then the Omega's AP will be accessible. Another suggestion would be to access the Omega via the serial terminal while you are at work to disable the client network (running wifisetup -killsta on the command line will disable the client network).

    We're working on implementing a system to store wifi networks and attempt to connect automatically, stay tuned for that!

    USB Driver Idea

    While this would be cool, I think it would be pretty difficult to actually pull off. This would be something like plugging your laptop into another laptop with usb and expecting them to be able to read each other's harddrives. We have some filesystem sharing plans in the future so keep an eye out for that!

    I'm glad you're happy with the Omega so far šŸ™‚
    Hopefully I've answered some questions, feel free to drop a line if not!

  • Thank you!
    I will get on the chromebook setup write-up.

Looks like your connection to Community was lost, please wait while we try to reconnect.