We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Getting list of Available Python Modules fails

  • Using the command line:

    opkg list | grep python

    fails to list available modules. It results in a segmentation fault. How to fix ???

  • @Michael-Smorto
    Only you know the details ... (what is your HW and FW version, what did you modify, what did you install, ... 😉

    On Omega2+ with an almost factory default 0.1.10-b160 FW your command(s) is(are) working well:

    opkg update
    opkg list | grep ^python | awk '{ print $1, $2, $3 }'

    python - 2.7.13-4
    python-attrs - 16.2.0-1
    python-base - 2.7.13-4
    python-cffi - 1.8.3-1
    python-codecs - 2.7.13-4
    python-compiler - 2.7.13-4
    python-crcmod - 1.7-1
    python-crypto - 2.6.1-1
    python-ctypes - 2.7.13-4
    python-dateutil - 2.5.2-2
    python-db - 2.7.13-4
    python-decimal - 2.7.13-4
    python-distutils - 2.7.13-4
    python-dns - 1.15.0-2
    python-email - 2.7.13-4
    python-enum34 - 1.1.6-2
    python-gdbm - 2.7.13-4
    python-gmpy2 - 2.0.8-1
    python-idna - 2.1-1
    python-ipaddress - 1.0.17-1
    python-ldap - 2.4.25-1
    python-lib2to3 - 2.7.13-4
    python-light - 2.7.13-4
    python-logging - 2.7.13-4
    python-multiprocessing - 2.7.13-4
    python-mysql - 1.2.5-1
    python-ncurses - 2.7.13-4
    python-openssl - 2.7.13-4
    python-pip - 8.1.2-1
    python-ply - 3.9-1
    python-pyasn1 - 0.1.9-1
    python-pyasn1-modules - 0.0.8-1
    python-pycparser - 2.14-3
    python-pydoc - 2.7.13-4
    python-pyptlib - 0.0.6-1
    python-pyserial - 3.1.1-1
    python-setuptools - 27.2.0-1
    python-six - 1.10.0-1
    python-sqlite3 - 2.7.13-4
    python-unittest - 2.7.13-4
    python-urllib3 - 1.19-1
    python-xml - 2.7.13-4
    python-yaml - 3.11-1
    python3 - 3.6.0-2
    python3-asyncio - 3.6.0-2
    python3-base - 3.6.0-2
    python3-codecs - 3.6.0-2
    python3-ctypes - 3.6.0-2
    python3-dbm - 3.6.0-2
    python3-decimal - 3.6.0-2
    python3-dev - 3.6.0-2
    python3-distutils - 3.6.0-2
    python3-email - 3.6.0-2
    python3-gdbm - 3.6.0-2
    python3-lib2to3 - 3.6.0-2
    python3-light - 3.6.0-2
    python3-logging - 3.6.0-2
    python3-lzma - 3.6.0-2
    python3-multiprocessing - 3.6.0-2
    python3-ncurses - 3.6.0-2
    python3-openssl - 3.6.0-2
    python3-pip - 8.1.2-1
    python3-pydoc - 3.6.0-2
    python3-setuptools - 27.2.0-1
    python3-sqlite3 - 3.6.0-2
    python3-unittest - 3.6.0-2
    python3-xml - 3.6.0-2


    boost - 1.63.0-1
    micropython - 1.8.6
    micropython-lib - 1.8.6

  • @György-Farkas said in Getting list of Available Python Modules fails:

    0.1.10-b160 FW

    Tried your command and still got the segmentation error. I am using FW 0.1.10-b160 on a windows 10 machine from the console. I have a Omega 2+. I did install i2c, spi python libraries and gcc per the instructions. I am also running off the sd card to get the extra space.

  • @Michael-Smorto
    Try to use SSH on a Windows Device instead of the Onion Console.
    Generally I'm using ssh on Linux - connect with one of Omega IP addresses instead of omega-ABCD.local.

  • @György-Farkas Just tried using ssh using the IP address. opkg update worked fine. Doing the list command got me the same error message - segmentation fault.

  • @Michael-Smorto
    Well... then the first thing to check is whether it is opkg list or grep that segfaults.

    You may try without piping:
    opkg list >opkg.list
    grep ^python opkg.list

  • @Michael-Smorto

    If I were you I would make a clean state by a Factory Reset and try to build that desired config again - install the necessary packages only - step by step.
    Your Omega storage might be "messy" after those lots of successful (sd card, I2C, python, gcc, ...) and unsuccessful (numpy, scipy, matplotlib, ...) install.

  • @Flemming-Richter Tried both methods you suggested and both resulted in segmentation faults. However, opkg list-installed worked fine. Did a opkg -V list and got the following info:
    opkg_conf_parse_file: Loading conf file /etc/opkg.con
    opkg_conf_parse_file: Loading conf file /etc/opkg/cus
    opkg_conf_parse_file: Loading conf file /etc/opkg/dis
    Segmentation fault

    May have to reinstall, but this thing is beginning to get on my nerves.

    went to level -V4 and got a few more details:
    pkg_vec_insert_merge: Adding new pkg=python3-gdbm-src version=3.6.2 arch=mipsel_24kc.
    pkg_vec_insert_merge: Adding new pkg=python3-gdbm version=3.6.2 arch=mipsel_24kc.
    pkg_vec_insert_merge: Adding new pkg=python3-gnupg version=2.3.0 arch=mipsel_24kc.
    Segmentation fault

  • Ok. Got it resolved. renamed distfeeds.conf.new to distfeeds.conf. Redid the command and it worked fine. Seems like something was wrong with the original file. Maybe on one of my edits. who knows. Thanks for the help in troubleshooting.

  • @Michael-Smorto said in Getting list of Available Python Modules fails:

    Ok. Got it resolved. renamed distfeeds.conf.new to distfeeds.conf. Redid the command and it worked fine. Seems like something was wrong with the original file. Maybe on one of my edits. who knows.

    Now you have a factory default /etc/opkg/distfeeds.conf file - ie all LEDE repos are disabled. Formerly you enabled the
    src/gz reboot_packages http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/packages repo.

    opkg update
    opkg <one of informational sub-commands>
    Segmentation fault

    Temporary solution (hmm):
    Hans Dedecker LEDE developer wrote "After remove /tmp/opkg-lists/reboot_packages, segfault gone."

    opkg update
    rm /tmp/opkg-lists/reboot_packages
    opkg <one of informational sub-commands>

    So this was a LEDE opkg bug and it's already fixed (at least the opkg source has already fixed 😉

    projects / project / opkg-lede.git / commit
    pkg_parse: fix segfault when parsing descriptions with leading newlines

    "Stay tuned!"™ @Lazar-Demin

  • i was getting this segmentation fault also. could not figure out what it was. i just re-installed b160. but, the whole process got me thinking about being to upgrade all packages at one time after the update and i could not find a command to do that. it only does it on package level, by listing each package. does anyone have a favorite command to upgrade all without having to find what is upgraded package then listing it? i have yet to make such command myself that works properly. thanks for responses.

  • administrators

    can confirm that

    opkg update
    rm /tmp/opkg-lists/reboot_packages
    opkg list

    resolves the seg fault issue

  • @Lazar-Demin
    Yes that rm /tmp/opkg-lists/reboot_packages resolves the seg fault issue - but the problem has not been resolved - it has been only swept under the rug.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.