We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

omega2+ unable to make USB webcam to work

  • Hi all, I am using Omega2+ with PowerDock (the one which also allows battery management - defined as Power Dock in the official documentation);

    I've tried connecting an USB webcam to onion omega2+; webcam is Sony from the PS3 kit.
    even if, according with the info I've found (https://onion.io/streaming-video-over-wifi/) official it seems to be flawless, it doesn-t work. launching /etc/init.d/mjpeg-streamer start gives me the error:
    bolded textdevice ' /dev/video0 ' does not exist;
    tried a simple command: lsusb gives:
    -ash: lsusb: not found
    cd /tmp/mounts and ls gives nothing.

    What else can I try ?
    I've checked the USB port by inserting an USB stick, I was able to mount-it and read/write on it, so the communication is working.
    I've also tested an old webcam Microsoft 1000vx, but the result is the same - no image ....no connection to the cam.

  • @the-mask

    Webcam is too overly generalized group of devices. USB used in device interface is also too broad.
    For driver support, UVC type of USB cameras are the ones that would have better support from Linux "supported camera" point of view.


  • I found a post from 2015 of an user which was suggested to "start" a list of unsupported webcam; he listed Sony PS3 camera as "not working" with onion omega;
    I guess from omega to omega2+ there is no progress.

  • but also, seeking support on the LEDE channel I found out that they have a support for gspca-0v534 (which is related to PS3 webcam).
    Unfortunately, the install packages works only for LEDE kernel and those packages are not rewritten for omega2.
    Again, maybe a list of "working by default" usb webcams for onion omega should be kept somewhere . . .

  • have you tried the webcam app?

  • Yes, I did.
    I doesn't work. Every time I access the web interface I select the webcam app, is telling me to install the app, after that the interface is refreshing, I login again click the webcam app and the process goes like this all the time.
    As explained by ccs hello above, it seems that a "proper" webcam should be used ( UVC - usb video class - aka products which supposed to work plug-and-play in most of the knows OS ( Windows / Linux / MAC ).

  • the USB is for powering up the device not for attaching peripherals.

  • @Akhil-Kathi
    I do not agree with you. In my opinion, yusb is a very convenient interface for connecting peripheral devices.

  • see the micro usb is for powering the device right.
    can we add peripherals to it?

  • microUSB is for power and UART. You can connect peripherals to the full size USB port and add a USB hub to create multiple ports if you need more than 1 device attached.

    FYI on the original post, I had some webcams just not recognize in the Onion. It's gonna happen, driver issues. Also encoding issues where some camera's only output H.264/265 format.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.