We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Cross Compile docker libwebsockets.h not found mosquitto

  • I compiled LEDE in docker on a MacBook Pro according to this tutorial: https://onion.io/2bt-cross-compiling-c-programs-part-1/

    I had the same problem but got around it by disabling the libwebsocket support for mosquitto-ssl (under the topic 'Network')

  • Finally got rid of the error
    i ran "make defconfig",
    the "make menuconfig" to reselect the options i wanted and all is good now.

  • Has anyone actually gotten libwebsockets and mosquitto to compile (cross compiled) onto the omega2+ successfully?

    Im trying for days and no luck. Any help would be appreciated.

  • For now, the only way to compile the Build system is to un-select mosquitto and libwebsockets packages from the menuconfig. 0_1519767258955_mqtt_menuconfig.PNG


    This is what it looks in the menu. You can search the package using / and enter the desired package to be removed (e.g. mosquitto). You will also be able to see the location where you can locate it.

  • there is no possibility to uncheck mosquito. It's either [M] or [*]. Pressing space and <N> doesn't work. libwebsockets is unchecked by default:

    short video example

  • I used vi to comment out all references to mosquitto in .config. Just search for mosquitto, there are a number of lines.
    ~/source# vi .config

  • administrators

    An update on this topic:
    Many users have reported this issue with libwebsockets and mosquitto when running our Docker build system image on Windows and Mac OS.
    We recommend running the Docker build system image on a Linux system. That's how we build firmware at Onion and it don't see these issues.

    Happy hacking!

  • Hi @Lazar-Demin,

    It's probably worth mentioning the linux distro as well. I have came at this from a lot of different angles:

    Onion's Docker on Windows
    Ubuntu 16 VM Windows Host machine
    Onion's Docker on Ubuntu 16 VM Windows Host machine

    Onion's Docker on Centos 7 (Eventually worked!)

    From what I saw in my debugging there was a 502 timeout when trying to download the libwebsockets dependency, therefor failing the build.

    My fix was no different than the aforementioned, but my question to you is that worth a PR to GH repo? I can submit mine.

    Thank you kindly,
    -- Kade

  • Here is my fork: https://github.com/luckybroman5/source

    Clone, startup docker, then:

    # cd /root/source/c-cross-compile-example // https://github.com/OnionIoT/c-cross-compile-example
    # sh xCompile.sh --buildroot /root/source/ --lib ugpio

  • I'm having this same issue on Linux Mint 19 using the docker image.

  • @Lazar-Demin seeing the same thing running Parallels with ubuntu.

    I did find that libwebsockets was unchecked. Checking it got me further, but I still can not build, on MacOS or Ubuntu, same errors as everyone else with mosquitto and SSLlibwebsockets

  • I got the same on ubuntu 18.04 LTS. Deleting the container and rebuilding in a NEW container fixed the issue, when I tried for the 3rd time.

  • Hello @Lazar-Demin,
    I'm experiencing the same issue when running docker build system image on Ubuntu 18.04 LTS.
    Do you have any reasonable solution?
    I need libwebsockets and mosquitto in my project, so disabling it is not an option.

  • I think it useful to understand how the build system works so you can always install any OpenWrt package you may need. If you search for the packages on OpenWrt.org you can download the build configuration file(s) and it lists the dependencies.

    Here is how you would use the build system to build mosquitto which also handles the dependencies. You run the scripts from the directory in which you install the build system:

    ./scripts/feeds update
    ./scripts/feeds install mosquitto
    make menuconfig

    Here's the output:

    Installing package 'mosquitto' from packages
    Installing package 'libwebsockets' from packages
    Installing package 'libuv' from packages
    Installing package 'c-ares' from packages

    I don't use Docker, I think it strangles performance.

Looks like your connection to Community was lost, please wait while we try to reconnect.