We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.


  • @Chris-Ward Just received my C270 today and it is working fine. Still struggling with my PS3 cam šŸ˜ž

  • @Theodore-Borromeo I am working on a similar project. I have a van that I am trying to create a rear facing camera for, as I can't really see out the back. I had thought the RasPi would be camera, but now I am thinking the Omega, the C270, and a distance sensor at the back, and the RasPi with a screen at the front to view.

    @Uwe-Press I am not sure the PS3 will be a great streaming camera on the Omega. I would love confirmation, but I can only seem to get the PS3 eye cam to be in YUV mode on my RasPi which uses more resources than I would like.

  • @Steve-Fister said:

    Ok, question. I'd like to free up the USB port on the Omega by hard wiring the USB camera to the board. I'm assuming that connecting the camera to the pins for +2.8vout (red), Gnd (black), USB+ and USB- will work? The camera requires 5vdc input. Do I need a step-up converter?? Thanks...

  • @Steve-Fister If you use the Expansion Dock there should already be a 5V pin. If you are using the Omega with the Mini Dock, then you will need a step-up converter. Remember that the Vin for the Omega is 3.3V, so don't connect the 5V Omega directly.

  • administrators

    Webcam App is now available as part of the new 008 release of the firmware

  • Was this ever resolved, saw mention of Lazar looking into this but no results were ever posted.

  • [omega2+]
    hello guys
    i'm trying to stream and after several problems this is the closest i could get to make something work :
    alt text
    any ideas ?

    N.B: i created a folder called /usr/local/www/ but did not set any specific rights on it.
    also when i use dmesg it seems the camera is recognized with some sort of workaround message:

    [ 2782.743229] uvcvideo: Found UVC 1.00 device USB2.0 Camera (1e4e:0109)
    [ 2782.760050] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
    [ 2782.774970] input: USB2.0 Camera as /devices/platform/101c0000.ehci/usb1/1-1/1-1.3/1-1.3:1.0/input/input0

    from what i understood this is a proof the cam is mounted on the system:
    alt text

    this message surprizes me cause i have EXACTELY the camera shown on the end of this article : http://h-wrt.com/en/doc/webcam

    any toughts ?

  • it finally worked for me ! šŸ™‚
    Desperate i connected two Webcams at once on my usb hub, then "ls /dev/v*" was showing video0 and video1

    my newest cheap camera bought in 2016 shows the following message :
    "[ 12.590190] uvcvideo: Found UVC 1.00 device USB2.0 Camera (1e4e:0109)
    [ 12.597938] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.

    • LAST LINE :
      [ 57.016115] uvcvideo: Failed to query (GET_DEF) UVC control 11 on unit 3: -32 (exp. 1).

    a very old Logitech webcam i have for more than 8 years (Logitech QuickCam Pro 5000) seemed to show a positive message when i was activating the stream with mjpg_streamer (while the newest was saying : "Unable to set format: 1196444237 res: 640x480 / Init v4L2 failed !! exit fatal" )

    i started the same command on video1 ... the message was warning me that it cannot stream cause camera 1 already uses the port
    Then i hot-unpluged my newest camera and started the command again.
    This time everything worked and when i entered into Webcam app on the Omega Dashboard i could see my camera live ! i t also worked by going to page

  • Something isn't working webcam wise, I can't get beyond the following errors reported by dmesg...

    [ 7093.779850] do_page_fault(): sending SIGSEGV to mjpg_streamer for invalid write access to 76dbcd68
    [ 7093.789006] epc = 772dcbc4 in libc.so[77266000+92000]
    [ 7093.794181] ra = 772dcbb0 in libc.so[77266000+92000]
    [ 7093.799318]

    tried upgrading, removing and reinstalling mjpg-streamer, different cameras, lots of different startup options and installing the console webcam app. Always the same error.

    currently using mjpg_streamer -i "input_uvc.so -d /dev/video0" -o "
    output_http.so -w /www/webcam --port 8080"

    but can't change the error

    any thoughts???



  • @Zheng-Han

    1. What is the status of the kernel driver for PS3Eye on Omega2?

    PS3Eye is not UVC compliant.

    1. PS3Eye as you know outputs YUYV, not Mjpeg, so what kind of FPS can you get over Omega2 WiFi over a 10-15m distance, for Mjpeg video streaming at 640*480 frames?

    2. PS3Eye has both a mic and speaker, so can we use V4L2 on Omega2 for both video and audio streams?

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.