We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

NAS with Omega Onion

  • I've looked around for a little bit, but I can't find anything about creating Network Attached Storage (NAS) with Omega Onion. Anyone working and want to share please? ā¤

  • @C1ARK-Gable Did you want to access your drive via NFS, SMB(samba), or another protocol?

  • NFS preferably, but other protocols may help the community. @files_copying

  • @C1ARK-Gable We have that on our Todo list as a tutorial. We'll finish that tutorial within the next few days. Sorry about the delay!

  • Update: Still looks like I am being blocked by a firewall. I thought the below ports were what I needed to open but I am learning IPtables as I practice with this experiment. I am going to spend tomorrow evening reading about iptables.

    #Open TCP and UDP ports 111, 32777 through 32780 on firewall to allow NFS and NFSD
    iptables -A INPUT -j ACCEPT -i wlan0 -s -p tcp --dport 111
    iptables -A INPUT -j ACCEPT -i wlan0 -s -p udp --dport 111
    iptables -A INPUT -j ACCEPT -i wlan0 -s -p tcp --dport 32777:32780
    iptables -A INPUT -j ACCEPT -i wlan0 -s -p udp --dport 32777:32780
    sysctl -e

    #vi /etc/hosts.allow
    #portmap: 192.168.1.*

    . /etc/init.d/portmap start
    . /etc/init.d/portmap enable
    . /etc/init.d/nfsd start
    . /etc/init.d/nfsd enable

    Original Post below
    This is not yet complete but I think only the firewall port is left from this point.
    NFS Server Sharing USB Fat32 Flash Drive
    Test to see if USB device is recognized
    [ 1276.480000] usb 1-1: new high-speed USB device number 4 using ehci-platform
    [ 1276.630000] usb-storage 1-1:1.0: USB Mass Storage device detected
    [ 1276.650000] scsi host2: usb-storage 1-1:1.0
    [ 1277.660000] scsi 2:0:0:0: Direct-Access     Kingston DataTraveler 2.0 1.00 PQ: 0 ANSI: 4
    [ 1277.670000] sd 2:0:0:0: [sda] 15148608 512-byte logical blocks: (7.75 GB/7.22 GiB)
    [ 1277.680000] sd 2:0:0:0: [sda] Write Protect is off
    [ 1277.680000] sd 2:0:0:0: [sda] Mode Sense: 45 00 00 00
    [ 1277.690000] sd 2:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
    [ 1277.720000]  sda: sda1
    [ 1277.730000] sd 2:0:0:0: [sda] Attached SCSI removable disk
    If USB Drive support is needed. Otherwise continue on.
    opkg install kmod-usb2
    opkg install kmod-usb-storage-extras
    Ran into a kernel mismatch problem. Forcing to verify setup will work.
    opkg install --force-depends nfs-kernel-server
    Mount device
    mount /dev/sda1 /mnt
    ls /mnt 
    Export the directory. My test method shown is INSECURE. It allows anyone to mount and write.
    vi /etc/exports
    Copy and paste the following line:
    /mnt    *(rw,sync)
    Then press `ESC`, then `:wq` to save and exit out of `vi`.
    Reload and apply changes
    exportfs -ar
    Switch to other computer now
    mount onionomega:/mnt /mnt
    I hit this wall so far. I have to sleep now but will put some more time in it tomorrow evening after work. I think I have to open a port on the onion.
    $ sudo mount -vvv onionomega:/mnt /mnt/usb/                  
    mount.nfs: timeout set for Sun Dec 13 20:25:19 2015
    mount.nfs: trying text-based options 'vers=4.2,addr=,clientaddr='
    mount.nfs: mount(2): Connection refused
    mount.nfs: trying text-based options 'addr='
    mount.nfs: prog 100003, trying vers=3, prot=6
    mount.nfs: portmap query retrying: RPC: Program not registered
    mount.nfs: prog 100003, trying vers=3, prot=17
    mount.nfs: portmap query failed: RPC: Program not registered
    mount.nfs: requested NFS version or transport protocol is not supported

  • @Boken-Lin Is your todo list posted anywhere? I would love some ideas for projects to play with. Even if all you have is a text file it would be nice to see .

  • @files_copying Ha! Posting our roadmap (for both software releases and tutorials) has been on the todo list as well! I'll make sure I have that online by tomorrow!

  • Thanks for all your help guys! Great community!

  • SSHFS works very well

    opkg install openssh-sftp-server

    client# sshfs user@onionomega:/remote/mountpoint /local/mountpoint

    Done. Not sure how many devices are able to use SSHFS though.

  • @Boken-Lin said in NAS with Omega Onion:

    @files_copying Ha! Posting our roadmap (for both software releases and tutorials) has been on the todo list as well! I'll make sure I have that online by tomorrow!

    Any info on where I may find that tutorial?

  • @Yeshwanth-Shenoy , @Boken-Lin is refering to the roadmap a year ago.

    The tutorial should be in the wiki.onion.io if someone made it šŸ˜‰ With the search function I could not find it.

  • I haven't found anything either yet. Was it forgotten by the Onion team maybe?? Last post that said it was ready to be posted, it was a year ago.....

  • Bump for new solutions.

  • administrators

    Check out the Mobile Network File Server project in our free Project Book:


  • @Lazar-Demin Thanks for the post. I just tried to do this and it doesn't seem to be working for me. I know that samba is working as I am able to access my home folders. But, the usbshare is not working. This is what I have:

    config 'usbshare'
    option 'name' 'usb'
    option 'description' 'USB Drive'
    option 'path' '/tmp/run/mountd/sda1'
    option 'users' 'root'
    option 'read_only' 'no'
    option 'guest_ok' 'no'

    I know that my path option is not the same as what you had, but I was trying to debug it and decided to not use the symlink.

    When I try to connect to smb://<ip>/usb it doesn't allow the connection, but if I connect to just smb://<ip> it accesses roots hold folder.:

    Thanks for the help.

  • I was able to get it working with some tweaking. The problem was with the config 'usbshare' I changed this to config 'sambashare' and it worked.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.