We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

After Warp Core upgrade, device unreachable

  • Today I ran the upgrade. Here's what I saw in the output:

    BusyBox v1.26.2 () built-in shell (ash)
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/
       Ω-ware: 0.1.10 b160
    root@Koin:~# oupgrade --latest
    > Device Firmware Version: 0.1.10 b160
    > Checking latest version online...
    > Repo Firmware Version: 0.2.0 b176
    > Comparing version numbers
    > New firmware version available, need to upgrade device firmware
    > Downloading new firmware ...
    /usr/bin/oupgrade: local: line 377: not in a function
    --2018-03-28 15:45:02--  http://repo.onion.io/omega2/images/omega2p-v0.2.0-b176.bin
    Resolving repo.onion.io...
    Connecting to repo.onion.io||:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 7340207 (7.0M) [application/octet-stream]
    Saving to: '/tmp/omega2p-v0.2.0-b176.bin'
    /tmp/omega2p-v0.2.0-b176.bin               100%[=====================================================================================>]   7.00M  1.71MB/s    in 4.1s
    2018-03-28 15:45:06 (1.71 MB/s) - '/tmp/omega2p-v0.2.0-b176.bin' saved [7340207/7340207]
    > Starting firmware upgrade....
    Saving config files...
    killall: watchdog: no process killed
    Sending TERM to remaining processes ... udhcpc udhcpc dnsmasq rpcd mountd ntpd oupgrade Terminated
    root@Koin:~# ubusd askfirst logd netifd odhcpd uhttpd device-client avahi-daemon onion-helper
    Sending KILL to remaining processes ... askfirst
    Switching to ramdisk...
    Performing system upgrade...
    Unlocking firmware ...
    Writing from <stdin> to firmware ...
    Appending jffs2 data from /tmp/sysupgrade.tgz to firmware..
    Upgrade completed
    Rebooting system...
    umount: can't unmount /dev/pts: Resource busy
    umount: can't unmount /dev: Resource busy

    After waiting for the light to stop blinking and stay on solid, I tried to connect, but the device is no longer responding to mDNS requests. It seems to be disconnected from the network or has lost its name.

    Is this experience expected? If so, a notice in the announcement would be nice.

    Any other suggestions on what may have gone wrong? I don't have non-ascii characters in my WiFi SSID or password.

  • @Jason-R.-Coombs You should check with the serial console what's happening (if you have power / expansion board with USB-UART converter, that is. Do you see the Omega's standard WiFi network? Can you access the shell via serial? You might have to re-run the wifisetup.

    I just did the factory reset after the firmware upgrade and everything worked (https://docs.onion.io/omega2-docs/factory-reset.html).

  • So it's expected that one will have to factory reset after installing the upgrade? That's probably worth mentioning in the announcement and in the updater script.

  • @Jason-R.-Coombs I did one just to get a clean state, I don't know if that was necessary. It should keep important configuration data, though. Not sure though.

  • So it seems it lost the WiFi configuration and the hostname, but retained other state like the authorized keys and root password.

  • I noticed after the upgrade that the mac address had changed. My DHCP server wasn't handing off the correct address. Also I think the device ID for the cloud service had changed, so that might be where you are experiencing a problem as well. Also can't remember if Nano was on the onion before, but i had to reinstall that as well.

  • Seems curl was also missing after the upgrade.

  • @Simon-Cain hello, just wanted to add that the mac address on my omega2+ also changed.

  • Further digging, I believe I had folder at the root level that went missing too. My Suggestion would be to keep everything important in the root user folder. IE Keep things in /root not /

  • administrators

    I mentioned it in the other thread but should have highlighted it more:

    • Installation of the new OS will wipe the previous wireless configuration,
      please try running wifisetup and configuring your Omega to connect to your network. The rest of your system should be intact though.
    • There have been some changes to the MAC addressing as well, the two wireless interfaces (ra0 and apcli0) will now have different addresses:
      • The MAC address of ra0 (the wireless interface used to host the Omega's AP network) will match that written on the label of your device
      • The MAC address of apcli0 (the wireless interface used to connect to other networks) will be the MAC address on the label +1

  • @Lazar-Demin Hello. How to solve the host key problem after the factory reset. Everytime i use ssh the message displays. Can you please help me to fix it. You can also mail me at swapnilrkey911@gmail.com . Since i will not be notified in here.

  • administrators

    @Swapnil-Katpally After a factory reset, your Omega’s SSH signature will be different. You'll need to modify the known_hosts file on your computer.
    See our Docs for more details: https://docs.onion.io/omega2-docs/factory-reset.html#a-note-about-factory-resets-and-rsa-key-warnings

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.