We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Login Password doesn't work after firmware upgrade

  • So, i did a firmware upgrade via console and after a reboot it won't accept "onioneer" as a password anymore. I have the maker kit, so I'm pretty sure I've got an ethernet connector to flash it if needed, but when I tried to access the github page to do that, github tells me that the link is broken.

    Guys, I don't mean to be a jerk, but I don't think the Omega2+ is ready for prime time. Very cool idea, love where you're going, but you get a C+ for execution.

    I'm not new to SOC...I've been using Rasp Pi and Ard for years. I teach a class on it. I'm good with SSH and CLI and Terminal and GPIO and Python...and I'm getting so frustrated with your hardware I'm ready to coat it in peanut butter and let my German Shepherd use it as a chew toy.

    It'd be nice if it didn't take a week to get an answer on this question. Yes, I know you have answered it already, and "Yes! I did search for and find the answer!" but unfortunately the answer had a link that didn't work and no follow up. So, if you can't be bothered to provide working links and comprehensive answers, then I can't be bothered to search through 93 pages of hits for "Login password fails". So there!

    seriously, I don't want to jump online and start leaving bad reviews, I really, really, really want this thing to work. Because if it works, then it's the coolest thing since the light-up keyboard on the MacBook Pro for 2007! But, I'm human and my patience is wearing thin.

  • administrators

    @William-Srite How are you trying to access your Omega? Through a browser, serial, or SSH?
    If it's through the browser, I recommend trying either Serial or SSH, see this article for more details.
    If it's through the command line, then something is very off. I would recommend triggering a factory restore using the reset button.

  • @Lazar-Demin My O2+ is dead. I've posted a ticked and received no response. I submitted my ticket over two weeks ago. Here's the ticket (in italics):

    Ticket no. 25071
    *I got my Omega2 about 30 days ago and it has been plagued with problems from day one. Today, while attempting to flash the firmware via USB drive through a serial connect–because the WiFi isn't working at all–it died on me. No lights come on. There is no signal from the USB connection at all. I checked and zero data is coming across the cable. I've disconnected it from the USB cable and tried a different one. I've turned it on and then turned it off. I've held down the reset button for 30 seconds while it was on. I've held down the reset button for 30 seconds while it was off. I've pressed the reset button while turning it on. I've plugged it into a wall outlet to see if my power is wrong on my computer's USB port.

    Nothing has worked. I'm not sure if this is a problem with the dock or the omega2 itself, but I suspect it's the Omega2.

    I know that sometimes electronics come off the production line with issues and I'm sure that 99.99966% of your devices come off the line and are perfectly good. But, I think I got one of the rare bad ones.

    I backed your project several years ago on one of your crowdfunding campaigns and have patiently waited for a long time to get my Omega2 (although, technically, I ordered this product through your online store via a coupon code because I never got my device when your company shipped them after the crowdfunding ended). It would be really great if you guys could fix this issue as soon as possible. So far I've only seen promises as to what the Omega2 can do. I've yet to even write one line of code or make one LED blink with my Omega2. It came out of the box with issues. Ideally, you guys will just send me a replacement Omega2 and expansion dock with a pre-paid envelope and I can mail you back my bricked Omega2 and the expansion dock I have. That way this newest and latest wait will be as short as possible. I really, really, really want this thing to work out for me. Nobody was more excited to receive his Omega2 than I was!!! But, now I'm just disappointed. I'm hoping I just got supremely unlucky and I got the one-in-10million-unit that was corrupted from the beginning, that they aren't all this problematic, and that you guys will correct this and I'll be as delighted to use the Omega2 as I thought I would be when I backed this endeavor several years ago.*

    If the company isn't going to address my issue just let me know. I'd be happy to buy another if I broke it, although I highly, highly doubt it was anything I did. I think I got a bad item. Either way, I really want to try it out. Where can I order a new Omega2+? All I see is the page for the Omega2, not the Omega2 PLUS.

    I'm really trying to be patient with Onion, but I'm not a saint. I know the company is expanding and growing and it's probably just growing pains to blame, but at some point I'm going to give up. I really need to order about 200 of these to use as teaching tools, but I'm not going to if I can't get any support.

  • I guess Italics aren't working...

  • Here's a picture:0_1538015820023_IMG_0149.jpg

  • @William-Srite what is this picture supposed to be showing?

  • @Jon-Gordon that the power is on but the lights aren't. The company asked for a photo showing the Omega2+ connected and turned on. I thought I'd include it here too. As you can see the switch is in the on position and the lights never come on. I think it's fried.

  • and when you use the multi-meter you get 5V on the breakout board?

    Have you tried a different usb cable? Maybe plugged into a pc usb port instead of an iphone charger?

  • @Jon-Gordon I've tried every conceivable combination of cable and board and adapter. Nothing works.

  • @William-Srite so.... is that a yes? You do get a 5v reading at the board?

Looks like your connection to Community was lost, please wait while we try to reconnect.