We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega 2 boot problem

  • administrators

    @Valeri-V as @ccs-hello mentioned, this is most likely due to insufficient available current.

    See our guide on powering the Omega without an Onion Dock: http://docs.onion.io/omega2-docs/hardware-prep-no-dock.html

  • @Lazar-Demin About your recommendation - do you really know any three terminal 3.3V 0.8A regulator without (input and) output capacitor(s)?
    See also - for example - ST LD1117xx datasheet:

    Only a very common 10 μF minimum capacitor is needed for stability.

  • @Lazar-Demin, I use power module 3A with capacitors

  • @Valeri-V , and I try other power modules

  • administrators

    @Valeri-V As the guide mentions, this is the only procedure recommended by Onion.

    Please try using a LD1117 3.3V regulator or one of our Omega2 Docks.

    Alternatively, you can take a look at the designs of the Docks to get an idea of what regulators and components we used to provide steady power to the Omega: https://github.com/OnionIoT/Onion-Hardware/tree/master/Schematics

    @György-Farkas yes, we'll add this documentation update to our backlog

  • @Lazar-Demin
    Help pliz, do not understand anything. The problem with the omega 2 power+

    There is a project, the device worked for a year.
    then it stopped working. Simply so. Just stopped starting WiFi - at some point the download freezes.

    Powered by
    220V -> 5V ( HLK-PM01 ) - all project components except omega operate from 5V.
    5V -> 3.3 V ( https://ru.aliexpress.com/item/1PCS-Mini-DC-DC-12-24V-To-5V-3A-Step-Down-Power-Supply-Module-Voltage-Buck/32815304338.html ). It's adjustable, set of 3.4 V. Under load from the omega stable voltage of +-0.1 V. USB oscilloscope shows ripple to 0.2 V (similarly HLK-PM03 - see below).

    The Converter instance 5 -> 3.3 - I used different. I added a capacitor 10mkf, tried 4.7, 100 and 470 - no effect .

    If I use HLK-PM03 (220 -> 3.3) omega works.

    If I use a linear stabilizer Converter UART - USB-omega works.

    The 1117 - omega stabilizer works if the input voltage is 5V. If the input voltage is less than 5V - omega does not start at all. And I have a Converter Li -> 5V, it outputs 4.9 V. In this case 1117 produces less than 3.3 V (about 3.1) and the omega does not start. The device has soldered UART USB. But on its 5V line is Schottky diode to eliminate reverse current. Thus when powered only from the USB on the Board comes in 4.7 - 1117 again for no reason.

    As energize omega from arbitrary source 4...5V?

  • @Valeri-V Let's suppose that your power supply is really good.
    Try to perform a Factory Reset with one of the following methods:

    • Press and hold down the RESET BUTTON (if you have any) for 10 seconds then release it to trigger a factory reset / restore.

    • If you don't have RESET BUTTON - connect Omega2's FW RST (GPIO38) pin to 3.3V let's say with a 470 Ohm resistor for 10 seconds then disconnect it to trigger a factory reset / restore.

    • Press the [f] key and hit [Enter] (quickly !!!) to enter failsafe mode when you see this message on the Serial Console and type the next commands:
      firstboot -y

    # Omega2+ FW v0.2.2 b200
    [    4.985014] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
    [    5.002824] init: - preinit -
    [    5.946995] rt3050-esw 10110000.esw: link changed 0x00
    Press the [f] key and hit [enter] to enter failsafe mode
    Press the [1], [2], [3] or [4] key and hit [enter] to select the debug[    6.148210] random: procd: uninitialized urandom read (4 bytes read, 11 bits of entropy available)
    - failsafe -
    [    8.187505] random: dropbearkey: uninitialized urandom read (32 bytes read, 14 bits of entropy available)
    Generating key, [    8.198950] random: dropbearkey: uninitialized urandom read (32 bytes read, 14 bits of entropy available)
    this may take a while...
    [   10.610153] random: dropbearkey: uninitialized urandom read (32 bytes read, 18 bits of entropy available)
    Public key portion is:
    ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAAAgQCi[   10.746995] random: dropbear: uninitialized urandom read (32 bytes read, 18 bits of entropy available)
    v4eKtU3ht1kRkzIKvOtpsTtqp/BcNGfRdjhV6H5YKWJL0W3+lrnaNgnf0jkdT65tKHfVCgIO2Xv7GPSIOGiR4d4yjFr6CvcA1t3juuh1g9QmXPttz3EWWv1lQsGN0r7AMunT9BlocFeHGin74Im2wPPdJMVOdFRPy6CXij2jjw== root@(none)
    Fingerprint: md5 fc:7e:d6:7b:6d:28:a0:dc:2c:22:a5:aa:a1:ce:1e:72
    BusyBox v1.25.1 () built-in shell (ash)
    ash: can't access tty; job control turned off
        /        /\      _    ___ ___  ___
       /  LE    /  \    | |  | __|   \| __|
      /    DE  /    \   | |__| _|| |) | _|
     /________/  LE  \  |____|___|___/|___|                      lede-project.org
     \        \   DE /
      \    LE  \    /  -----------------------------------------------------------
       \  DE    \  /    Reboot (17.01-SNAPSHOT, r3518-b15e538)
        \________\/    -----------------------------------------------------------
    ================= FAILSAFE MODE active ================
    special commands:
    * firstboot	     reset settings to factory defaults
    * mount_root	 mount root-partition with config files
    after mount_root:
    * passwd			 change root's password
    * /etc/config		    directory with config files
    for more help see:
    root@(none):/# firstboot -y
    [   29.253048] jffs2reset: /dev/mtdblock6 is not mounted
    [   29.258402] jffs2reset: /dev/mtdblock6 will be erased on next mount
    root@(none):/# reboot
    root@(none):/# [  186.585220] reboot: Restarting system
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/"
    Board: Onion Omega2 APSoC DRAM:  128 MB
    relocate_code Pointer at: 87f60000
    Software System Reset Occurred

    Good luck!

  • @ Valeri V
    Hard to troubleshoot the power situation unless every single bit of info is known.
    In addition to static voltage measurement, transient power dip in the milli-second level will cause O2 to hang.
    Gold rule for power hygiene:

    1. don't use long cable, or at least, use thick cable
    2. put a large capacitor as close to the O2 side as possible (I used 470uF 6.3V low ESR capacitor)
    3. proper use of power regulator IC
      Some commonly seen mistakes are
      a) use a clone/off-brand/sub-standard IC or that IC has already degraded (due to various conditions)
      b) not using the datasheet specified capacitors on its input and output side
      < --- many cheap suppliers do that to save its cost
      < --- they need to be as close to the IC as possible
      c) no or insufficient heat sink and/or heat dissipation (will degrade the IC anyways)
      d) use the wrong part (e.g., mis-calculation on drop-out voltage)
    4. Use improper connection such as DuPont connector and header pins

    All of them are basic EE knowledge and are essential for a success project
    but some DIY maker Wikis/books failed to mention.

  • @György-Farkas, I tried, didn't help

  • @ccs-hello said in Omega 2 boot problem:

    1. 2...3sm

    470uF 6.3V low ESR capacitor

    I tried, didn't help

    1. I'll buy some other regulators, try them.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.