We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega won't connect to DNS from certain networks (originally/red herring issue: Slow/frozen oupgrade)

  • Hi All,

    How long should oupgrade take? I'm currently on > 6 hours and waiting, but don't want to pull the plug or control-c given that I don't have an Ethernet module (or an expansion dock, as mine was one of the lost orders that only recently started getting partially filled, and I'm told they're OOS while the new ones come in).

    A couple notes that might be relevant:


    1. How long should oupgrade take?
    2. Given that I don't have an Ethernet module and the ability to reflash, what's my suggested next step?


  • Update/further wackyness. I think this may be related to my wifi settings. I gave up around 10 hrs, rebooted, factory reset, and saw the serial connection appear to be stuck saying "[ 68.610000] random: nonblocking pool is initialized".

    So I tried the second Omega. Same thing. At some point I decided to try my phone's wifi hotspot... and suddenly it all "worked". Wifi connection, hot spot, etc. So I took the original Omega, logged onto its network, switched it over, and again, it works.

    A few notes and questions:

    1. Any ideas what might be wrong in my main network's settings? TomatoUSB, with a small amount of DNS games (DNSmasq is running to intercept an amazon dash so it can be used as a light switch), but I've been slowly disabling those, and still no luck.
    2. Network issue symptoms. When the Omegas are connected to the main network, they
    • cannot ping google.com
    • can ping outside ip addresses
    • from the Onion console, they cannot access the terminal (but can access the file system, stats, etc)
    • they cannot do oupgrades
    • simply adding a name server to resolve.conf doesn't fix the inability to access Onion terminal
    1. Not sure if its supposed to be this way... When I connect to the Serial terminal for both of these, I see what appears to be a timestamp and log, not a console I can type things in, except for a few prompts during reboots.

    Any thoughts are most welcome.

  • administrators

    Hey @Josh-Rosenthal,

    Yikes, oupgrade should take 5 to 10min tops. I'm glad that you got it worked out with your phone.

    Can you check what encryption your wifi network is using? The Omega doesn't currently support TKIP encryption https://community.onion.io/topic/137/ssh-from-lan-not-working/3

    For the stuck at [ 68.610000] random: nonblocking pool is initialized issue, pressing Enter in the terminal doesn't do anything?

  • Hi @Lazar-Demin -
    So, no, after the nonblocking pool, no keystrokes would work.

    However, I resolved the issue. Tonight I decided to sit down and deconstruct my network settings one at a time (aka, time for a tomato upgrade, so why not wipe my settings and rebuild them). It looks like the issue was that my network was set to operate on a 192.168.3.* ip range.... and that made the Onion very very grumpy. When I tried to connect the Onion to the network set to 192.168.3.* it would claim to connect, but would never be able to ping google.com (pinging worked fine). When I switched the network to 192.168.1.* , the Onion connected fine. I'm not sure if the Onion requires 192.168.1., or if the 3. settings are an issue because that's what the Onion uses for it's configuration AP, but that seems to have been an issue. I'd do more testing, but the wife is getting a bit upset with the network instability that I've wrought, so I think I'll leave answering the question of "Well, what if your network runs on 2.*?" to someone else.

    Thanks again,

  • Hi @Josh-Rosenthal, you can actually change the IP address of your Omega to something else to avoid conflict with your router. Just edit /etc/config/network, you should be able to find a block that looks like this:

    config interface 'wlan'
        option proto 'static'
        option ipaddr ''
        option netmask ''

    And all you need to do is to change where it says to something else that plays a bit better with your router.

    Please let me know if this works!

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.