We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Webcam detected but not streaming

  • Hi everyone!

    I followed several tutorials over the web but I couldn't get my SQ11 Webcam to work. I'm working on an Omega2 with firmware version 0.3.2 b233.

    When I run ls /dev/v* it returns among other stuff /dev/video0, so I guess the camera is detected successfully. I also tried the SQ11 previously on my computer, it works.

    I tried several things:

    • Run mjpg_streamer -i "input_uvc.so -r 1280x720 -f 15 -d /dev/video0" -o "output_http.so -p 8080 -w /www/webcam", I get the output:
    MJPG Streamer Version.: 2.0
     i: Using V4L2 device.: /dev/video0
     i: Desired Resolution: 1280 x 720
     i: Frames Per Second.: 15
     i: Format............: JPEG
     i: TV-Norm...........: DEFAULT
    Unable to set format: 1196444237 res: 1280x720
     Init v4L2 failed !! exit fatal
     i: init_VideoIn failed
    • Run mjpg_streamer -i "./input_uvc.so -f 30 -r 1280x720 -d /dev/video0" -o "./output_http.so -w ./www -p 8080" -b and it returned
    enabling daemon moderoot@Omega-XXXX:~# forked to background (7126)

    But when I went to it gave me an ERR_CONNECTION_REFUSED error.

    • Run mjpg_streamer -i "/usr/lib/input_uvc.s -d /dev/video0" -o "output_http.so -p 8080", getting the output
    MJPG Streamer Version.: 2.0
    ERROR: could not find input plugin
           Perhaps you want to adjust the search path with:
           # export LD_LIBRARY_PATH=/path/to/plugin/folder
           dlopen: Error loading shared library /usr/lib/input_uvc.s: No such file or directory
    • I even tried making a simple photo with fswebcam --no-banner -r 1280x720 `date +"%Y-%m-%d_%H%M%S"`.jpg, but I got the error
    --- Opening /dev/video0...
    Trying source module v4l2...
    /dev/video0 opened.
    No input was specified, using the first.
    Unable to find a compatible palette format.

    Is there any kind soul who could help a noob out? I would be very thankful, as I'm very lost and frustrated, and I don't know what else to try.

    Kind regards,
    Beto šŸ˜Š

Looks like your connection to Community was lost, please wait while we try to reconnect.