We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Onion Omega 2+ stopped working for no reason



  • @tjoseph1 factory reset first so the file system should be recovered, then upgrade.



  • @crispyoz thanks for the reply. As I mentioned above, the factory reset solution works to solve the problem. What I am looking for, are possible causes for these problems (for example, outdated version) as I have more than 500 installations made with the product.



  • @tjoseph1 thanks for the reply. The point here is that I have 500 installations (which started in 2018) that would need updating (which is not the problem) but would have to ensure that it would solve the problem. Do you think it will solve?



  • @crispyoz thank you again. I just proceed to https://docs.onion.io/omega2-docs/Firmware-Flashing-Web-Recovery.html and it worked on the 3 I have with me. The problem, is the other 500 already installed that I want to avoid that problem.



  • @francisco-vieira your error indicates an issue with the file system, so I find I very unlikely you would experience that same issue on 500 devices. However 35+ years in IT has taught me to be cautious when updating large numbers of devices. You would be best to pick a small number of devices and update those and carefully examine any errors reported. I would also suggest you may want to consider incremental updates, rather than jump from a very old firmware version to the current firmware version, you may upgrade the firmware in steps so if you do experience an issue you can adjust your production upgrade plans.

    Consider the disaster of upgrading 500 devices and having all of them in error and what time and resources you would need to support all those devices. I always look at how many devices I could reasonably support if they failed and then use that to plan which devices I would upgrade over what timeframe.



  • @crispyoz thank you for all you patient to answer me. But, every week, 1 or 2 Onion Omega 2+ are freezing and I'm afraid on what is happening. Based on your experience, do you think an update for the new firmware can solve this issue? Or help to solve it?



  • @francisco-vieira computers are complex things and therefore without specific analysis this is a difficult question to answer. Firmware updates address known issues in a range of software components and also make enhancements, the cause of your issue may already have been identified and resolved by one of these updates.

    When troubleshooting intermittent or irregular issues it is always best to be on the latest firmware release so that your issue is not caused by something that has been addressed already. My approach would be to upgrade a few units and then see if these units become more reliable than the others, it will certainly help narrow down the cause.



  • @crispyoz thank you again. What firmware version do you suggest? The most recent or the most stable?



  • @francisco-vieira for production devices always the most stable, I think 0.3.2 b233 is still the most current stable release, running oupgrade will show you.



  • @crispyoz thank you šŸ™‚


  • administrators

    @francisco-vieira Agree with @crispyoz it does look like the filesystem is corrupted on these units.

    A few questions for you:

    1. Do you have any external circuits or signals connected to the Omega's SPI pins?
    2. Do you have any programs running on the device that write to the filesystem on a regular basis?
    3. Could you give us an idea of what kind of environment these devices are operating in?


Looks like your connection to Community was lost, please wait while we try to reconnect.