We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Too long to load?

  • Hi I have a custom firmware built for omega but it takes too long to load I have specifically found the following between ip6 table and === pAd =, where it takes too long to load. Does anyone have any idea? I have noticed that on the onion binary it takes less than second to go through these. I would appreciate any help on thisCapture.PNG

  • @RandomPerson my approach would first to be determine if it is the ip6 module causing the delay, as it may be something else putting load on the device that is slowing down the loading of ip6 module.

    First remove the module script so the module doesn't get loaded.

    mv /etc/modules.d/42-ip6tables .

    Now reboot the device and see if that fixes your issue. If it does then the likely cause is the firewall rules. Remember to replace the script:

    mv 42-ip6tables /etc/modules.d

    If it doesn't fix the issue, look at the other modules in /etc/modules.d you'll see they generally have a sequence number in the name.

  • @crispyoz
    Thank you for your reply. I removed the module and it was still the same. I tried removing the wifi driver as in mt7628_init and it still did not load the module faster. Again, I need the wifi driver so it does not help my overall situation. Is there perhaps caching issue because some times it does load a lot faster like in onion. I once disabled the ra0 in config/wireless and restarted it loaded a lot faster a couple of times but I have not been able to replicated it ever since.


  • @RandomPerson Usually I would use console debugging, but module loading is not well reflected in this logging.

    Can you share your logs for the period in question? Use logread to see the logs.

    From this new description I'm not sure it is a module loading issue, have you tested your firmware on more than one device? Do you experience the same issue on the other device(s)?

  • @crispyoz
    Yes, I have tested on other devices, its still the same. I am sorry, I am new to linux. So, how do I use logread? or did you mean to see more of the log message.

  • @RandomPerson just type the command logread it will print the log on your display which will show all the messages that were printed during the boot process.

  • @crispyoz
    Hi, this here is my log read

  • @RandomPerson It seems to me that the module(s) loading after ip6_tables and before the mt7xxx module is where the delay is. So we need to determine which module is stalling. The modules get loaded in order based up the file name, so if you look in /etc/modules.d you can see the sequence prefix. My next step would be to move all the scripts that run between ip6-tables and the mt7 driver, so these are numbered 50 to 51. Try this:

    mkdir mods
    cd mods
    mv /etc/modules.d/51-* .
    mv /etc/modules.d/50-* .

    Now reboot and see if that resolves the issue. If not please post the directory listing of /etc/modules.d ( ls -l /etc/modules.d)

  • @crispyoz
    I am sorry, I will try to make my problem clearer to understand. Normally when the kernel finishes loading the modules,the ethernet is up and running (which I really need for this project). I removed all the modules one by one, got the module loading time faster but the ethernet loading time is literally the same.
    For example:
    module gets loaded at 95 seconds.
    ethernet is up and running.
    modules gets loaded at 45 seconds.
    ethernet is still not up till 95 seconds.

    Quite a few times I have noticed that module load faster, even with all the modules present. One certain period, I was able to replicate was when I disabled ra0 and restarted the system. Coincidentally I took out power and got same module loading time repeatedly and once I reboot, it went back to long loading time. This of course, I have not been able to replicate it since.

  • @RandomPerson What is your power source?

  • I use the USB to power. But I have not noticed any difference even by powering up through other way. Omega firmware loads faster so there must be something that I am missing right?

  • @RandomPerson I think it's time to get back to basics. You first need to determine if the issue is related to your customised firmware, or if it is a power issue.

    If you load standard Omega firmware, do experience this issue?
    Latest firmware is here: http://repo.onioniot.com/omega2/images/

  • @crispyoz
    No, I do not. Does it have something to do with block-mount? I believe pAd is partition disk?? And its partitioning or reading all blocks on each boot?

  • @RandomPerson if the standard software works ok and you have tried your firmware on more than one device and on each device your firmware causes this issue, then the question is what is unique about your custom firmware that is causing this issue.

    What changes have you made to the standard build? Have you made a change to the kernel version?

    Can you share your .config? from your build source root

  • @crispyoz
    Thank you for your reply. I did end up figuring out the problem. I connected to wifi and reboot it loaded a lot faster. Is there some sort of bug or is there something else that causes onion to load faster when wifi connection is present? I tried with a dummy wifi name and password, it was loading equally as fast.

  • @RandomPerson That's interesting, the boot logging shows the delay before the driver is loaded. I tried commenting out my wifi config and the boot time is no different.

  • @crispyoz
    Yeah, I find it weird too. Don't know the reason, will try to figure it out eventually. I will just work around it for now.

    Thank you for your time. I did not know about logread, which is being super helpful to me right now. So, thanks for that

  • @RandomPerson I still suspect this is power related, a lot of wierd stuff happens when there is insufficient current. When the wifi system starts there is a spike in current draw.

Looks like your connection to Community was lost, please wait while we try to reconnect.