We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

How to change omega onion pro 2 name

  • Hello,

    I am trying to change omega onion pro 2 SSID from Omega-XXXX to something else.

    I have tried the following three but did not work:

    [1] "uci set wireless.@wifi-iface[0].ssid=MyCoolOmega" , followed by the following two commands: "uci commit wireless" and "/etc/init.d/wireless restart"

    [2] Editing the SSID in "vi /etc/config/wireless" followed by "/etc/init.d/wireless restart"

    [3] wifisetup -ap edit -ssid MyOmega -password superimpossibleparkranger

    Is there another way or are these commands incorrect?

    Thank you!

  • @Antony

    uci set wireless.ap.ssid='MyCoolOmega'
    uci commit wireless
    service network restart

  • @crispyoz said in How to change omega onion pro 2 name:

    Thank you so much! This worked for me. Do you know of a way to change the IP address on the omega onion pro. It seems that all omega onion pro have a common IP address.

    Thanks again!

  • @Antony To change the ip address of the ap of your Omega2+ :

    uci set network.wlan.ipaddr='' <-------- whatever IP you wish to assign to your AP
    uci commit network
    service network restart

  • @crispyoz Thank you very much. Do you know if there are two levels to the SSID and passwords setting? Because even though the SSID and password has been changed (and is observed in the "seen" networks) when I attempt to connect the onion board via the terminal I have to use the manufactured SSID (Omega-XXXX) and password.

    Thanks again!

  • @Antony That is very weird, I have seen an old SSID still hanging around for a short time, but you can't connect to it. Please post the file contents of /etc/config/network and /etc/config/wireless

  • Yes, please see the images attached. It seems the hostname is not changing/updating to the new SSID. Thank you!

    Screen Shot 2022-08-23 at 12.58.45 PM.png Screen Shot 2022-08-23 at 1.05.54 PM.png

  • @Antony I think the issue is you have the sta disabled which will also disable the ap. Re-enable the sta and retest.

  • I enabled the sta and the file contents of /etc/config/network and /etc/config/wireless are the same as before.

    Is there a way to manually change the hostname? I tried different terminal commands with no success.

  • @Antony The hostname and the ssid are not the same, the ssid is the name of the wifi is set in the wireless config file, the host name is set in /etc/config/system and is the name by which the device itself is known. To check the name of the host you do as follows:

    uci show system.@system[0].hostname


    cat /proc/sys/kernel/hostname

    To set the host name you can use:

    uci set system.@system[0].hostname='MyNewHostName'
    uci commit system

    Once the device reboots the new host name will be used. It will not change the ssid of your ap wifi.

    Returning to your original issue. To re-enabled the sta, you would use the following commands:

    uci set wireless.sta.disabled='0'
    uci commit wireless
    service network restart

    Once you have reenabled the sta you may want to reboot because sometimes old ap ssid does not disappear and the new one may not immediately appear. Or you can just wait a few minutes and it will resolve itself.

  • Thank you so much for this clarification. This is very helpful.

    Can the "user" name "root" be changed?

    Thanks again!

  • @Antony Please create a new topic for the new question, it assists others in the future.

  • Will do!

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.