We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega 2S+ Image Size

  • Hi @crispyoz, I'm including below the steps followed to setup the build system and compile it. I started from scratch to make sure that the changes pushed by @Lazar-Demin were included in the build system.

    Note: I'm using a Linux System and not the Docker image.

    • create an onion folder, navigate into it and download the build system from github.
      mkdir onion
      cd onion
      git clone https://github.com/OnionIoT/source.git -b openwrt-18.06
      cd source
    • setup the onion feeds.
      sh scripts/onion-feed-setup.sh
      python scripts/onion-setup-build.py
    • update the image configuration. If I manually chose the packages and target (among other options), I run make menuconfig. However, I usually use an already generated .config file, which has a diff format.
      cp CustomConfig /home/user/onion/source/.config
      cd /home/user/onion/source
      make defconfig
    • finally, the image is built by running make -j4. If any error is raised, I re run the command with the following syntax to get more information about the error: make -j1 V=s

    These bullets summarize the steps followed to build the image. Let me know if there is any way I can share with you the config file.

    BTW, when selecting both the Omega2 Pro and the Omega2+ as the Target Devices, binary for Omega2+ is generated but not for the Omega2 Pro. As for the Omega2+, the binary size is 18 MB, and as for the Omega2 Pro, I get the warning message that the image is too big.

    Best regards,

  • @matiaslao You can paste the CustomConfig to https://paste.mozilla.org/

  • @crispyoz please find the CustomConfig in the following link. https://paste.mozilla.org/qrMwjsZR

    Best regards,

  • @matiaslao I built your firmware from scratch using your config file and it completed fine. Have you checked the updated is in place? It's in source/target/linux/ramips/dts/OMEGA2PRO.dts

  • @crispyoz good to know that it worked for you.

    I've checked the source/target/linux/ramips/dts/OMEGA2PRO.dts and it includes the latest modification pushed by @Lazar-Demin to the source repo.

    #include "OMEGA2.dtsi"
    / {
            model = "Onion Omega2 Pro";
            memory@0 {
                    device_type = "memory";
                    reg = <0x0 0x8000000>;
            new-leds {
                    compatible = "gpio-leds";
                    wifi {
                            label = "omega2pro:blue:wifi";
                            gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
    &firmware {
            reg = <0x50000 0x1f30000>;
    &system_led {
            label = "omega2pro:amber:system";
            gpios = <&gpio1 11 GPIO_ACTIVE_LOW>;
    &pinctrl {
            state_default: pinctrl0 {
                    uart2 {
                            ralink,group = "uart2";
                            ralink,function = "gpio";

    BTW, I'm sharing with you the content from source/bin/targets/ramips/mt76x8 directory. Does the Omega2+ image build has the same size than the one you built?

    user@ML-PC:~/onion/source/bin/targets/ramips/mt76x8$ ls -lh
    total 58M
     -rw-r--r-- 1 user user  12K Feb 22 10:45 config.seed
     -rw-r--r-- 1 user user  18M Feb 22 11:17 openwrt-ramips-mt76x8-omega2p-squashfs-sysupgrade.bin
     -rw-r--r-- 1 user user 7.3K Feb 22 11:17 openwrt-ramips-mt76x8.manifest
     -rw-r--r-- 1 user user  41M Feb 22 11:15 openwrt-toolchain-ramips-mt76x8_gcc-7.3.0_musl.Linux-x86_64.tar.bz2
     drwxr-xr-x 1 user user  512 Feb 22 11:18 packages
     -rw-r--r-- 1 user user  429 Feb 22 11:18 sha256sums

    Thanks for the support being provided.

    Best regards,

  • @matiaslao I think I have managed to duplicate your problem, it's not generating the openwrt-ramips-mt76x8-omega2pro-squashfs-sysupgrade.bin firmware. No error but I only have the issue when using your config. Don't have a lot of time right now but but will try to nail down the cause.

  • @crispyoz thanks for the update. You're correct. The make command does not return an error. However, after it finishes running openwrt-ramips-mt76x8-omega2p-squashfs-sysupgrade.bin is generated but not openwrt-ramips-mt76x8-omega2pro-squashfs-sysupgrade.bin.
    When looking into the make command output, the messages shown below are the only reference to the Omega2Pro image.

    WARNING: Image file /home/user/onion/source/build_dir/target-mipsel_24kc_musl/linux-ramips_mt76x8/tmp/openwrt-ramips-mt76x8-omega2pro-squashfs-sysupgrade.bin is too big
    cp /home/user/onion/source/build_dir/target-mipsel_24kc_musl/linux-ramips_mt76x8/tmp/openwrt-ramips-mt76x8-omega2pro-squashfs-sysupgrade.bin /home/user/onion/source/bin/targets/ramips/mt76x8/openwrt-ramips-mt76x8-omega2pro-squashfs-sysupgrade.bin
    cp: cannot stat '/home/user/onion/source/build_dir/target-mipsel_24kc_musl/linux-ramips_mt76x8/tmp/openwrt-ramips-mt76x8-omega2pro-squashfs-sysupgrade.bin': No such file or directory

    Please let me know if you have any new finding.

    Thanks in advance,

  • Hi @Lazar-Demin & @crispyoz, I was able to find the root cause for this issue. I've created a pull request in OnionIoT/source github repository with the fix.

  • administrators

    @matiaslao Good find! I've merged in the PR, thanks!

  • Good catch @matiaslao !

Looks like your connection to Community was lost, please wait while we try to reconnect.