We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega shipped with wrong firmware how to flash

    • I received an Omega with the testing firmware. The password is 5up....

    • I have an ethernet expansion.

    • I ran httpd and I can connect my browser to the Omega using but nothing happens

    • I looked around and found /usr/...www so I tried http -h /usr/,,,www but still no command to upload an image.


  • administrators

  • Yes. Everything is fine unto step 5 when i get press any key to interrupt the boot sequence and i get to the uboot i do not get "Omega>" prompt. This is because (as i stated) this is the "testing image" (as reported by others).

    As further proof: it asks me for a loggin : root with 5up (again as others reported)

    The help command doesnt list http demon.

    httpd does exist though and i tried launching it but it does not offer me to flash.

    Again, I am not the only one that experienced this -- please provide me with the procedure to get my Omega up - given that i have your test image.

  • administrators

    @Avi-Lior Ok, I will look into this today and get back to you!

  • administrators

    @Avi-Lior Can you please post a screenshot of what happens when you try to flash the image?

  • Here is the output. Looks exactly like another user (Andrew Donnely) whom you are helping. Note I already opened a ticket with help desk. (Ticket 1068).

    U-Boot 1.1.4 (Aug 28 2015 - 16:51:26)

    AP121 (ar9331) U-boot

    DRAM: 64 MB
    Top of RAM usable for U-Boot at: 84000000
    Reserving 140k for U-Boot at: 83fdc000
    Reserving 192k for malloc() at: 83fac000
    Reserving 44 Bytes for Board Info at: 83fabfd4
    Reserving 36 Bytes for Global Data at: 83fabfb0
    Reserving 128k for boot params() at: 83f8bfb0
    Stack Pointer at: 83f8bf98
    Now running in RAM - U-Boot at: 83fdc000
    Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
    flash size 16777216, sector count = 256
    Flash: 16 MB
    Using default environment

    In: serial
    Out: serial
    Err: serial
    Net: ag7240_enet_initialize...
    Fetching MAC Address from 0x83ff4068
    Fetching MAC Address from 0x83ff4068
    : cfg1 0x5 cfg2 0x7114
    eth0: 00:03:7f:11:40:00
    eth0 up
    : cfg1 0xf cfg2 0x7214
    eth1: 00:03:7f:11:40:01
    ATHRS26: resetting s26
    ATHRS26: s26 reset done
    eth1 up
    eth0, eth1
    Hit any key to stop autoboot: 0
    reset - Perform RESET of the CPU
    ? - alias for 'help'
    boot - boot default, i.e., run 'bootcmd'
    bootd - boot default, i.e., run 'bootcmd'
    bootm - boot application image from memory
    cp - memory copy
    erase - erase FLASH memory
    help - print online help
    md - memory display
    mm - memory modify (auto-incrementing)
    mtest - simple RAM test
    mw - memory write (fill)
    nm - memory modify (constant address)
    ping - send ICMP ECHO_REQUEST to network host
    printenv- print environment variables
    progmac - Set ethernet MAC addresses
    run - run commands in an environment variable
    setenv - set environment variables
    tftpboot- boot image via network using TFTP protocol
    version - print monitor version

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.