We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Did I destroy my Arduino Dock?

  • Today I used my Arduino Dock for the first time with an external power supply via the DC barrel jack (5V). Unfortunately after a very short time it became kinda hot and made strange noises - what brought me to cut it off power supply immediately.
    Since then it doesn't work anymore. When I connect it to mains, the small LED on the Arduino Dock flickers for like 1 sec before turning off. The attached Omega does absolutely nothing.

    Doe you have any idea how to debug this? Is this a case for the customer service?

  • I hope it not for you, that you made a onion BBQ šŸ˜‰

    Have a look on the guidelines linked on top:

    Hardware Issues
    If you are posting about a hardware issue with one of our boards, please include the following information:

    • A description of the issue and your setup
    • Photos of your setup, including the Omega plugged into power with the switch in the "ON" position.

    Power it just with the USB-Cable to avoid more damage.
    And yes, making a ticket with a link to this post will be a good idea.
    Just with all the info's they ask for, it is possible to give you a definitive answer.

  • administrators

    What were the voltage and current ratings of the external power supply?
    Does the Omega work in a different Dock?

  • @Lazar-Demin the power supply was 5.5V, 500mA. The Arduino does work correctly in the mini dock as well as the expansion dock. Seems like just the Arduino Dock is affected.

    @Luciano-S I could provide a picture of the Omega on the Arduino Dock as well later. But be assured that I do know how to use it normally and successfully had it running before (with USB power supply).
    My setup now is my Omega attached to the Arduino Dock which has a USB cable (connected to by PC) as power supply. Issue as described in my first post.

  • @Peter-Harrald
    I have had power issues with Arduinos in the past that had similar symptoms and were non-responsive; these were caused by shorted power and ground pins. In those cases I was able to save them by reflashing the firmware. Try that with the Onion Arduino firmware as in the Initial Setup guide and let us know how it goes.


  • @Gabriel-Ongpauco Thanks for your reply. Reflashing the Arduino Dock worked well (according to the console). Unfortunately the only difference after that is, that the LED on the Arduino Dock is flickering permanently now. The attached Omega is still not doing anything neither does the LED on the omega go on or something.
    I assume that the omega does not get (enough) power from the Arduino dock. Any ideas? šŸ™‚

    my setup

  • @Peter-Harrald said in Did I destroy my Arduino Dock?:

    I assume that the omega does not get (enough) power from the Arduino dock. Any ideas? šŸ™‚

    Did you try out other USB-cables?
    Also try to connect a USB connector direct on Mainboard if you use a Desktop computer with a front-controller. As longer and older the cables are, bigger is the possibility to get power loss.

Looks like your connection to Community was lost, please wait while we try to reconnect.