We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

"Signature check failed." /var/opkg-lists/chaos_calmer_packages.

  • Hi,

    I factory reset my Onion today and then tried to do a package update but now get:

    root@Omega-1081:~/web# date
    Sat Nov 14 00:55:19 GMT 2015
    root@Omega-1081:~/web# opkg update
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_base.
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/Packages.sig.
    Signature check passed.
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/packages/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_packages.
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/packages/Packages.sig.
    Signature check failed.
    Remove wrong Signature file.

    I don't think I am being a noob... can someone test if they have similar problems?

  • @None-None You are not alone šŸ˜ž While I have not done a factory reset on my Omega, I have just recently done on oupgrade to 0.0.4 b216 and get exactly the same message from opkg update šŸ˜ž

    Additionally, doing opkg list <package-name> and opkg install <package-name> for some packages known to be available from previous runs, now fail.

  • This problem exists because the firmware on the Omega are compiled by us here at Onion, so the signature generated during the compilation is different from the signature stored in the Opkg repo server. We will be launching our own repo servers in the coming weeks. For the time being, you just need to change your configuration to fix the issue:

    Open /etc/opkg.conf

    delete the line that reads option check_signature 1

    Try opkg update again and the problem should be fixed.

  • Thank you for the quick reply. I can confirm that the workaround has worked for me : )

  • Can confirm that this works for me too. Thanks šŸ™‚

  • Ufff... Problem solved šŸ‘

  • That saved my day.

  • @Boken-Lin I am getting 'Permission denied'

  • @Donald-Wright , you are looking in a one year old request! If you use Omega2 this will not be for you.

    Read this instaed:

Looks like your connection to Community was lost, please wait while we try to reconnect.