We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

[SOLVED]Question about building custom image



  • Hi,

    So I'm messing with LEDE trying to build a custom image. There are some packages that I need, like fast-gpio and wifisetup, or at least I would like to have them.

    I added the repo with OpenWRT packages from Onion to the feed list. Then I:

    scripts/feeds update -a && scripts/feeds install -a

    After that:

    make menuconfig

    Selected the wanted Onion packages and:

    make

    After quite a lot of time, got an error due to permission denied (Publickey) when reading from the repo. I have been looking at LEDE forums, also tried directly adding the ipk files but no idea how to make my custom build with those packages. Probably is a dumb question, but I'm really noob at that and have been searching without success.

    Thank you.

    Thank



  • @Iker said in Question about building custom image:

    After quite a lot of time, got an error due to permission denied (Publickey) when reading from the repo.

    You need to either have a github-account and add a public SSH-key for yourself there and configure it on your build-machine, or you can modify the Makefiles for the packages you want in the Onion-feed to use https://github.com instead of git@github.com



  • Thank you very much @WereCatf ! I didn't want to bother you at NTC with another DM about this and you ended answering here šŸ˜„ Everything worked, now I know how to build my image! Only one of the packages had the git@github and that one was making eveything fail.

    Fast-gpio and Omega2-ctrl working like charms. Wifisetup doesn't connect though, I'll check the script trying to find any missing dependence.

    Thank you.



  • @Iker maybe you can teach Onion how to get Fast-gpio working.



  • @Iker AFAIK wifisetup tries to use the proprietary wifi-driver, which obviously is missing from your image. I haven't touched the official firmware in a while now, but I think the wifi-interface was called ra0 instead of wlan0, and that may or may not be the cause of the issue. I really don't have any interest in wifisetup, so I have not given it a look.



  • @WereCatf yes it is ra0 and details can be seen with:

    cat /etc/config/wireless
    


  • @Costas-Costas said in Question about building custom image:

    @Iker maybe you can teach Onion how to get Fast-gpio working.

    I think, but I am a real noob, they need to have /dev/mem enabled. With that enabled, the package works.

    @WereCatf said in Question about building custom image:

    @Iker AFAIK wifisetup tries to use the proprietary wifi-driver, which obviously is missing from your image. I haven't touched the official firmware in a while now, but I think the wifi-interface was called ra0 instead of wlan0, and that may or may not be the cause of the issue. I really don't have any interest in wifisetup, so I have not given it a look.

    Thank you for the info! I'll try messing a little bit with the config file. It's great to be able to create custom firmwares.



  • @administrators can you please enable /dev/mem and rebuild the firmware to fix the broken Fast-gpio ?



  • @Costas-Costas said in [SOLVED]Question about building custom image:

    @administrators can you please enable /dev/mem and rebuild the firmware to fix the broken Fast-gpio ?

    I do 2nd that.



  • @Costas-Costas @Zogg-Baubas you can always build your LEDE based firmware. I know it's a pity not having a properly working firmware, but I am enjoying a lot building my own and I think it will be, once I learn more and find some useful packages, the way to go for me.

    I can explain you how to do it (credits to @WereCatf though, who explained it to me and is being great help).

    I have some problems now with WiFi, I am not able to configure in /etc/config/wireless but appart from that GPIOs are working perfectly. Once I get WiFi to work, the goal will be getting rid of any not needed stuff to get the lightest image possible.

    Cheers,

    Iker.



  • @Iker Its a no-go for me without working WiFi... It would be great if you'd share how to have preconfigured working wifi with LEDE.



  • @Zogg-Baubas The image-branch on my github-repo at https://github.com/WereCatf/source sets up a WiFi AP by default on first boot, look into the directory called "files" on how it sets that up. It's easy enough to set it up change it to instead connect to a local WiFi-network or whatever, if one wishes to.



  • Thank you @WereCatf !

    I'll try to have a look at it this week. If I'm able to enable WiFi I will stick to my image as GPIO's are working perfectly.



  • Excuse me for the double post, I add these lines to /etc/config/wireless

    config wifi-iface
        option device 'radio0'
        option network 'wwan'
        option mode 'sta'
        option ssid 'myssid'
        option encryption 'psk2'
        option key 'mykey'
        option disabled '0'
    

    Then I do wifi up and it''s not working. I can connect to the Omega2+ but not the other way round.

    Thank you.



  • @Iker You're only configuring how the wireless-device connects to the WiFi-network, but you're not configuring the network itself on the Omega2. Make sure you have the following in /etc/config/network:

    config interface 'wwan'
            option proto 'dhcp'
    

    And edit /etc/config/firewall:

    config zone
            option name 'lan'
            option input 'ACCEPT'
            option output 'ACCEPT'
            option forward 'ACCEPT'
            option network 'lan wwan'
    


  • Thank you @WereCatf

    Added the line to /etc/config/network

    Also edited /etc/config/firewall

    Restarted both network and firewall, not working. Rebooted, not working.



  • @Iker In /etc/config/wireless, do you have channel as auto? It needs to be specified, auto doesn't seem to work. It's a bug in the driver.



  • Edit: it's working!

    The last time was just the hotspot was not properly created. Thank you @WereCatf !

    In case anyone wants to try: http://www74.zippyshare.com/v/v8arpumN/file.html

    Both Omega2-ctrl and fast-gpio working. It's a bit heavy, I think, due to having nano installed (I prefer it to vi) I will update with how to config WiFi, even though it's explained along the topic.

    Just for the Omega2 plus!



  • @Iker Hi, I am looking into the same issue. I am not getting the Wifi up on the self built LEDE Firmware! Do you have the steps? I got all the settings configured as described in this post but seems to not getting anywhere.

    If I define "rao" and doing "wifi up" I get:
    ra0(ralink): Interface type not supported
    'radio0' is disabled
    ra0(ralink): Interface type not supported
    'radio0' is disabled

    If I change to "radio0" I get:
    'radio0' is disabled
    'radio0' is disabled

    But I am not sure I know if I do any of this right. Any help would be much appreciated!



  • Hi @michael-westberg let's see if we're able to make it work.

    First edit /etc/config/wireless. Don't change/delete anything, just add this

    config wifi-iface
        option device 'radio0'
        option network 'wwan'
        option mode 'sta'
        option ssid 'myssid'
        option encryption 'psk2'
        option key 'mykey'
        option disabled '0'
    

    Now be sure that you have this, or add it, to /etc/config/network:

    config interface 'wwan'
            option proto 'dhcp'
    

    Finally, add this to /etc/config/firewall:

    config zone
            option name 'lan'
            option input 'ACCEPT'
            option output 'ACCEPT'
            option forward 'ACCEPT'
            option network 'lan wwan'
    

Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.